summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-10-25 18:37:45 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-10-25 18:37:45 +0000
commit6d46bdecf892f106cf00155efc75c2b110dbbba9 (patch)
treea40c772cdc16a924bd2ecf244f588439d366ecf4 /sci-astronomy
parent* bug #148163 (diff)
downloadgentoo-2-6d46bdecf892f106cf00155efc75c2b110dbbba9.tar.gz
gentoo-2-6d46bdecf892f106cf00155efc75c2b110dbbba9.tar.bz2
gentoo-2-6d46bdecf892f106cf00155efc75c2b110dbbba9.zip
Version bump. Thanks to Sebastien Fabbro <seb@ist.utl.pt> for preparing the ebuild and patch in the sci-overlay.
(Portage version: 2.1.2_pre3-r7)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/orsa/ChangeLog9
-rw-r--r--sci-astronomy/orsa/files/digest-orsa-0.7.03
-rw-r--r--sci-astronomy/orsa/files/orsa-0.7.0-gcc41.patch60
-rw-r--r--sci-astronomy/orsa/orsa-0.7.0.ebuild63
4 files changed, 134 insertions, 1 deletions
diff --git a/sci-astronomy/orsa/ChangeLog b/sci-astronomy/orsa/ChangeLog
index 6603f36ff9f6..6a3f0b6b064e 100644
--- a/sci-astronomy/orsa/ChangeLog
+++ b/sci-astronomy/orsa/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-astronomy/orsa
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/orsa/ChangeLog,v 1.13 2006/10/25 16:01:19 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/orsa/ChangeLog,v 1.14 2006/10/25 18:37:45 markusle Exp $
+
+*orsa-0.7.0 (25 Oct 2006)
+
+ 25 Oct 2006; Markus Dittrich <markusle@gentoo.org>
+ +files/orsa-0.7.0-gcc41.patch, +orsa-0.7.0.ebuild:
+ Version bump. Thanks to Sebastien Fabbro <seb@ist.utl.pt>
+ for preparing the ebuild and patch in the sci-overlay.
25 Oct 2006; Markus Dittrich <markusle@gentoo.org>
+files/orsa-0.6.1-as-needed.patch, +files/orsa-0.6.1-gcc4.patch,
diff --git a/sci-astronomy/orsa/files/digest-orsa-0.7.0 b/sci-astronomy/orsa/files/digest-orsa-0.7.0
new file mode 100644
index 000000000000..c87caa6154b6
--- /dev/null
+++ b/sci-astronomy/orsa/files/digest-orsa-0.7.0
@@ -0,0 +1,3 @@
+MD5 16c86f3aa73920631f9768d8c70cce70 orsa-0.7.0.tar.gz 746444
+RMD160 12bdaebf4b5730535a07247da9ca992f72fa9fe5 orsa-0.7.0.tar.gz 746444
+SHA256 959abd0f9ed4311cf28a31d088b8afecd50674bd0d9a8360ac4a5c2752f22879 orsa-0.7.0.tar.gz 746444
diff --git a/sci-astronomy/orsa/files/orsa-0.7.0-gcc41.patch b/sci-astronomy/orsa/files/orsa-0.7.0-gcc41.patch
new file mode 100644
index 000000000000..df6e32295958
--- /dev/null
+++ b/sci-astronomy/orsa/files/orsa-0.7.0-gcc41.patch
@@ -0,0 +1,60 @@
+diff -Naur orsa-0.7.0/src/liborsa/orsa_body.h orsa-0.7.0.new/src/liborsa/orsa_body.h
+--- orsa-0.7.0/src/liborsa/orsa_body.h 2004-12-30 03:58:03.000000000 +0000
++++ orsa-0.7.0.new/src/liborsa/orsa_body.h 2006-06-01 16:27:02.000000000 +0100
+@@ -183,7 +183,7 @@
+ inline void SetVelocity(const double x, const double y, const double z) { Vector v(x,y,z); SetVelocity(v); }
+
+ // b position - this position
+- inline Vector Body::distanceVector(const Body & b) const { return b.position()-position(); }
++ inline Vector distanceVector(const Body & b) const { return b.position()-position(); }
+ inline double distance(const Body & b) const { return distanceVector(b).Length(); }
+
+ // alias
+diff -Naur orsa-0.7.0/src/libxorsa/xorsa_analysis.h orsa-0.7.0.new/src/libxorsa/xorsa_analysis.h
+--- orsa-0.7.0/src/libxorsa/xorsa_analysis.h 2004-06-25 01:58:30.000000000 +0100
++++ orsa-0.7.0.new/src/libxorsa/xorsa_analysis.h 2006-06-01 16:27:02.000000000 +0100
+@@ -129,7 +129,7 @@
+ XOrsaPeaksListItem(QListView *parent, QString label1, QString label2 = QString::null, QString label3 = QString::null, QString label4 = QString::null, QString label5 = QString::null, QString label6 = QString::null, QString label7 = QString::null, QString label8 = QString::null);
+
+ public:
+- int XOrsaPeaksListItem::compare(QListViewItem * i, int col, bool ascending) const;
++ int compare(QListViewItem * i, int col, bool ascending) const;
+
+ };
+
+diff -Naur orsa-0.7.0/src/libxorsa/xorsa_import_astorb_objects.h orsa-0.7.0.new/src/libxorsa/xorsa_import_astorb_objects.h
+--- orsa-0.7.0/src/libxorsa/xorsa_import_astorb_objects.h 2005-01-05 03:04:17.000000000 +0000
++++ orsa-0.7.0.new/src/libxorsa/xorsa_import_astorb_objects.h 2006-06-01 16:27:02.000000000 +0100
+@@ -600,7 +600,7 @@
+ inline XOrsaAstorbObjectItem(QListView *parent, QString label1, QString label2 = QString::null, QString label3 = QString::null, QString label4 = QString::null, QString label5 = QString::null, QString label6 = QString::null, QString label7 = QString::null, QString label8 = QString::null) : QListViewItem(parent, label1, label2, label3, label4, label5, label6, label7, label8) { };
+
+ public:
+- inline int XOrsaAstorbObjectItem::compare(QListViewItem *i, int col, bool ascending) const {
++ inline int compare(QListViewItem *i, int col, bool ascending) const {
+
+ using std::atof;
+
+diff -Naur orsa-0.7.0/src/libxorsa/xorsa_object_selector.cc orsa-0.7.0.new/src/libxorsa/xorsa_object_selector.cc
+--- orsa-0.7.0/src/libxorsa/xorsa_object_selector.cc 2004-06-25 04:12:57.000000000 +0100
++++ orsa-0.7.0.new/src/libxorsa/xorsa_object_selector.cc 2006-06-01 16:27:02.000000000 +0100
+@@ -40,7 +40,7 @@
+ XOrsaObjectItem(QListView *parent, QString label1, QString label2 = QString::null, QString label3 = QString::null, QString label4 = QString::null, QString label5 = QString::null, QString label6 = QString::null, QString label7 = QString::null, QString label8 = QString::null);
+
+ public:
+- int XOrsaObjectItem::compare(QListViewItem * i, int col, bool ascending) const;
++ int compare(QListViewItem * i, int col, bool ascending) const;
+
+ };
+
+diff -Naur orsa-0.7.0/src/orsa/xorsa.h orsa-0.7.0.new/src/orsa/xorsa.h
+--- orsa-0.7.0/src/orsa/xorsa.h 2004-07-13 03:21:19.000000000 +0100
++++ orsa-0.7.0.new/src/orsa/xorsa.h 2006-06-01 16:27:02.000000000 +0100
+@@ -62,7 +62,7 @@
+ ObjectItem(QListView *parent, QString label1, QString label2 = QString::null, QString label3 = QString::null, QString label4 = QString::null, QString label5 = QString::null, QString label6 = QString::null, QString label7 = QString::null, QString label8 = QString::null);
+
+ public:
+- int ObjectItem::compare(QListViewItem * i, int col, bool ascending) const;
++ int compare(QListViewItem * i, int col, bool ascending) const;
+
+ };
+
diff --git a/sci-astronomy/orsa/orsa-0.7.0.ebuild b/sci-astronomy/orsa/orsa-0.7.0.ebuild
new file mode 100644
index 000000000000..2b962c9800d9
--- /dev/null
+++ b/sci-astronomy/orsa/orsa-0.7.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/orsa/orsa-0.7.0.ebuild,v 1.1 2006/10/25 18:37:45 markusle Exp $
+
+inherit qt3 flag-o-matic
+
+DESCRIPTION="Celestial orbit reconstruction, simulation and analysis"
+HOMEPAGE="http://orsa.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="opengl qt3 mpi ginac cln gsl fftw xinerama threads static"
+
+DEPEND=">=sys-libs/readline-4.2
+ opengl? ( virtual/opengl )
+ fftw? ( =sci-libs/fftw-2.1* )
+ gsl? ( >=sci-libs/gsl-1.5 )
+ qt3? ( $(qt_min_version 3.3) )
+ mpi? ( sys-cluster/lam-mpi )
+ ginac? ( >=sci-mathematics/ginac-1.2.0 )
+ cln? ( >=sci-libs/cln-1.1.6 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+ epatch "${FILESDIR}"/${PN}-0.6.1-as-needed.patch
+}
+
+src_compile() {
+ local myconf=""
+ use mpi || export MPICXX="g++"
+ use ginac || myconf="--with-ginac-prefix=/no/such/file"
+ use gsl || myconf="${myconf} --with-gsl-prefix=/no/such/file"
+ use cln || myconf="${myconf} --with-cln-prefix=/no/such/file"
+ use fftw || sed -i -e 's/have_fftw=yes/have_fftw=no/' configure \
+ die "sed to fix fftw failed"
+ use qt3 || myconf="${myconf} --with-qt-dir=/no/such/file"
+ if use mpi; then
+ sed -e 's/\(orsa_LDADD = .*\)/\1 -llammpi++ -lmpi -llam -lpthread -lutil/' \
+ -i src/orsa/Makefile || die "sed to fix MPI failed"
+ fi
+
+ econf \
+ ${myconf} \
+ $(use_with mpi) \
+ $(use_with opengl gl) \
+ $(use_with threads) \
+ $(use_with xinerama) \
+ $(use_enable static) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS COPYRIGHT DEVELOPERS TODO THANKS
+ insinto /usr/share/${P}/test
+ doins src/test/*.{cc,h,fft,ggo} || die "Failed to install tests"
+}