summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-17 22:03:51 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-17 22:03:51 +0000
commit5de9612cd02c9412b9185fba86ce9a6552081ccb (patch)
tree0ebfd0d8119bddb7fdc4fc01a01afc7c9ed4f01c /sci-astronomy
parentDrop 'empty' dirs from kde 4.1.x (diff)
downloadgentoo-2-5de9612cd02c9412b9185fba86ce9a6552081ccb.tar.gz
gentoo-2-5de9612cd02c9412b9185fba86ce9a6552081ccb.tar.bz2
gentoo-2-5de9612cd02c9412b9185fba86ce9a6552081ccb.zip
Now propagate LDFLAGS, and merge fixes in patch
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/cdsclient/ChangeLog6
-rw-r--r--sci-astronomy/cdsclient/cdsclient-3.2.ebuild17
-rw-r--r--sci-astronomy/cdsclient/files/cdsclient-makefile.in.patch40
3 files changed, 49 insertions, 14 deletions
diff --git a/sci-astronomy/cdsclient/ChangeLog b/sci-astronomy/cdsclient/ChangeLog
index e3a36f369cb1..dfcc2504bde3 100644
--- a/sci-astronomy/cdsclient/ChangeLog
+++ b/sci-astronomy/cdsclient/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-astronomy/cdsclient
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cdsclient/ChangeLog,v 1.1 2009/02/17 20:47:22 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cdsclient/ChangeLog,v 1.2 2009/02/17 22:03:50 bicatali Exp $
+
+ 17 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/cdsclient-makefile.in.patch, cdsclient-3.2.ebuild:
+ Now propagate LDFLAGS, and merge fixes in patch
*cdsclient-3.2 (17 Feb 2009)
diff --git a/sci-astronomy/cdsclient/cdsclient-3.2.ebuild b/sci-astronomy/cdsclient/cdsclient-3.2.ebuild
index 7fbeef6667ba..e22d1729a92d 100644
--- a/sci-astronomy/cdsclient/cdsclient-3.2.ebuild
+++ b/sci-astronomy/cdsclient/cdsclient-3.2.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cdsclient/cdsclient-3.2.ebuild,v 1.1 2009/02/17 20:47:22 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cdsclient/cdsclient-3.2.ebuild,v 1.2 2009/02/17 22:03:50 bicatali Exp $
+EAPI=2
inherit eutils
DESCRIPTION="Collection of scripts to access the CDS databases"
@@ -14,24 +15,14 @@ IUSE=""
DEPEND=""
RDEPEND="app-shells/tcsh"
-src_unpack() {
- unpack ${A}
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-makefile.in.patch
# remove non standard "mantex" page
sed -i \
-e 's/aclient.tex//' \
"${S}"/configure || die "sed failed"
- # remove useless version file
- sed -i \
- -e 's/install_shs install_info/install_shs/' \
- "${S}"/Makefile.in || die "sed failed"
-}
-
-src_compile() {
- econf || die "econf failed"
- emake C_OPT="${CFLAGS}" STRIP=touch || die "emake failed"
}
-
src_install() {
dodir /usr/bin
dodir /usr/share/man
diff --git a/sci-astronomy/cdsclient/files/cdsclient-makefile.in.patch b/sci-astronomy/cdsclient/files/cdsclient-makefile.in.patch
new file mode 100644
index 000000000000..c0dd3e06f166
--- /dev/null
+++ b/sci-astronomy/cdsclient/files/cdsclient-makefile.in.patch
@@ -0,0 +1,40 @@
+--- Makefile.in.orig 2009-02-17 21:45:45.469037983 +0000
++++ Makefile.in 2009-02-17 22:01:42.960921967 +0000
+@@ -59,7 +59,6 @@
+ DEBUG =
+ C_OPT = -O
+ SYS =
+-CFLAGS = $(C_OPT) $(DEBUG) $(SYS) -I.
+
+ # FILES --------------------------------
+ VERFILE = $(PREFIX)/versions
+@@ -91,7 +90,7 @@
+ # RULES --------------------------------
+ .SUFFIXES: .o .c
+ .c.o:
+- $(CC) $(CFLAGS) -c $<
++ $(CC) $(CFLAGS) -I. -c $<
+
+ # DEPENDENCIES --------------------------------
+
+@@ -110,17 +109,15 @@
+ rm -f $$f; ln finducac2 $$f; done
+
+ aclient: aclient.o $(OBJ)
+- $(CC) $@.o $(OBJ) $(LIBSYS) -o $@
+- $(STRIP) $@
++ $(CC) $(LDFLAGS) $@.o $(OBJ) $(LIBSYS) -o $@
+
+ wwwget: wwwget.c
+- $(CC) wwwget.c $(LIBSYS) -o $@
+- $(STRIP) $@
++ $(CC) $(LDFLAGS) wwwget.c $(LIBSYS) -o $@
+
+ doc: sk.tex man.tex aclient.tex
+ latex man.tex
+
+-install: $(EXPORT_INSTALL) install_shs install_info
++install: $(EXPORT_INSTALL) install_shs
+ rm -rf *.cache
+
+ export_install: install_bin install_man