summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-03-11 20:59:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-03-11 20:59:46 +0000
commit20039cd20aef3dbdf1219634a576453d1ece9a21 (patch)
treea4ea44b88ec6833fe9223cb6b5fb7bd02eacf648 /sci-astronomy
parentHups dep was added to wrong package :P (diff)
downloadgentoo-2-20039cd20aef3dbdf1219634a576453d1ece9a21.tar.gz
gentoo-2-20039cd20aef3dbdf1219634a576453d1ece9a21.tar.bz2
gentoo-2-20039cd20aef3dbdf1219634a576453d1ece9a21.zip
version bump
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/stellarium/ChangeLog8
-rw-r--r--sci-astronomy/stellarium/stellarium-0.10.2.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/sci-astronomy/stellarium/ChangeLog b/sci-astronomy/stellarium/ChangeLog
index 010d6b662b57..ff84b27c612a 100644
--- a/sci-astronomy/stellarium/ChangeLog
+++ b/sci-astronomy/stellarium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/stellarium
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/ChangeLog,v 1.48 2009/02/20 18:08:04 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/ChangeLog,v 1.49 2009/03/11 20:59:46 mr_bones_ Exp $
+
+*stellarium-0.10.2 (11 Mar 2009)
+
+ 11 Mar 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +stellarium-0.10.2.ebuild:
+ version bump
20 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org>
stellarium-0.10.1.ebuild:
diff --git a/sci-astronomy/stellarium/stellarium-0.10.2.ebuild b/sci-astronomy/stellarium/stellarium-0.10.2.ebuild
new file mode 100644
index 000000000000..18d724b44cba
--- /dev/null
+++ b/sci-astronomy/stellarium/stellarium-0.10.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/stellarium-0.10.2.ebuild,v 1.1 2009/03/11 20:59:46 mr_bones_ Exp $
+
+EAPI=2
+inherit cmake-utils eutils
+
+DESCRIPTION="Stellarium renders 3D photo-realistic skies in real time."
+HOMEPAGE="http://www.stellarium.org/"
+SRC_URI="mirror://sourceforge/stellarium/${P}.tar.gz"
+
+LICENSE="GPL-2 BitstreamVera"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="nls"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libpng
+ media-libs/freetype:2
+ dev-libs/boost
+ media-libs/jpeg
+ || ( ( x11-libs/qt-core:4 x11-libs/qt-gui:4 x11-libs/qt-script:4 x11-libs/qt-opengl:4 ) >=x11-libs/qt-4.4.2:4[opengl] )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.7
+ nls? ( sys-devel/gettext )
+ x11-libs/libXt"
+
+src_configure() {
+ mycmakeargs=$(cmake-utils_use_enable nls NLS)
+ CMAKE_IN_SOURCE_BUILD=1 cmake-utils_src_configure
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newicon doc/images/stellarium-logo.png ${PN}.png
+ make_desktop_entry ${PN} Stellarium ${PN} "Education;Science;Astronomy;"
+ dodoc AUTHORS ChangeLog README
+}