summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-01-29 06:51:38 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-01-29 06:51:38 +0000
commit17d83851d30a57a562b6c4fcfe98e3d6a584b21a (patch)
treee6039c94fb5b7e6dcd2449577ef41c28efddae88 /sci-astronomy/wcstools
parentuse_with does not work but use_enable does (thanks to Alexander Miller, bug #... (diff)
downloadgentoo-2-17d83851d30a57a562b6c4fcfe98e3d6a584b21a.tar.gz
gentoo-2-17d83851d30a57a562b6c4fcfe98e3d6a584b21a.tar.bz2
gentoo-2-17d83851d30a57a562b6c4fcfe98e3d6a584b21a.zip
Version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/wcstools')
-rw-r--r--sci-astronomy/wcstools/ChangeLog10
-rw-r--r--sci-astronomy/wcstools/wcstools-3.8.1.ebuild52
2 files changed, 60 insertions, 2 deletions
diff --git a/sci-astronomy/wcstools/ChangeLog b/sci-astronomy/wcstools/ChangeLog
index 189c6b84dae3..40061fa11ed4 100644
--- a/sci-astronomy/wcstools/ChangeLog
+++ b/sci-astronomy/wcstools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/wcstools
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcstools/ChangeLog,v 1.16 2009/09/09 16:06:30 bicatali Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcstools/ChangeLog,v 1.17 2010/01/29 06:51:38 bicatali Exp $
+
+*wcstools-3.8.1 (29 Jan 2010)
+
+ 29 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +wcstools-3.8.1.ebuild:
+ Version bump
09 Sep 2009; Sébastien Fabbro <bicatali@gentoo.org>
wcstools-3.7.7.ebuild:
diff --git a/sci-astronomy/wcstools/wcstools-3.8.1.ebuild b/sci-astronomy/wcstools/wcstools-3.8.1.ebuild
new file mode 100644
index 000000000000..fe1698bf5877
--- /dev/null
+++ b/sci-astronomy/wcstools/wcstools-3.8.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcstools/wcstools-3.8.1.ebuild,v 1.1 2010/01/29 06:51:38 bicatali Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="World Coordinate System library for astronomical FITS images"
+HOMEPAGE="http://tdc-www.harvard.edu/software/wcstools"
+SRC_URI="http://tdc-www.harvard.edu/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.7-autotools.patch
+ # avoid colliding with fixdos, getdate and remap from other packages
+ sed -i \
+ -e 's/getdate/wcsgetdate/' \
+ -e 's/crlf/wcscrlf/' \
+ -e 's/remap/wcsremap/' \
+ wcstools Makefile.am || die
+ sed -i -e "s/3.7.x/${PV}/" "${S}"/configure.ac || die "sed failed"
+ eautoreconf
+}
+
+src_test() {
+ einfo "Testing various wcstools programs"
+ ./newfits -a 10 -j 248 41 -p 0.15 test.fits || die "test newfits failed"
+ ./sethead test.fits A=1 B=1 || die "test sethead failed"
+ [[ "$(./gethead test.fits RA)" == "16:32:00.000" ]] \
+ || die "test gethead failed"
+ rm -f test.fits
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doman Man/man1/* || die "doman failed"
+ dodoc Readme Programs NEWS libned/NED_client || die "dodoc failed"
+ newdoc libwcs/Readme Readme.libwcs || die "newdoc failed"
+ newdoc libwcs/NEWS NEWS.libwcs || die "newdoc failed"
+}
+
+pkg_postinst() {
+ elog "The following execs have been renamed to avoid colliding"
+ elog "with other packages:"
+ elog " getdate -> wcsgetdate"
+ elog " crlf -> wcscrlf"
+ elog " remap -> wcsremap"
+}