summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2009-09-16 04:20:56 +0000
committerMarkus Dittrich <markusle@gentoo.org>2009-09-16 04:20:56 +0000
commit8cff86bfc999ee9e7c91769e72c7a07967733511 (patch)
treef2bd5e2f28f779c110889b90f373ea37a79e5537 /sci-astronomy/skycat
parentstable on ppc64, bug #284971 (diff)
downloadgentoo-2-8cff86bfc999ee9e7c91769e72c7a07967733511.tar.gz
gentoo-2-8cff86bfc999ee9e7c91769e72c7a07967733511.tar.bz2
gentoo-2-8cff86bfc999ee9e7c91769e72c7a07967733511.zip
Fixed building with tk-8.5 and glibc-2.10 (fixes bug #283265).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/skycat')
-rw-r--r--sci-astronomy/skycat/ChangeLog9
-rw-r--r--sci-astronomy/skycat/files/skycat-3.0.2-glibc-2.10.patch12
-rw-r--r--sci-astronomy/skycat/files/skycat-3.0.2-tk8.5.patch21
-rw-r--r--sci-astronomy/skycat/skycat-3.0.2-r1.ebuild12
4 files changed, 50 insertions, 4 deletions
diff --git a/sci-astronomy/skycat/ChangeLog b/sci-astronomy/skycat/ChangeLog
index 6c95d80277a2..7c049bb87039 100644
--- a/sci-astronomy/skycat/ChangeLog
+++ b/sci-astronomy/skycat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/skycat
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/ChangeLog,v 1.4 2008/11/05 21:53:39 bicatali Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/ChangeLog,v 1.5 2009/09/16 04:20:56 markusle Exp $
+
+ 16 Sep 2009; Markus Dittrich <markusle@gentoo.org> skycat-3.0.2-r1.ebuild,
+ +files/skycat-3.0.2-glibc-2.10.patch, +files/skycat-3.0.2-tk8.5.patch:
+ Fixed building with tk-8.5 and glibc-2.10 (fixes bug #283265).
+ Thanks much to Kacper Kowalik for his patches.
*skycat-3.0.2-r1 (05 Nov 2008)
diff --git a/sci-astronomy/skycat/files/skycat-3.0.2-glibc-2.10.patch b/sci-astronomy/skycat/files/skycat-3.0.2-glibc-2.10.patch
new file mode 100644
index 000000000000..85cdf3479a42
--- /dev/null
+++ b/sci-astronomy/skycat/files/skycat-3.0.2-glibc-2.10.patch
@@ -0,0 +1,12 @@
+diff -Naur skycat-3.0.2/tclutil/generic/HTTP.C skycat-3.0.2.new/tclutil/generic/HTTP.C
+--- skycat-3.0.2/tclutil/generic/HTTP.C 2006-01-12 11:40:58.000000000 -0500
++++ skycat-3.0.2.new/tclutil/generic/HTTP.C 2009-09-16 00:13:30.000000000 -0400
+@@ -1108,7 +1108,7 @@
+ // host. Note need a copy of variable as strtok modifies it.
+ char *ptr = getenv( "http_noproxy" );
+ if ( ptr != NULL ) {
+- char *hostdomain = strchr(host, '.');
++ char *hostdomain = strchr(const_cast<char*>(host), '.');
+ if (hostdomain != NULL) {
+ hostdomain++;
+ // make a copy of the http_noproxy string for strtok
diff --git a/sci-astronomy/skycat/files/skycat-3.0.2-tk8.5.patch b/sci-astronomy/skycat/files/skycat-3.0.2-tk8.5.patch
new file mode 100644
index 000000000000..2cb325da853d
--- /dev/null
+++ b/sci-astronomy/skycat/files/skycat-3.0.2-tk8.5.patch
@@ -0,0 +1,21 @@
+--- skycat-3.0.2.orig/rtd/generic/RtdImage.C 2006-02-02 18:36:47.000000000 +0100
++++ skycat-3.0.2/rtd/generic/RtdImage.C 2009-09-15 09:23:44.505239756 +0200
+@@ -913,6 +913,9 @@
+ updateIdleTasks();
+ }
+
++#ifndef MODULE_SCOPE
++#define MODULE_SCOPE extern
++#endif
+
+ // Fix for Tk clipping coordinates to short range: See CanvasWindowCoordsNoClip() below.
+ #ifdef HAVE_TKCANVAS_H
+--- skycat-3.0.2.orig/skycat/skycat.in 2006-02-04 14:27:30.000000000 +0100
++++ skycat-3.0.2/skycat/skycat.in 2009-09-15 09:20:45.910857133 +0200
+@@ -54,5 +54,5 @@
+
+ test -d $HOME/.skycat || mkdir $HOME/.skycat
+ echo "`date`: Starting skycat with: $0 ${1+"$@"}" > $HOME/.skycat/log
+-exec wish8.4 $SKYCAT_BASE/lib/skycat@PACKAGE_VERSION@/main.tcl ${1+"$@"} | tee -a $HOME/.skycat/log 2>&1
++exec wish8.5 $SKYCAT_BASE/lib/skycat@PACKAGE_VERSION@/main.tcl ${1+"$@"} | tee -a $HOME/.skycat/log 2>&1
+
diff --git a/sci-astronomy/skycat/skycat-3.0.2-r1.ebuild b/sci-astronomy/skycat/skycat-3.0.2-r1.ebuild
index cf512ab56457..9d9c9a4070ac 100644
--- a/sci-astronomy/skycat/skycat-3.0.2-r1.ebuild
+++ b/sci-astronomy/skycat/skycat-3.0.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/skycat-3.0.2-r1.ebuild,v 1.1 2008/11/05 21:53:39 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/skycat-3.0.2-r1.ebuild,v 1.2 2009/09/16 04:20:56 markusle Exp $
inherit eutils autotools
@@ -13,6 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="threads"
+RDEPEND="${DEPEND}"
DEPEND="x11-libs/libXext
>=dev-tcltk/tclx-2.4
>=dev-tcltk/blt-2.4
@@ -27,6 +28,13 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-3.0.1-m4.patch
# fix old style headers, set as error by new g++
epatch "${FILESDIR}"/${PN}-3.0.1-gcc43.patch
+
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ # need fix for tk-8.5
+ if has_version ">=dev-lang/tk-8.5" ; then
+ epatch "${FILESDIR}"/${P}-tk8.5.patch
+ fi
+
eautoconf
}