summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-05-02 13:58:06 +0000
committerTorsten Veller <tove@gentoo.org>2012-05-02 13:58:06 +0000
commit46c1bae9ebba38b8bb031d0c8bed90aa20da36e0 (patch)
tree4fcf183c6bc274e39c23ce51f2c4e77cf6e9347c /perl-core
parent[bump] virtual/perl-Compress-Raw-Bzip2-2.52.0 (diff)
downloadgentoo-2-46c1bae9ebba38b8bb031d0c8bed90aa20da36e0.tar.gz
gentoo-2-46c1bae9ebba38b8bb031d0c8bed90aa20da36e0.tar.bz2
gentoo-2-46c1bae9ebba38b8bb031d0c8bed90aa20da36e0.zip
[bump] perl-core/Compress-Raw-Zlib-2.52.0
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/Compress-Raw-Zlib/ChangeLog8
-rw-r--r--perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.52.0.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/perl-core/Compress-Raw-Zlib/ChangeLog b/perl-core/Compress-Raw-Zlib/ChangeLog
index 6e5a37ac1725..bceaa5dc68d3 100644
--- a/perl-core/Compress-Raw-Zlib/ChangeLog
+++ b/perl-core/Compress-Raw-Zlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for perl-core/Compress-Raw-Zlib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/ChangeLog,v 1.46 2012/04/26 19:58:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/ChangeLog,v 1.47 2012/05/02 13:58:06 tove Exp $
+
+*Compress-Raw-Zlib-2.52.0 (02 May 2012)
+
+ 02 May 2012; Torsten Veller <tove@gentoo.org>
+ +Compress-Raw-Zlib-2.52.0.ebuild:
+ Version bump
26 Apr 2012; Alexis Ballier <aballier@gentoo.org>
Compress-Raw-Zlib-2.49.0.ebuild:
diff --git a/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.52.0.ebuild b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.52.0.ebuild
new file mode 100644
index 000000000000..53068838ae8c
--- /dev/null
+++ b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.52.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.52.0.ebuild,v 1.1 2012/05/02 13:58:06 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=PMQS
+MODULE_VERSION=2.052
+inherit multilib perl-module
+
+DESCRIPTION="Low-Level Interface to zlib compression library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=sys-libs/zlib-1.2.5"
+DEPEND="${RDEPEND}"
+# test? ( dev-perl/Test-Pod )"
+
+SRC_TEST=parallel
+
+src_prepare() {
+ rm -rf "${S}"/zlib-src/ || die
+ sed -i '/^zlib-src/d' "${S}"/MANIFEST || die
+ perl-module_src_prepare
+}
+
+src_configure() {
+ BUILD_ZLIB=False \
+ ZLIB_INCLUDE="${EPREFIX}"/usr/include \
+ ZLIB_LIB="${EPREFIX}"/usr/$(get_libdir) \
+ perl-module_src_configure
+}