summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2006-08-20 19:37:36 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2006-08-20 19:37:36 +0000
commitc8394457fd83600e7cf6d8a0132a876fea964415 (patch)
tree7ae548e61140a759b6faf31e67a0be4181d8d67a /net-zope
parent(fd.o #3914) Altix support breaks some sparc64 systems with Mach64 video, so ... (diff)
downloadgentoo-2-c8394457fd83600e7cf6d8a0132a876fea964415.tar.gz
gentoo-2-c8394457fd83600e7cf6d8a0132a876fea964415.tar.bz2
gentoo-2-c8394457fd83600e7cf6d8a0132a876fea964415.zip
version bump, fixes #141578
(Portage version: 2.1.1_pre5)
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zope/ChangeLog9
-rw-r--r--net-zope/zope/files/digest-zope-2.8.83
-rw-r--r--net-zope/zope/files/digest-zope-2.9.43
-rw-r--r--net-zope/zope/zope-2.8.8.ebuild109
-rw-r--r--net-zope/zope/zope-2.9.4.ebuild79
5 files changed, 202 insertions, 1 deletions
diff --git a/net-zope/zope/ChangeLog b/net-zope/zope/ChangeLog
index 162568bbd6c9..5e8cdf142b12 100644
--- a/net-zope/zope/ChangeLog
+++ b/net-zope/zope/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-zope/zope
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.103 2006/06/03 14:43:03 radek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.104 2006/08/20 19:37:36 radek Exp $
+
+*zope-2.9.4 (20 Aug 2006)
+*zope-2.8.8 (20 Aug 2006)
+
+ 20 Aug 2006; Radoslaw Stachowiak <radek@gentoo.org> +zope-2.8.8.ebuild,
+ +zope-2.9.4.ebuild:
+ version bump, fixes #141578
*zope-2.8.7 (03 Jun 2006)
diff --git a/net-zope/zope/files/digest-zope-2.8.8 b/net-zope/zope/files/digest-zope-2.8.8
new file mode 100644
index 000000000000..4537223f60da
--- /dev/null
+++ b/net-zope/zope/files/digest-zope-2.8.8
@@ -0,0 +1,3 @@
+MD5 6deaf23f8a77a1d6f0be43864cff9b54 Zope-2.8.8-final.tgz 5394023
+RMD160 e1f06d80f9b1943f32316086690b0eb015cf611a Zope-2.8.8-final.tgz 5394023
+SHA256 94a6ad1fe0fdc28c0ea5c3a501976b96b16a4110a3290a80e4897bd3f145c856 Zope-2.8.8-final.tgz 5394023
diff --git a/net-zope/zope/files/digest-zope-2.9.4 b/net-zope/zope/files/digest-zope-2.9.4
new file mode 100644
index 000000000000..f6a90e199ab4
--- /dev/null
+++ b/net-zope/zope/files/digest-zope-2.9.4
@@ -0,0 +1,3 @@
+MD5 7d7ffe62eabc84d0c438e450e344c29f Zope-2.9.4-final.tgz 6962298
+RMD160 297254e4ad0a27bdc585c88147a6e42698de485e Zope-2.9.4-final.tgz 6962298
+SHA256 4085dee8a6bd252072ca69f1c2d9e00cbff8d999651da93fd9df5a9db65dba35 Zope-2.9.4-final.tgz 6962298
diff --git a/net-zope/zope/zope-2.8.8.ebuild b/net-zope/zope/zope-2.8.8.ebuild
new file mode 100644
index 000000000000..3b8e7c11988e
--- /dev/null
+++ b/net-zope/zope/zope-2.8.8.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.8.8.ebuild,v 1.1 2006/08/20 19:37:36 radek Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites"
+HOMEPAGE="http://www.zope.org"
+SRC_URI="http://www.zope.org/Products/Zope/${PV}/Zope-${PV}-final.tgz"
+
+LICENSE="ZPL"
+SLOT="${PV}"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="unicode"
+
+RDEPEND="=dev-lang/python-2.3*"
+python='python2.3'
+
+DEPEND="${RDEPEND}
+virtual/libc
+>=sys-apps/sed-4.0.5"
+
+S="${WORKDIR}/Zope-${PV}-final"
+ZUID=zope
+ZGID=zope
+ZS_DIR=${ROOT%/}/usr/$(get_libdir)
+ZSERVDIR=${ZS_DIR}/${P}
+
+# Narrow the scope of ownership/permissions.
+# Security plan:
+# * ZUID is the superuser for all zope instances.
+# * ZGID is for a single instance's administration.
+# * Other' should not have any access to ${ZSERVDIR},
+# because they can work through the Zope web interface.
+# This should protect our code/data better.
+#
+# UPDATE: ${ZSERVDIR} is a lib directory and should be world readable
+# like e.g /usr/lib/python we do not store any user data there,
+# currently removed all custom permission stuff, for ${ZSERVDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ ./configure --ignore-largefile --prefix=. --with-python=/usr/bin/python2.3 || die "Failed to configure."
+ emake || die "Failed to compile."
+}
+
+src_install() {
+ dodoc README.txt
+ dodoc doc/*.txt
+ docinto PLATFORMS ; dodoc doc/PLATFORMS/*
+ docinto ZEO ; dodoc doc/ZEO/*
+
+ # Patched StructuredText will accept source text formatted in utf-8 encoding,
+ # apply all formattings and output utf-8 encoded text.
+ # if you want to use this option you need to set your
+ # system python encoding to utf-8 (create the file sitecustomize.py inside
+ # your site-packages, add the following lines
+ # import sys
+ # sys.setdefaultencoding('utf-8')
+ # If this is a problem, let me know right away. --batlogg@gentoo.org
+ # I wondering if we need a USE flag for this and wheter we can set the
+ # sys.encoding automtically
+ # so i defined a use flag
+
+ if use unicode; then
+ einfo "Patching structured text"
+ einfo "make sure you have set the system python encoding to utf-8"
+ einfo "create the file sitecustomize.py inside your site-packages"
+ einfo "import sys"
+ einfo "sys.setdefaultencoding('utf8')"
+ # stx i18n support borked. --batlogg@gentoo.org
+ ewarn "sorry, the Structured Text patch doesn't work yet for zope-2.8."
+ #cd ${S}/lib/python/StructuredText/
+ #epatch ${FILESDIR}/${PV}/i18n-1.0.0.patch
+ epause 15
+ cd ${S}
+ fi
+
+ make install PREFIX=${D}${ZSERVDIR}
+ rm -rf ${D}${ZSERVDIR}/doc
+ dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
+ # copy the init script skeleton to skel directory of our installation
+ skel=${D}${ZSERVDIR}/skel
+ # <radek@gentoo.org> from 2.7.4 release i think that we can use the same
+ # file for every one, and not separate it by PV
+ cp ${FILESDIR}/zope.initd ${skel}/zope.initd
+}
+
+pkg_postinst() {
+ # create the zope user and group for backward compatibility
+ enewgroup ${ZGID} 261
+ usermod -g ${ZGID} ${ZUID} 2>&1 >/dev/null || \
+ enewuser ${ZUID} 261 -1 /var/$(get_libdir)/zope ${ZGID}
+
+ einfo "Be warned that you need at least one zope instance to run zope."
+ einfo "Please emerge zope-config for futher instance management."
+}
+
+pkg_prerm() {
+
+ #need to remove this symlink because portage keeps links to
+ #existing targets
+
+ rm ${ZSERVDIR}/bin/python
+}
diff --git a/net-zope/zope/zope-2.9.4.ebuild b/net-zope/zope/zope-2.9.4.ebuild
new file mode 100644
index 000000000000..85f624e57cd0
--- /dev/null
+++ b/net-zope/zope/zope-2.9.4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.9.4.ebuild,v 1.1 2006/08/20 19:37:36 radek Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites"
+HOMEPAGE="http://www.zope.org"
+SRC_URI="http://www.zope.org/Products/Zope/${PV}/Zope-${PV}-final.tgz"
+
+LICENSE="ZPL"
+SLOT="${PV}"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/python-2.4*"
+
+DEPEND="${RDEPEND}
+virtual/libc
+>=sys-apps/sed-4.0.5"
+
+S="${WORKDIR}/Zope-${PV}-final"
+ZUID=zope
+ZGID=zope
+ZS_DIR=${ROOT%/}/usr/$(get_libdir)
+ZSERVDIR=${ZS_DIR}/${P}
+
+# Narrow the scope of ownership/permissions.
+# Security plan:
+# * ZUID is the superuser for all zope instances.
+# * ZGID is for a single instance's administration.
+# * Other' should not have any access to ${ZSERVDIR},
+# because they can work through the Zope web interface.
+# This should protect our code/data better.
+#
+# UPDATE: ${ZSERVDIR} is a lib directory and should be world readable
+# like e.g /usr/lib/python we do not store any user data there,
+# currently removed all custom permission stuff, for ${ZSERVDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ ./configure --prefix="${D}${ZSERVDIR}" --with-python=/usr/bin/python2.4 || die "Failed to execute ./configure ..."
+ emake || die "Failed to compile."
+}
+
+src_install() {
+ dodoc README.txt
+ dodoc Zope/doc/*.txt
+ docinto PLATFORMS ; dodoc Zope/doc/PLATFORMS/*
+ docinto ZEO ; dodoc Zope/doc/ZEO/*
+
+ make install prefix=${D}${ZSERVDIR} || die "Failed to install into ${D}${ZSERVDIR}"
+ rm -rf ${D}${ZSERVDIR}/doc
+ dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
+
+ # copy the init script skeleton to skel directory of our installation
+ cp ${FILESDIR}/zope.initd ${D}/${ZSERVDIR}/skel/zope.initd
+}
+
+pkg_postinst() {
+ # create the zope user and group for backward compatibility
+ enewgroup ${ZGID} 261
+ usermod -g ${ZGID} ${ZUID} 2>&1 >/dev/null || \
+ enewuser ${ZUID} 261 -1 /var/$(get_libdir)/zope ${ZGID}
+
+ einfo "Be warned that you need at least one zope instance to run zope."
+ einfo "Please emerge zope-config for futher instance management."
+}
+
+pkg_prerm() {
+
+ #need to remove this symlink because portage keeps links to
+ #existing targets
+ rm ${ZSERVDIR}/bin/python
+}