summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2006-08-27 16:59:37 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2006-08-27 16:59:37 +0000
commit43a4508b9ad7632120337fd2226c2f44bea72a9b (patch)
tree029894a17632fbbff6742cf34bf5389e44b9b4aa /net-zope
parentFixed a bug where jar-from getjar and getjars did not die when the package re... (diff)
downloadgentoo-2-43a4508b9ad7632120337fd2226c2f44bea72a9b.tar.gz
gentoo-2-43a4508b9ad7632120337fd2226c2f44bea72a9b.tar.bz2
gentoo-2-43a4508b9ad7632120337fd2226c2f44bea72a9b.zip
closes #141578 and #145081
(Portage version: 2.1.1_rc1)
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zope/ChangeLog10
-rw-r--r--net-zope/zope/files/2.9/zope-2.9.4_logerror.patch63
-rw-r--r--net-zope/zope/files/digest-zope-2.7.96
-rw-r--r--net-zope/zope/files/digest-zope-2.8.83
-rw-r--r--net-zope/zope/zope-2.7.9.ebuild111
-rw-r--r--net-zope/zope/zope-2.8.8.ebuild38
-rw-r--r--net-zope/zope/zope-2.9.4.ebuild6
7 files changed, 206 insertions, 31 deletions
diff --git a/net-zope/zope/ChangeLog b/net-zope/zope/ChangeLog
index 25c6afab8a33..9f273d117152 100644
--- a/net-zope/zope/ChangeLog
+++ b/net-zope/zope/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-zope/zope
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.105 2006/08/20 19:40:32 radek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.106 2006/08/27 16:59:37 radek Exp $
+
+*zope-2.7.9 (27 Aug 2006)
+
+ 27 Aug 2006; Radoslaw Stachowiak <radek@gentoo.org>
+ +files/2.9/zope-2.9.4_logerror.patch, +zope-2.7.9.ebuild,
+ zope-2.8.8.ebuild, zope-2.9.4.ebuild:
+ Fixed 2.9.4 w/o version bump, closes 145081, thanks to Chris Fletcher.
+ Released 2.7.9 (w/ version bump) and 2.8.8 (w/o version bump) to close #141578
20 Aug 2006; Radoslaw Stachowiak <radek@gentoo.org> -zope-2.8.3.ebuild,
-zope-2.9.0.ebuild, -zope-2.9.1.ebuild, -zope-3.2.0.ebuild:
diff --git a/net-zope/zope/files/2.9/zope-2.9.4_logerror.patch b/net-zope/zope/files/2.9/zope-2.9.4_logerror.patch
new file mode 100644
index 000000000000..b0c04eae745c
--- /dev/null
+++ b/net-zope/zope/files/2.9/zope-2.9.4_logerror.patch
@@ -0,0 +1,63 @@
+diff -Naur Zope-2.9.4-final-orig/lib/python/App/RefreshFuncs.py Zope-2.9.4-final/lib/python/App/RefreshFuncs.py
+--- Zope-2.9.4-final-orig/lib/python/App/RefreshFuncs.py 2006-07-20 05:31:19.000000000 +0000
++++ Zope-2.9.4-final/lib/python/App/RefreshFuncs.py 2006-08-25 11:15:28.000000000 +0000
+@@ -140,7 +140,7 @@
+ exc = sys.exc_info()
+ try:
+ logger.error('Exception while refreshing %s'
+- % productid, error=exc)
++ % productid, exc_info=exc)
+ if hasattr(exc[0], '__name__'):
+ error_type = exc[0].__name__
+ else:
+diff -Naur Zope-2.9.4-final-orig/lib/python/OFS/ObjectManager.py Zope-2.9.4-final/lib/python/OFS/ObjectManager.py
+--- Zope-2.9.4-final-orig/lib/python/OFS/ObjectManager.py 2006-07-20 05:31:20.000000000 +0000
++++ Zope-2.9.4-final/lib/python/OFS/ObjectManager.py 2006-08-25 11:15:42.000000000 +0000
+@@ -675,7 +675,7 @@
+ stat=marshal.loads(v.manage_FTPstat(REQUEST))
+ except:
+ logger.error("Failed to stat file '%s'" % k,
+- error=sys.exc_info())
++ exc_info=sys.exc_info())
+ stat=None
+ if stat is not None:
+ out=out+((k,stat),)
+diff -Naur Zope-2.9.4-final-orig/lib/python/Shared/DC/ZRDB/Connection.py Zope-2.9.4-final/lib/python/Shared/DC/ZRDB/Connection.py
+--- Zope-2.9.4-final-orig/lib/python/Shared/DC/ZRDB/Connection.py 2006-07-20 05:31:21.000000000 +0000
++++ Zope-2.9.4-final/lib/python/Shared/DC/ZRDB/Connection.py 2006-08-25 11:10:27.000000000 +0000
+@@ -71,7 +71,7 @@
+ try: self.connect(self.connection_string)
+ except:
+ logger.error('Error connecting to relational database.',
+- error=exc_info())
++ exc_info=exc_info())
+
+ def title_and_id(self):
+ s=Connection.inheritedAttribute('title_and_id')(self)
+@@ -151,7 +151,7 @@
+ self._v_database_connection.close()
+ except:
+ logger.error('Error closing relational database connection.',
+- error=exc_info())
++ exc_info=exc_info())
+ self._v_connected=''
+ if REQUEST is not None:
+ return self.manage_main(self, REQUEST)
+diff -Naur Zope-2.9.4-final-orig/lib/python/ZPublisher/BeforeTraverse.py Zope-2.9.4-final/lib/python/ZPublisher/BeforeTraverse.py
+--- Zope-2.9.4-final-orig/lib/python/ZPublisher/BeforeTraverse.py 2006-07-20 05:31:19.000000000 +0000
++++ Zope-2.9.4-final/lib/python/ZPublisher/BeforeTraverse.py 2006-08-25 11:14:32.000000000 +0000
+@@ -105,7 +105,7 @@
+ cob(container, request)
+ except TypeError:
+ self.logger.error('%s call %s failed.' % (
+- `self._hookname`, `cob`), error=sys.exc_info())
++ `self._hookname`, `cob`), exc_info=sys.exc_info())
+
+ def add(self, cob):
+ self._list.append(cob)
+@@ -153,4 +153,4 @@
+ # the programmer may want to raise them deliberately.
+ import sys
+ self.logger.error('Error while invoking hook: "%s"'
+- % self.name, error=sys.exc_info())
++ % self.name, exc_info=sys.exc_info())
diff --git a/net-zope/zope/files/digest-zope-2.7.9 b/net-zope/zope/files/digest-zope-2.7.9
new file mode 100644
index 000000000000..d5ea9544cae8
--- /dev/null
+++ b/net-zope/zope/files/digest-zope-2.7.9
@@ -0,0 +1,6 @@
+MD5 5cb921d15ff6d290bfc73bdc20ff67c1 Hotfix_20060821.tar.gz 1050
+RMD160 83479de3200711dd1cff306030f0181674862b51 Hotfix_20060821.tar.gz 1050
+SHA256 6ba5f717cc7443c6182c5b829f2a4228e7c56667d07e2b6fad8323ab1ec850af Hotfix_20060821.tar.gz 1050
+MD5 d44e19ca501f6629375f8f0b40c72e08 Zope-2.7.9-final.tgz 2993519
+RMD160 644e7e815945478b04d68af05beeccf428a82391 Zope-2.7.9-final.tgz 2993519
+SHA256 b3982421dded26e95c8a5a7272365224ba399d552a143a9d457509f11b9d94ab Zope-2.7.9-final.tgz 2993519
diff --git a/net-zope/zope/files/digest-zope-2.8.8 b/net-zope/zope/files/digest-zope-2.8.8
index 4537223f60da..020f0148322d 100644
--- a/net-zope/zope/files/digest-zope-2.8.8
+++ b/net-zope/zope/files/digest-zope-2.8.8
@@ -1,3 +1,6 @@
+MD5 5cb921d15ff6d290bfc73bdc20ff67c1 Hotfix_20060821.tar.gz 1050
+RMD160 83479de3200711dd1cff306030f0181674862b51 Hotfix_20060821.tar.gz 1050
+SHA256 6ba5f717cc7443c6182c5b829f2a4228e7c56667d07e2b6fad8323ab1ec850af Hotfix_20060821.tar.gz 1050
MD5 6deaf23f8a77a1d6f0be43864cff9b54 Zope-2.8.8-final.tgz 5394023
RMD160 e1f06d80f9b1943f32316086690b0eb015cf611a Zope-2.8.8-final.tgz 5394023
SHA256 94a6ad1fe0fdc28c0ea5c3a501976b96b16a4110a3290a80e4897bd3f145c856 Zope-2.8.8-final.tgz 5394023
diff --git a/net-zope/zope/zope-2.7.9.ebuild b/net-zope/zope/zope-2.7.9.ebuild
new file mode 100644
index 000000000000..a06d31493d2a
--- /dev/null
+++ b/net-zope/zope/zope-2.7.9.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.7.9.ebuild,v 1.1 2006/08/27 16:59:37 radek Exp $
+
+inherit eutils
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites"
+HOMEPAGE="http://www.zope.org"
+HOTFIXES_URI="http://www.zope.org/Products/Zope/Hotfix-2006-08-21/Hotfix-20060821/Hotfix_20060821.tar.gz"
+SRC_URI="http://www.zope.org/Products/Zope/Zope-${PV}/Zope-${PV}-final.tgz
+ ${HOTFIXES_URI}"
+
+LICENSE="ZPL"
+SLOT="${PV}"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="unicode"
+
+RDEPEND="=dev-lang/python-2.3*"
+python='python2.3'
+
+DEPEND="${RDEPEND}
+virtual/libc
+>=sys-apps/sed-4.0.5"
+
+S="${WORKDIR}/Zope-${PV}-final"
+ZUID=zope
+ZGID=zope
+ZS_DIR=${ROOT%/}/usr/lib
+ZSERVDIR=${ZS_DIR}/${P}
+
+# Narrow the scope of ownership/permissions.
+# Security plan:
+# * ZUID is the superuser for all zope instances.
+# * ZGID is for a single instance's administration.
+# * Other' should not have any access to ${ZSERVDIR},
+# because they can work through the Zope web interface.
+# This should protect our code/data better.
+#
+# UPDATE: ${ZSERVDIR} is a lib directory and should be world readable
+# like e.g /usr/lib/python we do not store any user data there,
+# currently removed all custom permission stuff, for ${ZSERVDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ ./configure --ignore-largefile --prefix=. --with-python=/usr/bin/python2.3 || die "Failed to configure."
+ emake || die "Failed to compile."
+}
+
+src_install() {
+ dodoc README.txt
+ dodoc doc/*.txt
+ docinto PLATFORMS ; dodoc doc/PLATFORMS/*
+
+ # Patched StructuredText will accept source text formatted in utf-8 encoding,
+ # apply all formattings and output utf-8 encoded text.
+ # if you want to use this option you need to set your
+ # system python encoding to utf-8 (create the file sitecustomize.py inside
+ # your site-packages, add the following lines
+ # import sys
+ # sys.setdefaultencoding('utf-8')
+ # If this is a problem, let me know right away. --batlogg@gentoo.org
+ # I wondering if we need a USE flag for this and wheter we can set the
+ # sys.encoding automtically
+ # so i defined a use flag
+
+ if use unicode; then
+ einfo "Patching structured text"
+ einfo "make sure you have set the system python encoding to utf-8"
+ einfo "create the file sitecustomize.py inside your site-packages"
+ einfo "import sys"
+ einfo "sys.setdefaultencoding('utf8')"
+ cd ${S}/lib/python/StructuredText/
+ epatch ${FILESDIR}/2.7.8/i18n-1.0.0.patch
+ epause 15
+ cd ${S}
+ fi
+
+ make install PREFIX=${D}${ZSERVDIR}
+ rm -rf ${D}${ZSERVDIR}/doc
+ dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
+ # copy the init script skeleton to skel directory of our installation
+ skel=${D}${ZSERVDIR}/skel
+ # <radek@gentoo.org> from 2.7.4 release i think that we can use the same
+ # file for every one, and not separate it by PV
+ cp ${FILESDIR}/zope.initd ${skel}/zope.initd
+
+ # hotfixes to be applied
+ cp -a ${WORKDIR}/Hotfix_20060821/ ${D}${ZSERVDIR}/lib/python/Products/
+}
+
+pkg_postinst() {
+ # create the zope user and group for backward compatibility
+ enewgroup ${ZGID} 261
+ usermod -g ${ZGID} ${ZUID} 2>&1 >/dev/null || \
+ enewuser ${ZUID} 261 -1 /var/lib/zope ${ZGID}
+
+ einfo "Be warned that you need at least one zope instance to run zope."
+ einfo "Please emerge zope-config for futher instance management."
+}
+
+pkg_prerm() {
+
+ #need to remove this symlink because portage keeps links to
+ #existing targets
+
+ rm ${ZSERVDIR}/bin/python
+}
diff --git a/net-zope/zope/zope-2.8.8.ebuild b/net-zope/zope/zope-2.8.8.ebuild
index 3b8e7c11988e..7438d6e858bf 100644
--- a/net-zope/zope/zope-2.8.8.ebuild
+++ b/net-zope/zope/zope-2.8.8.ebuild
@@ -1,17 +1,19 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.8.8.ebuild,v 1.1 2006/08/20 19:37:36 radek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.8.8.ebuild,v 1.2 2006/08/27 16:59:37 radek Exp $
inherit eutils multilib
DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites"
HOMEPAGE="http://www.zope.org"
-SRC_URI="http://www.zope.org/Products/Zope/${PV}/Zope-${PV}-final.tgz"
+HOTFIXES_URI="http://www.zope.org/Products/Zope/Hotfix-2006-08-21/Hotfix-20060821/Hotfix_20060821.tar.gz"
+SRC_URI="http://www.zope.org/Products/Zope/${PV}/Zope-${PV}-final.tgz
+ ${HOTFIXES_URI}"
LICENSE="ZPL"
SLOT="${PV}"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="unicode"
+IUSE=""
RDEPEND="=dev-lang/python-2.3*"
python='python2.3'
@@ -54,32 +56,6 @@ src_install() {
docinto PLATFORMS ; dodoc doc/PLATFORMS/*
docinto ZEO ; dodoc doc/ZEO/*
- # Patched StructuredText will accept source text formatted in utf-8 encoding,
- # apply all formattings and output utf-8 encoded text.
- # if you want to use this option you need to set your
- # system python encoding to utf-8 (create the file sitecustomize.py inside
- # your site-packages, add the following lines
- # import sys
- # sys.setdefaultencoding('utf-8')
- # If this is a problem, let me know right away. --batlogg@gentoo.org
- # I wondering if we need a USE flag for this and wheter we can set the
- # sys.encoding automtically
- # so i defined a use flag
-
- if use unicode; then
- einfo "Patching structured text"
- einfo "make sure you have set the system python encoding to utf-8"
- einfo "create the file sitecustomize.py inside your site-packages"
- einfo "import sys"
- einfo "sys.setdefaultencoding('utf8')"
- # stx i18n support borked. --batlogg@gentoo.org
- ewarn "sorry, the Structured Text patch doesn't work yet for zope-2.8."
- #cd ${S}/lib/python/StructuredText/
- #epatch ${FILESDIR}/${PV}/i18n-1.0.0.patch
- epause 15
- cd ${S}
- fi
-
make install PREFIX=${D}${ZSERVDIR}
rm -rf ${D}${ZSERVDIR}/doc
dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
@@ -88,6 +64,10 @@ src_install() {
# <radek@gentoo.org> from 2.7.4 release i think that we can use the same
# file for every one, and not separate it by PV
cp ${FILESDIR}/zope.initd ${skel}/zope.initd
+
+ # hotfixes to be applied
+ cp -a ${WORKDIR}/Hotfix_20060821/ ${D}${ZSERVDIR}/lib/python/Products/
+
}
pkg_postinst() {
diff --git a/net-zope/zope/zope-2.9.4.ebuild b/net-zope/zope/zope-2.9.4.ebuild
index 85f624e57cd0..e0eaaf0e7abe 100644
--- a/net-zope/zope/zope-2.9.4.ebuild
+++ b/net-zope/zope/zope-2.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.9.4.ebuild,v 1.1 2006/08/20 19:37:36 radek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.9.4.ebuild,v 1.2 2006/08/27 16:59:37 radek Exp $
inherit eutils multilib
@@ -59,6 +59,10 @@ src_install() {
# copy the init script skeleton to skel directory of our installation
cp ${FILESDIR}/zope.initd ${D}/${ZSERVDIR}/skel/zope.initd
+
+ epatch ${FILESDIR}/2.9/${P}_logerror.patch
+ pwd
+ sleep 15
}
pkg_postinst() {