summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2004-11-09 07:41:33 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2004-11-09 07:41:33 +0000
commit02fad0a7051dc2f537960ff366d80605800a4e60 (patch)
treeaadb755d99ae4e703fcd3f7c8f784ebbdd2664c8 /net-zope
parentsparc needs =media-libs/gst-plugins-0.8.1* first (Manifest recommit) (diff)
downloadgentoo-2-02fad0a7051dc2f537960ff366d80605800a4e60.tar.gz
gentoo-2-02fad0a7051dc2f537960ff366d80605800a4e60.tar.bz2
gentoo-2-02fad0a7051dc2f537960ff366d80605800a4e60.zip
new version release.
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/simpletal/ChangeLog8
-rw-r--r--net-zope/simpletal/Manifest2
-rw-r--r--net-zope/simpletal/files/digest-simpletal-3.111
-rw-r--r--net-zope/simpletal/simpletal-3.11.ebuild48
4 files changed, 58 insertions, 1 deletions
diff --git a/net-zope/simpletal/ChangeLog b/net-zope/simpletal/ChangeLog
index 1e9614e9d520..245882f8f2ca 100644
--- a/net-zope/simpletal/ChangeLog
+++ b/net-zope/simpletal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/simpletal
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/simpletal/ChangeLog,v 1.2 2004/06/25 01:25:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/simpletal/ChangeLog,v 1.3 2004/11/09 07:41:33 radek Exp $
+
+*simpletal-3.11 (09 Nov 2004)
+
+ 09 Nov 2004; Radoslaw Stachowiak <radek@gentoo.org>
+ +simpletal-3.11.ebuild:
+ New version release. Also added html documentation to ebuild.
12 May 2004; Jodok Batlogg <batlogg@gentoo.org>; :
initial import, user submitted ebuild, fixes #50278, thanks to Iain Smith
diff --git a/net-zope/simpletal/Manifest b/net-zope/simpletal/Manifest
index e071c0dd7578..2139b4fbcc94 100644
--- a/net-zope/simpletal/Manifest
+++ b/net-zope/simpletal/Manifest
@@ -1,4 +1,6 @@
MD5 12c3ee7d9a885f4755da3019b5cf9c67 simpletal-3.9.ebuild 1311
+MD5 12c3ee7d9a885f4755da3019b5cf9c67 simpletal-3.11.ebuild 1311
MD5 24773add1835519c4c4f4be56987d023 ChangeLog 364
MD5 7890d88c5c6d189fbe6b187a3ebb6532 metadata.xml 161
+MD5 8ab1c501fda1db4fbdaa3a452d1ad025 files/digest-simpletal-3.11 65
MD5 6087cc9e8740414f14c5d41646acc8ae files/digest-simpletal-3.9 64
diff --git a/net-zope/simpletal/files/digest-simpletal-3.11 b/net-zope/simpletal/files/digest-simpletal-3.11
new file mode 100644
index 000000000000..229be1663745
--- /dev/null
+++ b/net-zope/simpletal/files/digest-simpletal-3.11
@@ -0,0 +1 @@
+MD5 fe37ab089165625738a10736a573b0b3 SimpleTAL-3.11.tar.gz 84558
diff --git a/net-zope/simpletal/simpletal-3.11.ebuild b/net-zope/simpletal/simpletal-3.11.ebuild
new file mode 100644
index 000000000000..b40e9ddca876
--- /dev/null
+++ b/net-zope/simpletal/simpletal-3.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/simpletal/simpletal-3.11.ebuild,v 1.1 2004/11/09 07:41:33 radek Exp $
+
+IUSE=""
+
+MY_P=SimpleTAL
+
+inherit distutils
+
+DESCRIPTION="SimpleTAL is a stand alone Python implementation of the TAL, TALES and METAL specifications used in Zope to power HTML and XML templates."
+SRC_URI="http://www.owlfish.com/software/simpleTAL/downloads/${MY_P}-${PV}.tar.gz"
+HOMEPAGE="http://www.owlfish.com/software/simpleTAL/"
+DEPEND="virtual/python"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+S=${WORKDIR}/${MY_P}-${PV}
+
+src_compile() {
+ distutils_src_compile || die
+}
+
+src_install() {
+ distutils_src_install
+
+ dohtml documentation/html/*
+
+ docinto examples/basic
+ dodoc examples/basic/basic-example.py
+ dodoc examples/basic/basic.html
+
+ docinto examples/cgi-example
+ dodoc examples/cgi-example/simple-cgi.py
+ dodoc examples/cgi-example/fields.html
+ dodoc examples/cgi-example/results.html
+
+ docinto examples/metal-example
+ dodoc examples/metal-example/metal-example.py
+ dodoc examples/metal-example/macro.html
+ dodoc examples/metal-example/page.html
+
+ docinto examples/structure-example
+ dodoc examples/structure-example/structure-example.py
+ dodoc examples/structure-example/structure.html
+
+}