summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-27 17:51:59 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-27 17:51:59 +0000
commit544d07e6778807db50139aa0fc49c488775fc061 (patch)
tree652d3f516ffd201bbb3edb1db377d3fd73dd408a /net-zope/zope-security
parentDelete older ebuild. (diff)
downloadgentoo-2-544d07e6778807db50139aa0fc49c488775fc061.tar.gz
gentoo-2-544d07e6778807db50139aa0fc49c488775fc061.tar.bz2
gentoo-2-544d07e6778807db50139aa0fc49c488775fc061.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/zope-security')
-rw-r--r--net-zope/zope-security/ChangeLog8
-rw-r--r--net-zope/zope-security/zope-security-3.7.3.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/net-zope/zope-security/ChangeLog b/net-zope/zope-security/ChangeLog
index 23ea4de6e8ad..68ac39bd357b 100644
--- a/net-zope/zope-security/ChangeLog
+++ b/net-zope/zope-security/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/zope-security
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-security/ChangeLog,v 1.5 2010/02/14 19:17:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-security/ChangeLog,v 1.6 2010/05/27 17:51:59 arfrever Exp $
+
+*zope-security-3.7.3 (27 May 2010)
+
+ 27 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -zope-security-3.7.2.ebuild, +zope-security-3.7.3.ebuild:
+ Version bump.
14 Feb 2010; Raúl Porcel <armin76@gentoo.org> zope-security-3.7.2.ebuild:
Add ~alpha/~sparc wrt #297734
diff --git a/net-zope/zope-security/zope-security-3.7.3.ebuild b/net-zope/zope-security/zope-security-3.7.3.ebuild
new file mode 100644
index 000000000000..82e86d7aad99
--- /dev/null
+++ b/net-zope/zope-security/zope-security-3.7.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-security/zope-security-3.7.3.ebuild,v 1.1 2010/05/27 17:51:59 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope3 Security Framework"
+HOMEPAGE="http://pypi.python.org/pypi/zope.security"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pytz
+ dev-python/restrictedpython
+ net-zope/zope-component
+ net-zope/zope-configuration
+ net-zope/zope-exceptions
+ net-zope/zope-i18nmessageid
+ net-zope/zope-interface
+ net-zope/zope-location
+ net-zope/zope-proxy
+ net-zope/zope-schema"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="${PN/-//}"
+
+src_install() {
+ distutils_src_install
+ python_clean_installation_image
+}