summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-05-07 22:25:55 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-05-07 22:25:55 +0000
commitb26385801bc58d529b507dbf17d2f443311d4296 (patch)
treee2e451a15cfb931f843331f6408b1cc9c981ee1f /net-zope/plone
parentopenvas-server: don't delete include file (diff)
downloadgentoo-2-b26385801bc58d529b507dbf17d2f443311d4296.tar.gz
gentoo-2-b26385801bc58d529b507dbf17d2f443311d4296.tar.bz2
gentoo-2-b26385801bc58d529b507dbf17d2f443311d4296.zip
Version bump to 3.1.1 Fix bug #190435
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-zope/plone')
-rw-r--r--net-zope/plone/ChangeLog9
-rw-r--r--net-zope/plone/plone-3.1.1.ebuild91
2 files changed, 98 insertions, 2 deletions
diff --git a/net-zope/plone/ChangeLog b/net-zope/plone/ChangeLog
index 71d6b7a05c9d..1ef035365f12 100644
--- a/net-zope/plone/ChangeLog
+++ b/net-zope/plone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-zope/plone
-# Copyright 2003-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/plone/ChangeLog,v 1.47 2007/12/25 23:55:06 radek Exp $
+# Copyright 2003-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/plone/ChangeLog,v 1.48 2008/05/07 22:25:55 tupone Exp $
+
+*plone-3.1.1 (07 May 2008)
+
+ 07 May 2008; Tupone Alfredo <tupone@gentoo.org> +plone-3.1.1.ebuild:
+ Version bump to 3.1.1 Fix bug #190435 by Chris Slycord <cslycord@gmail.com>
25 Dec 2007; Radoslaw Stachowiak <radek@gentoo.org> -plone-2.5.ebuild,
-plone-2.5.3.ebuild:
diff --git a/net-zope/plone/plone-3.1.1.ebuild b/net-zope/plone/plone-3.1.1.ebuild
new file mode 100644
index 000000000000..c0f0069788dd
--- /dev/null
+++ b/net-zope/plone/plone-3.1.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/plone/plone-3.1.1.ebuild,v 1.1 2008/05/07 22:25:55 tupone Exp $
+
+inherit versionator zproduct
+
+MY_P="Plone-${PV}"
+DESCRIPTION="A Zope Content Management System, based on Zope CMF."
+HOMEPAGE="http://plone.org/"
+SRC_URI="https://launchpad.net/${PN}/$(get_version_component_range 1-2)/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="3.0"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+IUSE=""
+
+DEPEND="app-admin/zope-config"
+RDEPEND=">=dev-python/imaging-1.1.5
+ =net-zope/zope-2.10*
+ >=net-zope/zope-2.10.5
+ dev-python/elementtree
+ >=app-admin/zprod-manager-0.3.2"
+
+S="${WORKDIR}/${MY_P}"
+
+ZPROD_LIST="
+ Archetypes
+ ATContentTypes
+ ATReferenceBrowserWidget
+ AdvancedQuery
+ CMFActionIcons
+ CMFCalendar
+ CMFCore
+ CMFDefault
+ CMFDiffTool
+ CMFDynamicViewFTI
+ CMFEditions
+ CMFFormController
+ CMFPlacefulWorkflow
+ CMFPlone
+ CMFQuickInstallerTool
+ CMFTestCase
+ CMFTopic
+ CMFUid
+ DCWorkflow
+ ExtendedPathIndex
+ ExternalEditor
+ GenericSetup
+ GroupUserFolder
+ kupu
+ Marshall
+ MimetypesRegistry
+ NuPlone
+ PasswordResetTool
+ PlacelessTranslationService
+ PloneLanguageTool
+ PlonePAS
+ PloneTestCase
+ PloneTranslations
+ PluggableAuthService
+ PluginRegistry
+ PortalTransforms
+ ResourceRegistries
+ SecureMailHost
+ ZopeVersionControl
+ statusmessages
+ validation
+ "
+ZLPROD_LIST="
+ archetypes
+ borg
+ five
+ kss
+ plone
+ wicked
+ "
+DOT_ZLFOLDER_FPATH="${ZP_DIR}/${PF}/.zlfolder.lst"
+
+src_install() {
+ zproduct_src_install
+ for N in ${ZLPROD_LIST} ; do
+ echo ${N} >> "${D}"/${DOT_ZLFOLDER_FPATH}
+ done
+}
+
+pkg_postinst() {
+ elog "This plone version is a bundled version = contains all necessary zope products"
+ elog "You should carefully manage Your zope instance manually(!) with zprod-manager tool"
+ elog "If You have simple installation (just zope and plone) you can safely execute:"
+ elog "'zprod-manager add' and then mark ${P} to be added to your instance."
+}