summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-06 22:09:33 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-06 22:09:33 +0000
commit8e67a169f6457d1861da8d87dd66dfc7c638e135 (patch)
tree882d976508443535491758715a9f5f3e07163ffd /net-zope/five-formlib
parentDelete older ebuild. (diff)
downloadgentoo-2-8e67a169f6457d1861da8d87dd66dfc7c638e135.tar.gz
gentoo-2-8e67a169f6457d1861da8d87dd66dfc7c638e135.tar.bz2
gentoo-2-8e67a169f6457d1861da8d87dd66dfc7c638e135.zip
Version bump.
(Portage version: 2.2.0_alpha20/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/five-formlib')
-rw-r--r--net-zope/five-formlib/ChangeLog8
-rw-r--r--net-zope/five-formlib/five-formlib-1.0.4.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/net-zope/five-formlib/ChangeLog b/net-zope/five-formlib/ChangeLog
index 380bdfb9237c..56454b59a639 100644
--- a/net-zope/five-formlib/ChangeLog
+++ b/net-zope/five-formlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/five-formlib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/five-formlib/ChangeLog,v 1.6 2011/01/13 22:29:22 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/five-formlib/ChangeLog,v 1.7 2011/02/06 22:09:33 arfrever Exp $
+
+*five-formlib-1.0.4 (06 Feb 2011)
+
+ 06 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -five-formlib-1.0.3.ebuild, +five-formlib-1.0.4.ebuild:
+ Version bump.
13 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org>
five-formlib-1.0.3.ebuild:
diff --git a/net-zope/five-formlib/five-formlib-1.0.4.ebuild b/net-zope/five-formlib/five-formlib-1.0.4.ebuild
new file mode 100644
index 000000000000..e170bda0a272
--- /dev/null
+++ b/net-zope/five-formlib/five-formlib-1.0.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/five-formlib/five-formlib-1.0.4.ebuild,v 1.1 2011/02/06 22:09:33 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="zope.formlib integration for Zope 2"
+HOMEPAGE="http://pypi.python.org/pypi/five.formlib"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-zope/accesscontrol
+ net-zope/extensionclass
+ net-zope/transaction
+ net-zope/zope-app-form
+ net-zope/zope-browser
+ || ( net-zope/zope-browsermenu net-zope/zope-app-publisher )
+ net-zope/zope-component
+ net-zope/zope-event
+ net-zope/zope-formlib
+ net-zope/zope-i18nmessageid
+ net-zope/zope-interface
+ net-zope/zope-lifecycleevent
+ net-zope/zope-location
+ net-zope/zope-publisher
+ net-zope/zope-schema"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="${PN/-//}"