summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-01-28 19:02:33 +0000
committerChristian Heim <phreak@gentoo.org>2007-01-28 19:02:33 +0000
commit5cf9f239176ecf850a7473c8aad813d13478adee (patch)
treeea06957703633e226dee47e0fd92d85c7ab78b94 /net-www/mod_ftpd
parentbad maske on net-misc/tor (diff)
downloadgentoo-2-5cf9f239176ecf850a7473c8aad813d13478adee.tar.gz
gentoo-2-5cf9f239176ecf850a7473c8aad813d13478adee.tar.bz2
gentoo-2-5cf9f239176ecf850a7473c8aad813d13478adee.zip
Yet another version bump.
(Portage version: 2.1.2-r4)
Diffstat (limited to 'net-www/mod_ftpd')
-rw-r--r--net-www/mod_ftpd/ChangeLog7
-rw-r--r--net-www/mod_ftpd/files/digest-mod_ftpd-0.143
-rw-r--r--net-www/mod_ftpd/mod_ftpd-0.14.ebuild39
3 files changed, 48 insertions, 1 deletions
diff --git a/net-www/mod_ftpd/ChangeLog b/net-www/mod_ftpd/ChangeLog
index d78ecb5d4437..014567ce8282 100644
--- a/net-www/mod_ftpd/ChangeLog
+++ b/net-www/mod_ftpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mod_ftpd
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ftpd/ChangeLog,v 1.12 2007/01/25 20:49:50 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ftpd/ChangeLog,v 1.13 2007/01/28 19:02:33 phreak Exp $
+
+*mod_ftpd-0.14 (28 Jan 2007)
+
+ 28 Jan 2007; Christian Heim <phreak@gentoo.org> +mod_ftpd-0.14.ebuild:
+ Yet another version bump.
25 Jan 2007; Luca Longinotti <chtekk@gentoo.org> mod_ftpd-0.13.1.ebuild:
Cleanup.
diff --git a/net-www/mod_ftpd/files/digest-mod_ftpd-0.14 b/net-www/mod_ftpd/files/digest-mod_ftpd-0.14
new file mode 100644
index 000000000000..abbffcf0b729
--- /dev/null
+++ b/net-www/mod_ftpd/files/digest-mod_ftpd-0.14
@@ -0,0 +1,3 @@
+MD5 073532fb7837657cf52adecbb43a2f68 mod_ftpd-0.14.tar.bz2 330410
+RMD160 01823f02b2ae27952eef13946201e1ca9e55285c mod_ftpd-0.14.tar.bz2 330410
+SHA256 f36d3b65a5a200fca0c58e453246635e0f8e94c7f870d2b2f1946fa4a8b06d09 mod_ftpd-0.14.tar.bz2 330410
diff --git a/net-www/mod_ftpd/mod_ftpd-0.14.ebuild b/net-www/mod_ftpd/mod_ftpd-0.14.ebuild
new file mode 100644
index 000000000000..b5d6e552a0d2
--- /dev/null
+++ b/net-www/mod_ftpd/mod_ftpd-0.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ftpd/mod_ftpd-0.14.ebuild,v 1.1 2007/01/28 19:02:33 phreak Exp $
+
+inherit apache-module
+
+KEYWORDS="~ppc ~x86"
+
+DESCRIPTION="Apache2 module which provides an FTP server."
+HOMEPAGE="http://www.outoforder.cc/projects/apache/mod_ftpd/"
+SRC_URI="http://www.outoforder.cc/downloads/${PN}/${P}.tar.bz2"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="dbi gdbm"
+
+DEPEND="dbi? ( dev-db/libdbi )
+ gdbm? ( sys-libs/gdbm )"
+RDEPEND="${DEPEND}"
+
+APACHE2_EXECFILES="providers/*/.libs/*.so"
+APACHE2_MOD_CONF="45_${PN}"
+APACHE2_MOD_DEFINE="FTPD"
+
+DOCFILES="docs/manual.html AUTHORS ChangeLog NOTICE README TODO"
+
+need_apache2
+
+src_compile() {
+ local providers="default fail"
+
+ use dbi && providers="dbi ${providers}"
+ use gdbm && providers="dbm ${providers}"
+
+ econf \
+ --with-apxs=${APXS2} \
+ --enable-providers="${providers}" \
+ || die "econf failed"
+ emake || die "emake failed"
+}