summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-11-04 18:30:58 +0000
committerDonny Davies <woodchip@gentoo.org>2003-11-04 18:30:58 +0000
commit21144db71096ccf3c189ae94d631a531475d77a2 (patch)
tree3e1eda3775178875a50364ed9d167dce71dc194a /net-www/apache
parentFix #32361. (diff)
downloadgentoo-2-21144db71096ccf3c189ae94d631a531475d77a2.tar.gz
gentoo-2-21144db71096ccf3c189ae94d631a531475d77a2.tar.bz2
gentoo-2-21144db71096ccf3c189ae94d631a531475d77a2.zip
Fix #32361.
Diffstat (limited to 'net-www/apache')
-rw-r--r--net-www/apache/ChangeLog8
-rw-r--r--net-www/apache/Manifest6
-rw-r--r--net-www/apache/apache-1.3.29-r1.ebuild255
-rw-r--r--net-www/apache/apache-2.0.48-r1.ebuild347
-rw-r--r--net-www/apache/files/digest-apache-1.3.29-r13
-rw-r--r--net-www/apache/files/digest-apache-2.0.48-r11
6 files changed, 616 insertions, 4 deletions
diff --git a/net-www/apache/ChangeLog b/net-www/apache/ChangeLog
index 0f9b9a825da9..ab0ceb896a74 100644
--- a/net-www/apache/ChangeLog
+++ b/net-www/apache/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/apache
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.80 2003/11/02 14:06:26 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.81 2003/11/04 18:30:52 woodchip Exp $
+
+*apache-1.3.29-r1 (04 Nov 2003)
+
+ 04 Nov 2003; Donny Davies <woodchip@gentoo.org> apache-1.3.29-r1.ebuild,
+ apache-2.0.48-r1.ebuild:
+ Fix/close #32361.
*apache-1.3.29 (02 Nov 2003)
diff --git a/net-www/apache/Manifest b/net-www/apache/Manifest
index b6ec2acfedc2..6fc64f33e79c 100644
--- a/net-www/apache/Manifest
+++ b/net-www/apache/Manifest
@@ -2,9 +2,9 @@ MD5 bfe3bdf50a9328e0e90060cbbaf4b624 apache-2.0.48.ebuild 11153
MD5 246f3d374581e892615e2e5c8cb59e2a apache-1.3.27-r3.ebuild 7884
MD5 03c997dee35fcd0c56d77294ef557ab0 apache-2.0.47.ebuild 11434
MD5 18cb8436ab1b04381c78c9f9b5b6fc48 apache-1.3.29.ebuild 7503
-MD5 fe9e89e4f17994f9b47cf60665679b5d apache-1.3.29-r1.ebuild 7541
-MD5 862853bb99f9989ee23c580683b76951 apache-2.0.48-r1.ebuild 11158
-MD5 08ae2a21cc7922cb4767b69bf70f8788 ChangeLog 16022
+MD5 b120a9200fe6b38b82e23e27ece40a12 apache-1.3.29-r1.ebuild 7545
+MD5 5f8faff14c7d60f149d1a3a197636288 apache-2.0.48-r1.ebuild 11164
+MD5 eecda25cde9b59b655c823389874f2ae ChangeLog 16179
MD5 09fa626c00f029bdfb266b1e5d16193e apache-1.3.28-r1.ebuild 7905
MD5 bd80c41f0d8d92374c3712c4cac4d2ff metadata.xml 503
MD5 235d2261cabdf2fbf72bee4b0ddd519f apache-2.0.47-r1.ebuild 10711
diff --git a/net-www/apache/apache-1.3.29-r1.ebuild b/net-www/apache/apache-1.3.29-r1.ebuild
new file mode 100644
index 000000000000..d337d27a8e5e
--- /dev/null
+++ b/net-www/apache/apache-1.3.29-r1.ebuild
@@ -0,0 +1,255 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.29-r1.ebuild,v 1.1 2003/11/04 18:30:52 woodchip Exp $
+
+#IUSE="ipv6 pam"
+IUSE="pam"
+
+mod_ssl_ver=2.8.16
+
+S=${WORKDIR}/${PN}_${PV}
+DESCRIPTION="The Apache Web Server"
+HOMEPAGE="http://www.apache.org http://www.modssl.org"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~arm ~amd64"
+SRC_URI="http://httpd.apache.org/dist/httpd/apache_${PV}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2
+ ftp://ftp.modssl.org/source/mod_ssl-${mod_ssl_ver}-${PV}.tar.gz"
+# ipv6? http://motoyuki.bsdclub.org/data/IPv6/apache-${PV}-mod_ssl-${mod_ssl_ver}-v6-20021004.diff.gz"
+# The mod_ssl archive is only for providing the EAPI patch in here.
+# You should install the net-www/mod_ssl package for the actual DSO.
+
+DEPEND="dev-lang/perl <sys-libs/db-4.1
+ >=dev-libs/mm-1.1.3
+ >=sys-libs/gdbm-1.8
+ >=dev-libs/expat-1.95.2"
+LICENSE="Apache-1.1"
+SLOT="1"
+
+#Standard location for Gentoo Linux
+DATADIR="/var/www/localhost"
+
+src_unpack() {
+ local myssl
+ unpack ${A} || die
+ cd ${S} || die
+ patch -p1 <${WORKDIR}/${P}-gentoo.diff || die
+
+ #Obsolete 'head -1' and 'tail -1' calls.
+ perl -pi -e 's|tail -1|tail -n 1|;' \
+ src/Configure src/helpers/getuid.sh
+ perl -pi -e 's|head -1|head -n 1|;' \
+ src/Configure src/helpers/buildinfo.sh src/helpers/fmn.sh
+
+ #Make apachectl read /etc/conf.d/apache
+ patch -p1 <${FILESDIR}/apache-1.3.27-apachectl.patch || die
+
+ sed -i "s:/usr/local/bin/perl5:/usr/bin/perl:" \
+ htdocs/manual/search/manual-index.cgi
+
+ # setup eapi...
+ myssl=${WORKDIR}/mod_ssl-${mod_ssl_ver}-${PV}
+ cp ${myssl}/pkg.eapi/*.h src/include
+ cp ${myssl}/pkg.eapi/*.c src/ap
+ patch -p0 < ${myssl}/pkg.eapi/eapi.patch || die "eapi"
+
+ # set a reasonable MM_CORE_PATH location..
+ sed -i 's:logs/mm:/var/cache/apache-mm/mm:' \
+ src/include/httpd.h
+
+# # thanks drey@rt.mipt.ru for these two ...
+# if use ipv6; then
+# zcat ${DISTDIR}/apache-${PV}-mod_ssl-${mod_ssl_ver}-v6-20021004.diff.gz | patch -p0 || die
+# fi
+
+ if use pam; then
+ patch -p1 <${FILESDIR}/suexec_pam_gentoo.patch || die
+ fi
+
+ # Detect db4 correctly
+ patch -p1 <${FILESDIR}/apache-1.3.27_db4_gentoo.patch || die
+}
+
+src_compile() {
+ local myconf mycflags
+ mycflags="${CFLAGS}"
+ unset CFLAGS ; unset CXXFLAGS
+# use ipv6 && myconf="--enable-rule=INET6"
+
+ select_modules_config || die "determining modules"
+
+ #-DBUFFERED_LOGS
+ OPTIM="${mycflags} -DHARD_SERVER_LIMIT=${HARD_SERVER_LIMIT:=512} \
+ -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" \
+ LIBS="-lgdbm -lpthread" \
+ EAPI_MM=SYSTEM \
+ ./configure \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib/apache \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/apache/conf \
+ --datadir=${DATADIR} \
+ --cgidir=${DATADIR}/cgi-bin \
+ --iconsdir=${DATADIR}/icons \
+ --htdocsdir=${DATADIR}/htdocs \
+ --manualdir=/usr/share/doc/${PF}/manual \
+ --includedir=/usr/include/apache \
+ --localstatedir=/var \
+ --runtimedir=/var/run \
+ --logfiledir=/var/log/apache \
+ --proxycachedir=/var/cache/apache \
+ --serverroot=/etc/apache \
+ \
+ --target=apache \
+ --server-uid=apache \
+ --server-gid=apache \
+ --enable-rule=EAPI \
+ --enable-rule=SHARED_CHAIN \
+ --with-perl=/usr/bin/perl \
+ \
+ ${MY_BUILTINS} \
+ \
+ --enable-suexec \
+ --suexec-uidmin=1000 \
+ --suexec-gidmin=100 \
+ --suexec-caller=apache \
+ --suexec-userdir=public_html \
+ --suexec-docroot=/var/www \
+ --suexec-safepath="/bin:/usr/bin" \
+ --suexec-logfile=/var/log/apache/suexec_log \
+ \
+ ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ local myfile
+
+ GID=`getent group apache | cut -d: -f3`
+ if [ -z "${GID}" ]; then
+ einfo "Using default GID of 81 for Apache"
+ GID=81
+ fi
+
+ make install-quiet root=${D} || die
+ dodoc ABOUT_APACHE Announcement INSTALL* LICENSE* README* WARNING* \
+ ${FILESDIR}/robots.txt
+
+ #protect the suexec binary
+ fowners root.${GID} /usr/sbin/suexec
+ fperms 4710 /usr/sbin/suexec
+
+ # nice support scripts..
+ for myfile in apacheaddmod apachedelmod \
+ apachelogserverstatus apachesplitlogfile
+ do
+ exeinto /usr/sbin
+ doexe ${FILESDIR}/$myfile
+ done
+
+ # setup links in /etc/apache..
+ cd ${D}/etc/apache
+ ln -sf ../../usr/lib/apache modules
+ # apxs needs this to pickup the right lib for install..
+ ln -sf ../../usr/lib lib
+ ln -sf ../../var/log/apache logs
+ ln -sf ../../usr/lib/apache-extramodules extramodules
+
+ # drop in a convenient link to the manual
+ dosym /usr/share/doc/${PF}/manual ${DATADIR}/htdocs/manual
+
+ # deprecated config files, empty dirs..
+ rm -f ${D}/etc/apache/conf/apache.conf.default
+ rm -f ${D}/etc/apache/conf/access.conf*
+ rm -f ${D}/etc/apache/conf/srm.conf*
+
+ # now the config files..
+ insinto /etc/apache/conf
+ doins ${FILESDIR}/conf/commonapache.conf
+ doins ${FILESDIR}/conf/apache.conf
+
+ # Added by Jason Wever <weeve@gentoo.org>
+ # A little sedfu to fix bug #7172 for sparc64s
+ if [ ${ARCH} = "sparc" ]
+ then
+ sed -i -e '15a\AcceptMutex fcntl' \
+ ${D}/etc/apache/conf/apache.conf
+ fi
+
+ insinto /etc/apache/conf/vhosts
+ doins ${FILESDIR}/conf/VirtualHomePages.conf
+ doins ${FILESDIR}/conf/DynamicVhosts.conf
+ doins ${FILESDIR}/conf/Vhosts.conf
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/apache.rc6 apache
+ insinto /etc/conf.d ; newins ${FILESDIR}/apache.confd apache
+ insinto /etc/apache ; doins ${FILESDIR}/apache-builtin-mods
+
+ if use pam; then
+ insinto /etc/pam.d ; newins ${FILESDIR}/suexec.pam suexec
+ fi
+
+ #empty dirs
+ dodir /var/cache/apache ; touch ${D}/var/cache/apache/.keep
+ dodir /var/cache/apache-mm ; touch ${D}/var/cache/apache-mm/.keep
+ dodir /usr/lib/apache-extramodules ; touch ${D}/usr/lib/apache-extramodules/.keep
+ dodir /etc/apache/conf/addon-modules ; touch ${D}/etc/apache/conf/addon-modules/.keep
+ dodir /var/log/apache ; touch ${D}/var/log/apache/.keep
+}
+
+pkg_postinst() {
+ # these are in baselayout now; it will not hurt to leave them here though
+ # moved to pkg_postinst by jnelson, moved to pkg_preinst by lostlogic
+ getent group apache >/dev/null 2>&1
+ if [ $? -ne 0 ]; then
+ groupadd -g 81 apache || die "problem adding group apache"
+ fi
+
+ # usermod returns 2 on user-exists-but-no-flags-given
+ #usermod apache &>/dev/null
+ #if [ $? != 2 ]; then
+ getent passwd apache >/dev/null 2>&1
+ if [ $? -ne 0 ]; then
+ useradd -u 81 -g apache -s /bin/false -d /var/www/localhost -c "apache" apache
+ assert "problem adding user apache"
+ fi
+
+ einfo
+ einfo "Please remember to update your config files in /etc/apache"
+ einfo "as --datadir has been changed to ${DATADIR}!"
+ einfo
+}
+
+parse_modules_config() {
+ local filename=$1
+ local name=""
+ local dso=""
+ local disable=""
+ [ -f ${filename} ] || return 1
+ einfo "Using ${filename} for builtins."
+ for i in `cat $filename | sed "s/^#.*//"` ; do
+ if [ $i == "-" ] ; then
+ disable="true"
+ elif [ -z "$name" ] && [ ! -z "`echo $i | grep "mod_"`" ] ; then
+ name=`echo $i | sed "s/mod_//"`
+ elif [ "$disable" ] && ( [ $i == "static" ] || [ $i == "shared" ] ) ; then
+ MY_BUILTINS="${MY_BUILTINS} --disable-module=$name"
+ name="" ; disable=""
+ elif [ $i == "static" ] ; then
+ MY_BUILTINS="${MY_BUILTINS} --enable-module=$name --disable-shared=$name"
+ name="" ; disable=""
+ elif [ $i == "shared" ] ; then
+ MY_BUILTINS="${MY_BUILTINS} --enable-module=$name --enable-shared=$name"
+ name="" ; disable=""
+ fi
+ done
+}
+
+select_modules_config() {
+ parse_modules_config /etc/apache/apache-builtin-mods || \
+ parse_modules_config ${FILESDIR}/apache-builtin-mods || \
+ return 1
+}
diff --git a/net-www/apache/apache-2.0.48-r1.ebuild b/net-www/apache/apache-2.0.48-r1.ebuild
new file mode 100644
index 000000000000..cdda3ce7d073
--- /dev/null
+++ b/net-www/apache/apache-2.0.48-r1.ebuild
@@ -0,0 +1,347 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.48-r1.ebuild,v 1.1 2003/11/04 18:30:52 woodchip Exp $
+
+inherit flag-o-matic
+has_version =sys-libs/glibc-2.2* && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+
+DESCRIPTION="Apache Web Server, Version 2.0.x"
+HOMEPAGE="http://www.apache.org/"
+
+S="${WORKDIR}/httpd-${PV}"
+SRC_URI="http://www.apache.org/dist/httpd/httpd-${PV}.tar.gz"
+KEYWORDS="x86 ~ppc ~alpha ~hppa ~mips sparc ~amd64"
+LICENSE="Apache-1.1"
+SLOT="2"
+
+#Standard location for Gentoo Linux
+DATADIR="/var/www/localhost"
+
+DEPEND="dev-util/yacc
+ dev-lang/perl
+ sys-libs/zlib
+ dev-libs/expat
+ dev-libs/openssl
+ berkdb? sys-libs/db
+ gdbm? sys-libs/gdbm
+ ldap? =net-nds/openldap-2*"
+IUSE="berkdb gdbm ldap"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ patch -p1 <${FILESDIR}/apache-2.0.48-gentoo.diff || die
+
+ #avoid utf-8 charset problems
+ export LC_CTYPE=C
+
+ #the -1 shortcut is obsolete
+ perl -pi -e 's|head -1|head -n 1|;' srclib/apr/build/buildcheck.sh
+
+ #give it the stamp
+ perl -pi -e 's|" PLATFORM "|Gentoo/Linux|;' server/core.c
+ #fix perl with perl!
+ find -type f | xargs perl -pi -e \
+ "s|/usr/local/bin/perl|/usr/bin/perl|g; \
+ s|/usr/local/bin/perl5|/usr/bin/perl|g; \
+ s|/path/to/bin/perl|/usr/bin/perl|g;"
+ #dont want this cruft in /usr/bin
+ perl -pi -e 's|\@exp_bindir\@(/envvars)|\@exp_installbuilddir\@\1|;' \
+ support/apachectl.in
+
+ #setup the filesystem layout config
+ local prefix=/usr
+ cat >>config.layout <<-EOF
+ <Layout Gentoo>
+ prefix: ${prefix}
+ exec_prefix: ${prefix}
+ bindir: ${prefix}/bin
+ sbindir: ${prefix}/sbin
+ libdir: ${prefix}/lib
+ libexecdir: ${prefix}/lib/apache2
+ mandir: ${prefix}/share/man
+ infodir: ${prefix}/share/info
+ includedir: ${prefix}/include/apache2
+ installbuilddir: ${prefix}/lib/apache2/build
+ datadir: ${DATADIR}
+ errordir: ${DATADIR}/error
+ iconsdir: ${DATADIR}/icons
+ htdocsdir: ${DATADIR}/htdocs
+ cgidir: ${DATADIR}/cgi-bin
+ manualdir: /usr/share/doc/${PF}/manual
+ sysconfdir: /etc/apache2/conf
+ localstatedir: /var
+ runtimedir: /var/run
+ logfiledir: /var/log/apache2
+ proxycachedir: /var/cache/apache2
+ </Layout>
+ EOF
+
+ #gotta do these next two as well :\
+ cat >>srclib/apr/config.layout <<-EOF
+ <Layout Gentoo>
+ prefix: ${prefix}
+ exec_prefix: ${prefix}
+ bindir: ${prefix}/bin
+ sbindir: ${prefix}/sbin
+ libdir: ${prefix}/lib
+ libexecdir: ${prefix}/lib/apache2
+ mandir: ${prefix}/share/man
+ sysconfdir: /etc/apache2/conf
+ datadir: ${DATADIR}
+ installbuilddir: ${prefix}/lib/apache2/build
+ includedir: ${prefix}/include/apache2
+ localstatedir: /var
+ libsuffix: -\${APR_MAJOR_VERSION}
+ </Layout>
+ EOF
+
+ cat >>srclib/apr-util/config.layout <<-EOF
+ <Layout Gentoo>
+ prefix: ${prefix}
+ exec_prefix: ${prefix}
+ bindir: ${prefix}/bin
+ sbindir: ${prefix}/sbin
+ libdir: ${prefix}/lib
+ libexecdir: ${prefix}/lib/apache2
+ mandir: ${prefix}/share/man
+ sysconfdir: /etc/apache2/conf
+ datadir: ${DATADIR}
+ installbuilddir: ${prefix}/lib/apache2/build
+ includedir: ${prefix}/include/apache2
+ localstatedir: /var
+ libsuffix: -\${APRUTIL_MAJOR_VERSION}
+ </Layout>
+ EOF
+
+ ./buildconf || die "buildconf failed"
+}
+
+src_compile() {
+ local myconf
+ use ldap && \
+ myconf="--with-ldap --enable-auth-ldap=shared --enable-ldap=shared"
+
+ select_modules_config || die "determining modules"
+
+ # Fix for bug #24215 - robbat2@gentoo.org, 30 Oct 2003
+ # We pre-load the cache with the correct answer! This avoids
+ # it violating the sandbox. This may have to be changed for
+ # non-Linux systems or if sem_open changes on Linux. This
+ # hack is built around documentation in /usr/include/semaphore.h
+ # and the glibc (pthread) source
+ echo 'ac_cv_func_sem_open=${ac_cv_func_sem_open=no}' >> ${S}/config.cache
+
+ SSL_BASE="SYSTEM" \
+ ./configure \
+ --with-suexec-safepath="/usr/local/bin:/usr/bin:/bin" \
+ --with-suexec-logfile=/var/log/apache2/suexec_log \
+ --with-suexec-bin=/usr/sbin/suexec2 \
+ --with-suexec-userdir=public_html \
+ --with-suexec-caller=apache \
+ --with-suexec-docroot=/var/www \
+ --with-suexec-uidmin=1000 \
+ --with-suexec-gidmin=100 \
+ --with-suexec-umask=077 \
+ --enable-suexec=shared \
+ \
+ ${MY_BUILTINS} \
+ \
+ --cache-file=${S}/config.cache \
+ --with-perl=/usr/bin/perl \
+ --with-expat=/usr \
+ --with-ssl=/usr \
+ --with-z=/usr \
+ --with-port=80 \
+ --with-mpm=${MPM:=prefork} \
+ --enable-layout=Gentoo \
+ --with-program-name=apache2 \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+ #--with-mpm={worker|prefork|perchild|leader|threadpool}
+
+ emake || die "problem compiling Apache2 :("
+
+ #build ssl version of apache bench (ab-ssl)
+ cd support; rm -f ab .libs/ab ab.lo ab.o
+ make ab CFLAGS="${CFLAGS} -DUSE_SSL -lcrypto -lssl \
+ -I/usr/include/openssl -L/usr/lib" || die
+ mv ab ab-ssl; mv .libs/ab .libs/ab-ssl; rm -f ab.lo ab.o
+ make ab || die
+}
+
+src_install () {
+ local i
+ make DESTDIR=${D} install || die
+ dodoc ABOUT_APACHE CHANGES INSTALL LAYOUT \
+ LICENSE README* ${FILESDIR}/robots.txt
+
+ #bogus values pointing at /var/tmp/portage
+ perl -pi -e "s/(APR_SOURCE_DIR=).*/\1\"\"/" ${D}/usr/bin/apr-config
+ perl -pi -e "s/(APU_SOURCE_DIR=).*/\1\"\"/" ${D}/usr/bin/apu-config
+ perl -pi -e "s/(APU_BUILD_DIR=).*/\1\"\"/" ${D}/usr/bin/apu-config
+
+ #protect the suexec binary
+ local gid=`getent group apache |cut -d: -f3`
+ [ -z "${gid}" ] && gid=81
+ fowners root.${gid} /usr/sbin/suexec
+ fperms 4710 /usr/sbin/suexec
+
+ #setup links in /etc/apache2
+ cd ${D}/etc/apache2
+ ln -sf ../../usr/lib/apache2 modules
+ #apxs needs this to pickup the right lib for install
+ ln -sf ../../usr/lib lib
+ ln -sf ../../var/log/apache2 logs
+ ln -sf ../../usr/lib/apache2-extramodules extramodules
+ cd ${S}
+
+ #Credits to advx.org people for these scripts. Heck, thanks for
+ #the nice layout and everything else ;-)
+ exeinto /usr/sbin
+ for i in apache2logserverstatus apache2splitlogfile
+ do
+ doexe ${FILESDIR}/2.0.40/$i
+ done
+ exeinto /usr/lib/ssl/apache2-mod_ssl
+ doexe ${FILESDIR}/2.0.40/gentestcrt.sh
+
+ #some more scripts
+ exeinto /usr/sbin
+ for i in split-logfile list_hooks.pl logresolve.pl log_server_status
+ do
+ doexe ${S}/support/$i
+ done
+ #the ssl version of apache bench
+ doexe support/.libs/ab-ssl
+
+ #move some mods to extramodules
+ dodir /usr/lib/apache2-extramodules
+ for i in mod_ssl.so mod_ldap.so mod_auth_ldap.so
+ do
+ [ -x ${D}/usr/lib/apache2/$i ] && \
+ mv ${D}/usr/lib/apache2/$i ${D}/usr/lib/apache2-extramodules
+ done
+
+ #modules.d config file snippets
+ insinto /etc/apache2/conf/modules.d
+ for i in 40_mod_ssl.conf 41_mod_ssl.default-vhost.conf 45_mod_dav.conf
+ do
+ doins ${FILESDIR}/2.0.40/$i
+ done
+ use ldap && doins ${FILESDIR}/2.0.40/46_mod_ldap.conf
+
+ #drop in a convenient link to the manual
+ dosym /usr/share/doc/${PF}/manual ${DATADIR}/htdocs/manual
+
+ #SLOT=2!!!
+ cd ${D}
+ mv -v usr/sbin/apachectl usr/sbin/apache2ctl
+ mv -v usr/sbin/htdigest usr/sbin/htdigest2
+ mv -v usr/sbin/htpasswd usr/sbin/htpasswd2
+ mv -v usr/sbin/logresolve usr/sbin/logresolve2
+ mv -v usr/sbin/apxs usr/sbin/apxs2
+ mv -v usr/sbin/ab usr/sbin/ab2
+ mv -v usr/sbin/ab-ssl usr/sbin/ab2-ssl
+ mv -v usr/sbin/suexec usr/sbin/suexec2
+ mv -v usr/sbin/rotatelogs usr/sbin/rotatelogs2
+ mv -v usr/sbin/dbmmanage usr/sbin/dbmmanage2
+ mv -v usr/sbin/checkgid usr/sbin/checkgid2
+ mv -v usr/sbin/split-logfile usr/sbin/split-logfile2
+ mv -v usr/sbin/list_hooks.pl usr/sbin/list_hooks2.pl
+ mv -v usr/sbin/logresolve.pl usr/sbin/logresolve2.pl
+ mv -v usr/sbin/log_server_status usr/sbin/log_server_status2
+ mv -v usr/share/man/man1/htdigest.1 usr/share/man/man1/htdigest2.1
+ mv -v usr/share/man/man1/htpasswd.1 usr/share/man/man1/htpasswd2.1
+ mv -v usr/share/man/man1/dbmmanage.1 usr/share/man/man1/dbmmanage2.1
+ mv -v usr/share/man/man8/ab.8 usr/share/man/man8/ab2.8
+ mv -v usr/share/man/man8/apxs.8 usr/share/man/man8/apxs2.8
+ mv -v usr/share/man/man8/apachectl.8 usr/share/man/man8/apache2ctl.8
+ mv -v usr/share/man/man8/httpd.8 usr/share/man/man8/apache2.8
+ mv -v usr/share/man/man8/logresolve.8 usr/share/man/man8/logresolve2.8
+ mv -v usr/share/man/man8/rotatelogs.8 usr/share/man/man8/rotatelogs2.8
+ mv -v usr/share/man/man8/suexec.8 usr/share/man/man8/suexec2.8
+
+ #tidy up
+ mv ${D}/usr/sbin/envvars* ${D}/usr/lib/apache2/build
+ dodoc ${D}/etc/apache2/conf/*-std.conf
+ rm -f ${D}/etc/apache2/conf/*.conf
+ rm -rf ${D}/var/run ${D}/var/log
+
+ #config files
+ insinto /etc/conf.d; newins ${FILESDIR}/2.0.40/apache2.confd apache2
+ exeinto /etc/init.d; newexe ${FILESDIR}/2.0.40/apache2.initd apache2
+ insinto /etc/apache2; doins ${FILESDIR}/2.0.40/apache2-builtin-mods
+ insinto /etc/apache2/conf
+ doins ${FILESDIR}/2.0.40/commonapache2.conf
+ doins ${FILESDIR}/2.0.40/apache2.conf
+ insinto /etc/apache2/conf/vhosts
+ doins ${FILESDIR}/2.0.40/virtual-homepages.conf
+ doins ${FILESDIR}/2.0.40/dynamic-vhosts.conf
+ doins ${FILESDIR}/2.0.40/vhosts.conf
+
+ # Added by Jason Wever <weeve@gentoo.org>
+ # A little sedfu to fix bug #7172 for sparc64s
+ if [ ${ARCH} = "sparc" ]
+ then
+ sed -i -e '13a\AcceptMutex fcntl' \
+ ${D}/etc/apache2/conf/apache2.conf
+ fi
+}
+
+parse_modules_config() {
+ local filename=$1
+ local name=""
+ local dso=""
+ local disable=""
+ [ -f ${filename} ] || return 1
+ for i in `cat $filename | sed "s/^#.*//"` ; do
+ if [ $i == "-" ] ; then
+ disable="true"
+ elif [ -z "$name" ] && [ ! -z "`echo $i | grep "mod_"`" ] ; then
+ name=`echo $i | sed "s/mod_//"`
+ elif [ "$disable" ] && ( [ $i == "static" ] || [ $i == "shared" ] ) ; then
+ MY_BUILTINS="${MY_BUILTINS} --disable-$name"
+ name="" ; disable=""
+ elif [ $i == "static" ] ; then
+ MY_BUILTINS="${MY_BUILTINS} --enable-$name=yes"
+ name="" ; disable=""
+ elif [ $i == "shared" ] ; then
+ MY_BUILTINS="${MY_BUILTINS} --enable-$name=shared"
+ name="" ; disable=""
+ fi
+ done
+ einfo "${filename} options:\n${MY_BUILTINS}"
+}
+
+select_modules_config() {
+ parse_modules_config /etc/apache2/apache2-builtin-mods || \
+ parse_modules_config ${FILESDIR}/2.0.40/apache2-builtin-mods || \
+ return 1
+}
+
+pkg_postinst() {
+ #empty dirs...
+ install -d -m0755 -o apache -g apache ${ROOT}/var/lib/dav
+ install -d -m0755 -o root -g root ${ROOT}/var/log/apache2
+ install -d -m0755 -o root -g root ${ROOT}/var/cache/apache2
+ install -d -m0755 -o root -g root ${ROOT}/etc/apache2/conf/ssl
+
+ cd ${ROOT}/etc/apache2/conf/ssl
+ einfo
+ einfo "Generating self-signed test certificate in /etc/apache2/conf/ssl..."
+ yes "" 2>/dev/null | ${ROOT}/usr/lib/ssl/apache2-mod_ssl/gentestcrt.sh >/dev/null 2>&1
+ einfo
+
+ if has_version '=net-www/apache-1*' ; then
+ ewarn
+ ewarn "Please add the 'apache2' flag to your USE variable and (re)install"
+ ewarn "any additional DSO modules you may wish to use with Apache-2.x."
+ ewarn "Addon modules are configured in /etc/apache2/conf/modules.d/"
+ ewarn
+ fi
+
+ einfo
+ einfo "Please remember to update your config files in /etc/apache2"
+ einfo "as --datadir has been changed to ${DATADIR}!"
+ einfo
+}
diff --git a/net-www/apache/files/digest-apache-1.3.29-r1 b/net-www/apache/files/digest-apache-1.3.29-r1
new file mode 100644
index 000000000000..a5423284e321
--- /dev/null
+++ b/net-www/apache/files/digest-apache-1.3.29-r1
@@ -0,0 +1,3 @@
+MD5 e97fe9bf51dc2c9c233d53f63b1347e3 apache_1.3.29.tar.gz 2435809
+MD5 2faa15ad074ab273af41496a1afa527f apache-1.3.29-gentoo.diff.bz2 6862
+MD5 4f6c580ffa07d33e8584406132b98e86 mod_ssl-2.8.16-1.3.29.tar.gz 754325
diff --git a/net-www/apache/files/digest-apache-2.0.48-r1 b/net-www/apache/files/digest-apache-2.0.48-r1
new file mode 100644
index 000000000000..1b6f6924c8bf
--- /dev/null
+++ b/net-www/apache/files/digest-apache-2.0.48-r1
@@ -0,0 +1 @@
+MD5 466c63bb71b710d20a5c353df8c1a19c httpd-2.0.48.tar.gz 6258490