summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-04-05 06:34:01 +0000
committerDonny Davies <woodchip@gentoo.org>2003-04-05 06:34:01 +0000
commit937bb69bd36f92fbd58a6a59991117bbea2d5fc2 (patch)
tree3816b72ff6ec9cfba0e320300feb2f926b75724b /net-www/apache/files
parentnumerous fixes and cleanups for arm-headers (diff)
downloadgentoo-2-937bb69bd36f92fbd58a6a59991117bbea2d5fc2.tar.gz
gentoo-2-937bb69bd36f92fbd58a6a59991117bbea2d5fc2.tar.bz2
gentoo-2-937bb69bd36f92fbd58a6a59991117bbea2d5fc2.zip
Bump + small fixes.
Diffstat (limited to 'net-www/apache/files')
-rw-r--r--net-www/apache/files/2.0.40/40_mod_ssl.conf5
-rw-r--r--net-www/apache/files/2.0.40/apache2.initd3
-rw-r--r--net-www/apache/files/2.0.40/commonapache2.conf6
-rw-r--r--net-www/apache/files/apache-2.0.45-gentoo.diff162
-rw-r--r--net-www/apache/files/digest-apache-2.0.4537
5 files changed, 204 insertions, 9 deletions
diff --git a/net-www/apache/files/2.0.40/40_mod_ssl.conf b/net-www/apache/files/2.0.40/40_mod_ssl.conf
index 6942b8da2202..2db5457d3b17 100644
--- a/net-www/apache/files/2.0.40/40_mod_ssl.conf
+++ b/net-www/apache/files/2.0.40/40_mod_ssl.conf
@@ -69,9 +69,8 @@ SSLPassPhraseDialog builtin
#SSLSessionCache none
#SSLSessionCache shmht:logs/ssl_scache(512000)
#SSLSessionCache shmcb:logs/ssl_scache(512000)
-
-SSLSessionCache dbm:logs/ssl_scache
-#SSLSessionCache shmht:logs/ssl_scache(128000)
+#SSLSessionCache dbm:logs/ssl_scache
+SSLSessionCache shm:logs/ssl_scache(128000)
SSLSessionCacheTimeout 300
diff --git a/net-www/apache/files/2.0.40/apache2.initd b/net-www/apache/files/2.0.40/apache2.initd
index d7461a61d1d2..d56a3b36d5e1 100644
--- a/net-www/apache/files/2.0.40/apache2.initd
+++ b/net-www/apache/files/2.0.40/apache2.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/files/2.0.40/apache2.initd,v 1.7 2003/02/25 21:56:56 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/files/2.0.40/apache2.initd,v 1.8 2003/04/05 06:34:01 woodchip Exp $
opts="${opts} reload"
@@ -12,6 +12,7 @@ depend() {
start() {
ebegin "Starting apache2"
+ [ -f /var/log/apache2/ssl_scache ] && rm /var/log/apache2/ssl_scache
start-stop-daemon --quiet --start --startas /usr/sbin/apache2 \
--pidfile /var/run/apache2.pid -- -k start ${APACHE2_OPTS}
eend $?
diff --git a/net-www/apache/files/2.0.40/commonapache2.conf b/net-www/apache/files/2.0.40/commonapache2.conf
index 85d2d8fd04b5..ef0d7b3f0fd0 100644
--- a/net-www/apache/files/2.0.40/commonapache2.conf
+++ b/net-www/apache/files/2.0.40/commonapache2.conf
@@ -1,5 +1,5 @@
### /etc/apache2/conf/commonapache2.conf
-### $Id: commonapache2.conf,v 1.3 2003/02/23 19:39:22 woodchip Exp $
+### $Id: commonapache2.conf,v 1.4 2003/04/05 06:34:01 woodchip Exp $
###
### Common server configuration.
###
@@ -898,10 +898,6 @@ ServerSignature On
</IfModule>
</Directory>
-<Directory /home/httpd/htdocs/addon-modules>
- Options Indexes FollowSymLinks
-</Directory>
-
<Location /index.shtml>
Options +Includes
</Location>
diff --git a/net-www/apache/files/apache-2.0.45-gentoo.diff b/net-www/apache/files/apache-2.0.45-gentoo.diff
new file mode 100644
index 000000000000..21d9d089f85d
--- /dev/null
+++ b/net-www/apache/files/apache-2.0.45-gentoo.diff
@@ -0,0 +1,162 @@
+diff -uNr httpd-2.0.45.orig/acinclude.m4 httpd-2.0.45/acinclude.m4
+--- httpd-2.0.45.orig/acinclude.m4 2002-11-29 06:05:57.000000000 -0500
++++ httpd-2.0.45/acinclude.m4 2003-04-06 03:36:53.000000000 -0400
+@@ -60,6 +60,7 @@
+ APACHE_SUBST(HTTPD_LDFLAGS)
+ APACHE_SUBST(UTIL_LDFLAGS)
+ APACHE_SUBST(LIBS)
++ APACHE_SUBST(SSL_LIBS)
+ APACHE_SUBST(DEFS)
+ APACHE_SUBST(INCLUDES)
+ APACHE_SUBST(NOTEST_CPPFLAGS)
+@@ -190,7 +191,7 @@
+ ])dnl
+
+ dnl
+-dnl APACHE_MODULE(name, helptext[, objects[, structname[, default[, config]]]])
++dnl APACHE_MODULE(name, helptext[, objects[, structname[, default[, config[, libs]]]]])
+ dnl
+ dnl default is one of:
+ dnl yes -- enabled by default. user must explicitly disable.
+@@ -266,7 +267,7 @@
+ fi
+ shared="";;
+ esac
+- APACHE_MODPATH_ADD($1, $shared, $3)
++ APACHE_MODPATH_ADD($1, $shared, $3,, $7)
+ fi
+ ])dnl
+
+@@ -488,7 +489,7 @@
+ APR_ADDTO(LDFLAGS, [$ap_platform_runtime_link_flag$ap_ssltk_libdir])
+ fi
+ fi
+- APR_ADDTO(LIBS, [-lssl -lcrypto])
++ APR_ADDTO(SSL_LIBS, [-lssl -lcrypto])
+ ap_cv_ssltk="$ap_ssltk_base"
+ fi
+ ])
+diff -uNr httpd-2.0.45.orig/docs/man/suexec.8 httpd-2.0.45/docs/man/suexec.8
+--- httpd-2.0.45.orig/docs/man/suexec.8 2003-02-02 15:50:05.000000000 -0500
++++ httpd-2.0.45/docs/man/suexec.8 2003-04-06 03:36:53.000000000 -0400
+@@ -1,4 +1,4 @@
+-.TH suexec 8 "March 2001"
++.TH suexec2 8 "March 2001"
+ .\" The Apache Software License, Version 1.1
+ .\"
+ .\" Copyright (c) 2000-2003 The Apache Software Foundation. All rights
+@@ -51,25 +51,25 @@
+ .\" <http://www.apache.org/>.
+ .\"
+ .SH NAME
+-suexec \- Switch User For Exec
++suexec2 \- Switch User For Exec
+ .SH SYNOPSIS
+-.B suexec -V
++.B suexec2 -V
+ .PP
+ No other synopsis for usage, because this program
+ is otherwise only used internally by the Apache HTTP server.
+ .PP
+ .SH DESCRIPTION
+-.B suexec
+-is the "wrapper" support program for the suexec behaviour for the
++.B suexec2
++is the "wrapper" support program for the suexec2 behaviour for the
+ Apache HTTP server. It is run from within the server automatically
+ to switch the user when an external program has to be run under a
+-different user. For more information about suexec, see the online
++different user. For more information about suexec2, see the online
+ document `Apache suexec Support' on the HTTP server project's
+ Web site at http://httpd.apache.org/docs/suexec.html .
+ .SH OPTIONS
+ .IP -V
+-Display the list of compile-time settings used when \fBsuexec\fP
++Display the list of compile-time settings used when \fBsuexec2\fP
+ was built. No other action is taken.
+ .PD
+ .SH SEE ALSO
+-.BR httpd(8)
++.BR apache2(8)
+diff -uNr httpd-2.0.45.orig/modules/ssl/config.m4 httpd-2.0.45/modules/ssl/config.m4
+--- httpd-2.0.45.orig/modules/ssl/config.m4 2002-03-29 02:36:01.000000000 -0500
++++ httpd-2.0.45/modules/ssl/config.m4 2003-04-06 03:36:53.000000000 -0400
+@@ -79,7 +79,7 @@
+ APACHE_CHECK_SSL_TOOLKIT
+ AC_CHECK_FUNCS(SSL_set_state)
+ AC_CHECK_FUNCS(SSL_set_cert_store)
+-])
++], [\$(SSL_LIBS)])
+
+ dnl # end of module specific part
+ APACHE_MODPATH_FINISH
+diff -uNr httpd-2.0.45.orig/os/unix/unixd.c httpd-2.0.45/os/unix/unixd.c
+--- httpd-2.0.45.orig/os/unix/unixd.c 2003-02-03 12:31:58.000000000 -0500
++++ httpd-2.0.45/os/unix/unixd.c 2003-04-06 03:36:53.000000000 -0400
+@@ -228,23 +228,20 @@
+
+ AP_DECLARE(void) unixd_pre_config(apr_pool_t *ptemp)
+ {
+- apr_finfo_t wrapper;
++ struct stat wrapper;
+
+ unixd_config.user_name = DEFAULT_USER;
+ unixd_config.user_id = ap_uname2id(DEFAULT_USER);
+ unixd_config.group_id = ap_gname2id(DEFAULT_GROUP);
+
+ /* Check for suexec */
+- unixd_config.suexec_enabled = 0;
+- if ((apr_stat(&wrapper, SUEXEC_BIN,
+- APR_FINFO_NORM, ptemp)) != APR_SUCCESS) {
+- return;
+- }
+-
+- /* XXX - apr_stat is incapable of checking suid bits (grumble) */
+- /* if ((wrapper.filetype & S_ISUID) && wrapper.user == 0) { */
++ if (stat(SUEXEC_BIN, &wrapper) == 0 &&
++ (wrapper.st_mode & S_ISUID) && wrapper.st_uid == 0) {
+ unixd_config.suexec_enabled = 1;
+- /* } */
++ } else {
++ unixd_config.suexec_enabled = 0;
++ }
++
+ }
+
+
+diff -uNr httpd-2.0.45.orig/support/apachectl.in httpd-2.0.45/support/apachectl.in
+--- httpd-2.0.45.orig/support/apachectl.in 2003-02-03 12:32:08.000000000 -0500
++++ httpd-2.0.45/support/apachectl.in 2003-04-06 03:37:37.000000000 -0400
+@@ -28,7 +28,8 @@
+ # -------------------- --------------------
+ #
+ # the path to your httpd binary, including options if necessary
+-HTTPD='@exp_sbindir@/@progname@'
++. /etc/conf.d/apache2
++HTTPD="@exp_sbindir@/@progname@ ${APACHE2_OPTS}"
+ #
+ # pick up any necessary environment variables
+ if test -f @exp_bindir@/envvars; then
+diff -uNr httpd-2.0.45.orig/support/apxs.in httpd-2.0.45/support/apxs.in
+--- httpd-2.0.45.orig/support/apxs.in 2003-02-22 10:50:13.000000000 -0500
++++ httpd-2.0.45/support/apxs.in 2003-04-06 03:36:53.000000000 -0400
+@@ -237,19 +237,6 @@
+ ($httpd = $0) =~ s:support/apxs$::;
+ }
+
+-unless (-x "$httpd") {
+- error("$httpd not found or not executable");
+- exit 1;
+-}
+-
+-unless (grep /mod_so/, `. $envvars && $httpd -l`) {
+- error("Sorry, no shared object support for Apache");
+- error("available under your platform. Make sure");
+- error("the Apache module mod_so is compiled into");
+- error("your server binary `$httpd'.");
+- exit 1;
+-}
+-
+ sub get_config_vars{
+ my ($file, $rh_config) = @_;
+
diff --git a/net-www/apache/files/digest-apache-2.0.45 b/net-www/apache/files/digest-apache-2.0.45
new file mode 100644
index 000000000000..5e8f9d62d639
--- /dev/null
+++ b/net-www/apache/files/digest-apache-2.0.45
@@ -0,0 +1,37 @@
+MD5 161245c7aa1eb785db53b34d6a10be43 /files/suexec_pam_gentoo.patch 2149
+MD5 97c7a2efed7a3fd05614167426c495d9 /files/apache-builtin-mods 2465
+MD5 d3626a1e31a675c60d066c111d552adf /files/suexec.pam 59
+MD5 f2c60b199c12729b25716ed451a24e38 /files/apache-2.0.44-gentoo.diff 4895
+MD5 de4bb52edc581b44224e7006846aff43 /files/apache.rc6 1021
+MD5 8d790bf68c47c08951c761815cd66a1c /files/apachelogserverstatus 4763
+MD5 df54361aa8754197cf3bafe99d32c7ec /files/robots.txt 340
+MD5 02db12f0d91e1f89e0b173fea6c5151d /files/apacheaddmod 5977
+MD5 bae4b9d941cd38a32943533e958aa1b3 /files/apachedelmod 3185
+MD5 9dc40e1918a2d30a578ebf1653f7182c /files/apache-2.0.45-gentoo.diff 5448
+MD5 a90bef6fb0fb6d05f74c36eaf26285d6 /files/apachesplitlogfile 4959
+MD5 df1290566bb25603dbe5a649daec5185 /files/apache.confd 1012
+MD5 f440f0a32308bc9dc9d9acd041c8b6c5 /files/conf/apache.conf 7247
+MD5 e68da4777c0641e3bc5b284ee7f6fcf2 /files/conf/commonapache.conf 22140
+MD5 c774e0c7ddc6d55bddc164a9b5af0cb6 /files/conf/VirtualHomePages.conf 907
+MD5 f820076adb31912c060052154d08eecb /files/conf/Vhosts.conf 1909
+MD5 fd9b211c5078739d4aadbe6b3e53aead /files/conf/DynamicVhosts.conf 963
+MD5 14aebf386646fe7ab2623dad993a32fa /files/2.0.40/40_mod_ssl.conf 3420
+MD5 819ee444395cf42ccc8009529a94af37 /files/2.0.40/45_mod_dav.conf 583
+MD5 50b76a8df795c79378c02f1edea750a4 /files/2.0.40/46_mod_ldap.conf 902
+MD5 b610d37fd521de1f8fc782069e165969 /files/2.0.40/apache2logserverstatus 4652
+MD5 a14d8565fd5ca2b5753799477a85b1af /files/2.0.40/apache2splitlogfile 4844
+MD5 e14a1f0add1f5400e97cc6df5ad84429 /files/2.0.40/apache2-builtin-mods 2230
+MD5 b335411e582a8fd58aacf2f35e75291f /files/2.0.40/gentestcrt.sh 8805
+MD5 9375735d739344987fe4b2a3990de273 /files/2.0.40/highperformance.conf 1959
+MD5 5c47dec8c730edf1cb755b581327bd49 /files/2.0.40/httpd.conf 35481
+MD5 0055923f696c9ba3be7eeb5518603d40 /files/2.0.40/ssl.conf 11082
+MD5 8ce666f3b8ad3ed00c081dc29e19fe90 /files/2.0.40/41_mod_ssl.default-vhost.conf 8039
+MD5 1ea0af5a7b339e83ad1d045d8602469d /files/2.0.40/commonapache2.conf 30913
+MD5 4f46808418e644590002e78e98d88f21 /files/2.0.40/apache2.confd 776
+MD5 f807a994fd6bfe85da325fab19c16b34 /files/2.0.40/apache2.initd 1121
+MD5 8203712c2d827475922d031ffb4061d4 /files/2.0.40/apache2.conf 7643
+MD5 548304216950e0192bf40ae0f5ace370 /files/2.0.40/vhosts.conf 1683
+MD5 b69bf7c3126e471a2abff013e716367f /files/2.0.40/virtual-homepages.conf 780
+MD5 23416b00cbdc46b67e672f272e49ba40 /files/2.0.40/dynamic-vhosts.conf 840
+MD5 817d8a540193c3ecda1a587a77cd693e /apache-2.0.45.ebuild 10229
+MD5 1f33e9a2e2de06da190230fa72738d75 httpd-2.0.45.tar.gz 5549120