summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>2007-09-10 23:02:17 +0000
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>2007-09-10 23:02:17 +0000
commit85a1eda776f8f08a6db04e9165e20950dcebb8ac (patch)
treeb3babecefe1dcc269a4f6494bce370f2be32cf7a /net-wireless
parentwhitespace (diff)
downloadgentoo-2-85a1eda776f8f08a6db04e9165e20950dcebb8ac.tar.gz
gentoo-2-85a1eda776f8f08a6db04e9165e20950dcebb8ac.tar.bz2
gentoo-2-85a1eda776f8f08a6db04e9165e20950dcebb8ac.zip
Removed support for mac80211 since it is broken for now
(Portage version: 2.1.3.7)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/hostapd/ChangeLog6
-rw-r--r--net-wireless/hostapd/hostapd-0.6.0.ebuild25
2 files changed, 18 insertions, 13 deletions
diff --git a/net-wireless/hostapd/ChangeLog b/net-wireless/hostapd/ChangeLog
index c2bcc8e791d2..d03374fb49cb 100644
--- a/net-wireless/hostapd/ChangeLog
+++ b/net-wireless/hostapd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-wireless/hostapd
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.74 2007/06/19 07:50:22 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.75 2007/09/10 23:02:17 gurligebis Exp $
+
+ 10 Sep 2007; Bjarke Istrup Pedersen <gurligebis@gentoo.org>
+ hostapd-0.6.0.ebuild:
+ Removed support for mac80211 since it is broken for now
19 Jun 2007; Stefan Schweizer <genstef@gentoo.org> hostapd-0.4.9.ebuild,
hostapd-0.5.8.ebuild, hostapd-0.6.0.ebuild:
diff --git a/net-wireless/hostapd/hostapd-0.6.0.ebuild b/net-wireless/hostapd/hostapd-0.6.0.ebuild
index 2bac85e6e210..1112efac67b0 100644
--- a/net-wireless/hostapd/hostapd-0.6.0.ebuild
+++ b/net-wireless/hostapd/hostapd-0.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.6.0.ebuild,v 1.2 2007/06/19 07:50:22 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.6.0.ebuild,v 1.3 2007/09/10 23:02:17 gurligebis Exp $
inherit toolchain-funcs linux-info
@@ -60,12 +60,13 @@ generate_config() {
echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
fi
- if [ -e "${KV_DIR}"/net/mac80211 ]; then
- # Kernel source has the mac80211 subsystem, so we enable the driver
- echo "CONFIG_DRIVER_DEVICESCAPE=y" >> ${CONFIG}
- echo "WIRELESS_DEV=\"${KV_DIR}\"" >> ${CONFIG}
- echo "CFLAGS += -I\$(WIRELESS_DEV)/net/mac80211" >> ${CONFIG}
- fi
+ # REMOVED FOR NOW, BROKEN
+ #if [ -e "${KV_DIR}"/net/mac80211 ]; then
+ # # Kernel source has the mac80211 subsystem, so we enable the driver
+ # echo "CONFIG_DRIVER_DEVICESCAPE=y" >> ${CONFIG}
+ # echo "WIRELESS_DEV=\"${KV_DIR}\"" >> ${CONFIG}
+ # echo "CFLAGS += -I\$(WIRELESS_DEV)/net/mac80211" >> ${CONFIG}
+ #fi
# misc
echo "CONFIG_PKCS12=y" >> ${CONFIG}
@@ -151,9 +152,9 @@ pkg_postinst() {
einfo "You should remerge ${PN} after upgrading these packages."
einfo
fi
- if [ -e "${KV_DIR}"/net/mac80211 ]; then
- einfo "This package now compiles against the headers installed by"
- einfo "the kernel source for the mac80211 driver. You should "
- einfo "re-emerge ${PN} after upgrading your kernel source."
- fi
+ #if [ -e "${KV_DIR}"/net/mac80211 ]; then
+ # einfo "This package now compiles against the headers installed by"
+ # einfo "the kernel source for the mac80211 driver. You should "
+ # einfo "re-emerge ${PN} after upgrading your kernel source."
+ #fi
}