summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2014-04-08 03:14:08 +0000
committerRick Farina <zerochaos@gentoo.org>2014-04-08 03:14:08 +0000
commit835908f635923eab409280565fc5f84ee779a50d (patch)
tree1f0bdbd156bd79382d8ae8401434a4acb9357563 /net-wireless
parentConvert configure flags to an array to make management easier. Fix pkg-confi... (diff)
downloadgentoo-2-835908f635923eab409280565fc5f84ee779a50d.tar.gz
gentoo-2-835908f635923eab409280565fc5f84ee779a50d.tar.bz2
gentoo-2-835908f635923eab409280565fc5f84ee779a50d.zip
version bump and minor live updates
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/kismet-ubertooth/ChangeLog10
-rw-r--r--net-wireless/kismet-ubertooth/kismet-ubertooth-2014.04.1.ebuild54
-rw-r--r--net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild24
3 files changed, 72 insertions, 16 deletions
diff --git a/net-wireless/kismet-ubertooth/ChangeLog b/net-wireless/kismet-ubertooth/ChangeLog
index 3fa96dca99d6..15d489947326 100644
--- a/net-wireless/kismet-ubertooth/ChangeLog
+++ b/net-wireless/kismet-ubertooth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/kismet-ubertooth
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/kismet-ubertooth/ChangeLog,v 1.14 2013/04/27 23:12:42 zerochaos Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/kismet-ubertooth/ChangeLog,v 1.15 2014/04/08 03:14:08 zerochaos Exp $
+
+*kismet-ubertooth-2014.04.1 (08 Apr 2014)
+
+ 08 Apr 2014; Rick Farina <zerochaos@gentoo.org>
+ +kismet-ubertooth-2014.04.1.ebuild, kismet-ubertooth-9999.ebuild:
+ version bump and minor live updates
*kismet-ubertooth-2012.10.1-r2 (27 Apr 2013)
diff --git a/net-wireless/kismet-ubertooth/kismet-ubertooth-2014.04.1.ebuild b/net-wireless/kismet-ubertooth/kismet-ubertooth-2014.04.1.ebuild
new file mode 100644
index 000000000000..1dba8623f1aa
--- /dev/null
+++ b/net-wireless/kismet-ubertooth/kismet-ubertooth-2014.04.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/kismet-ubertooth/kismet-ubertooth-2014.04.1.ebuild,v 1.1 2014/04/08 03:14:08 zerochaos Exp $
+
+EAPI="5"
+
+inherit multilib
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/greatscottgadgets/ubertooth.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ MY_PV=${PV/\./-}
+ MY_PV=${MY_PV/./-R}
+ S="${WORKDIR}/ubertooth-${MY_PV}"
+ SRC_URI="https://github.com/greatscottgadgets/ubertooth/releases/download/${MY_PV}/ubertooth-${MY_PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Provides basic bluetooth support in kismet"
+HOMEPAGE="http://ubertooth.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE=""
+
+DEPEND=">=net-wireless/kismet-2011.03.2-r1:= \
+ >=net-wireless/ubertooth-2012.02.2 \
+ >=net-libs/libbtbb-2012.02.2 \
+ virtual/libusb:1"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ if has_version =net-wireless/kismet-9999; then
+ cd "${S}/host/kismet/plugin-ubertooth-phyneutral" || die
+ else
+ cd "${S}/host/kismet/plugin-ubertooth" || die
+ fi
+ emake KIS_SRC_DIR="/usr/include/kismet/"
+}
+
+src_install() {
+ if has_version =net-wireless/kismet-9999; then
+ cd "${S}/host/kismet/plugin-ubertooth-phyneutral" || die
+ else
+ cd "${S}/host/kismet/plugin-ubertooth" || die
+ fi
+ emake DESTDIR="${ED}" LIBDIR="/$(get_libdir)" KIS_SRC_DIR="/usr/include/kismet/" install
+}
+
+pkg_postinst() {
+ ewarn "This package must be rebuilt every time kismet is rebuilt. Or else."
+}
diff --git a/net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild b/net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild
index 9648bf8aa7bb..ccb8b60eb66a 100644
--- a/net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild
+++ b/net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild
@@ -1,24 +1,20 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild,v 1.10 2013/04/25 23:48:07 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild,v 1.11 2014/04/08 03:14:08 zerochaos Exp $
EAPI="5"
inherit multilib
-MY_PV=${PV/\./-}
-MY_PV=${MY_PV/./-R}
-S="${WORKDIR}/ubertooth-${MY_PV}"
-
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="http://git.code.sf.net/p/ubertooth/code"
- EGIT_PROJECT="ubertooth"
- #EGIT_REPO_URI="git://ubertooth.git.sourceforge.net/gitroot/ubertooth/ubertooth"
- #SRC_URI=""
- inherit git-2
+ EGIT_REPO_URI="https://github.com/greatscottgadgets/ubertooth.git"
+ inherit git-r3
KEYWORDS=""
else
- SRC_URI="mirror://sourceforge/ubertooth/ubertooth-${MY_PV}.tar.xz"
+ MY_PV=${PV/\./-}
+ MY_PV=${MY_PV/./-R}
+ S="${WORKDIR}/ubertooth-${MY_PV}"
+ SRC_URI="https://github.com/greatscottgadgets/ubertooth/releases/download/${MY_PV}/ubertooth-${MY_PV}.tar.xz"
KEYWORDS="~amd64 ~arm ~x86"
fi
@@ -30,8 +26,8 @@ SLOT="0/${PV}"
IUSE=""
DEPEND=">=net-wireless/kismet-2011.03.2-r1:= \
- =net-wireless/ubertooth-${PV} \
- =net-libs/libbtbb-${PV} \
+ >=net-wireless/ubertooth-${PV} \
+ >=net-libs/libbtbb-${PV} \
virtual/libusb:1"
RDEPEND="${DEPEND}"