summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-06-09 11:33:55 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-06-09 11:33:55 +0000
commit2ac7e5428c362c982591e441a9a31b4d480104d5 (patch)
tree517fd4d13978a87bb65f5190d8fa7807b0de01b2 /net-wireless
parentVersion bump (diff)
downloadgentoo-2-2ac7e5428c362c982591e441a9a31b4d480104d5.tar.gz
gentoo-2-2ac7e5428c362c982591e441a9a31b4d480104d5.tar.bz2
gentoo-2-2ac7e5428c362c982591e441a9a31b4d480104d5.zip
Add back the abilitity to run rfcomm bind all to the init script because the service architechture is not mature enough to handle that stuff yet. Fixes bug #181176.
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/bluez-utils/ChangeLog11
-rw-r--r--net-wireless/bluez-utils/bluez-utils-3.11-r2.ebuild148
-rw-r--r--net-wireless/bluez-utils/files/3.11/bluetooth-conf.d10
-rw-r--r--net-wireless/bluez-utils/files/3.11/bluetooth-init.d53
-rw-r--r--net-wireless/bluez-utils/files/digest-bluez-utils-3.11-r23
5 files changed, 224 insertions, 1 deletions
diff --git a/net-wireless/bluez-utils/ChangeLog b/net-wireless/bluez-utils/ChangeLog
index ede0b089c971..9151f87f8e1d 100644
--- a/net-wireless/bluez-utils/ChangeLog
+++ b/net-wireless/bluez-utils/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-wireless/bluez-utils
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-utils/ChangeLog,v 1.97 2007/06/01 17:36:27 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-utils/ChangeLog,v 1.98 2007/06/09 11:33:55 betelgeuse Exp $
+
+*bluez-utils-3.11-r2 (09 Jun 2007)
+
+ 09 Jun 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +files/3.11/bluetooth-conf.d, +files/3.11/bluetooth-init.d,
+ +bluez-utils-3.11-r2.ebuild:
+ Add back the abilitity to run rfcomm bind all to the init script because the
+ service architechture is not mature enough to handle that stuff yet. Fixes
+ bug #181176.
*bluez-utils-3.11-r1 (01 Jun 2007)
diff --git a/net-wireless/bluez-utils/bluez-utils-3.11-r2.ebuild b/net-wireless/bluez-utils/bluez-utils-3.11-r2.ebuild
new file mode 100644
index 000000000000..e2ad59e415b4
--- /dev/null
+++ b/net-wireless/bluez-utils/bluez-utils-3.11-r2.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-utils/bluez-utils-3.11-r2.ebuild,v 1.1 2007/06/09 11:33:55 betelgeuse Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="Bluetooth Tools and System Daemons for Linux"
+HOMEPAGE="http://bluez.sourceforge.net/"
+SRC_URI="http://bluez.sourceforge.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+IUSE="cups debug examples hal old-daemons test-programs usb"
+
+DEPEND="
+ >=net-wireless/bluez-libs-${PV}
+ hal? ( sys-apps/hal )
+ usb? ( dev-libs/libusb )
+ cups? ( net-print/cups )
+ sys-fs/udev
+ dev-libs/glib
+ sys-apps/dbus"
+
+src_unpack() {
+ unpack ${A}
+ # bundled glib
+ cd "${S}"
+ rm -r eglib/{*.c,*.h} || die
+ if use cups; then
+ epatch "${FILESDIR}/3.11/cups-location.patch"
+ eautoreconf
+ fi
+}
+
+src_compile() {
+ # the order is the same as ./configure --help
+
+ # we don't need the other daemons either with the new
+ # service architechture
+ # hcid has in integrated sdpd now that we use
+
+ # These are currently under work and don't work properly:
+ # --enable-alsa
+ # --enable-sync
+ # --enable-obex
+ # Only for embedded devices
+ # --enable-audio
+
+ econf \
+ $(use_enable debug) \
+ --enable-inotify \
+ $(use_enable hal) \
+ $(use_enable usb) \
+ --enable-glib \
+ --disable-obex \
+ --disable-alsa \
+ --enable-network \
+ --enable-serial \
+ --enable-input \
+ --disable-audio \
+ --disable-sync \
+ $(use_enable examples echo) \
+ --enable-hcid \
+ $(use_enable test-programs test) \
+ $(use_enable old-daemons sdpd) \
+ $(use_enable old-daemons hidd) \
+ $(use_enable old-daemons pand) \
+ $(use_enable cups) \
+ --enable-configfiles \
+ --disable-initscripts \
+ --disable-pcmciarules \
+ --enable-bccmd \
+ --enable-avctrl \
+ --enable-hid2hci \
+ --enable-dfutool \
+ --localstatedir=/var \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog README || die
+
+ # a very simple example daemon
+ dobin daemon/passkey-agent || die
+
+ newinitd "${FILESDIR}/3.11/bluetooth-init.d" bluetooth || die
+ newconfd "${FILESDIR}/3.11/bluetooth-conf.d" bluetooth || die
+
+ if use old-daemons; then
+ sed -re 's/^(Autostart=)true/\1false/' \
+ -i "${D}/etc/bluetooth/input.service" || die
+ newconfd "${FILESDIR}/3.11/conf.d-hidd" hidd || die
+ newinitd "${FILESDIR}/3.11/init.d-hidd" hidd || die
+ fi
+
+ # bug #84431
+ insinto /etc/udev/rules.d/
+ newins "${FILESDIR}/${PN}-3.10.1-udev.rules" 70-bluetooth.rules || die
+ newins "${S}/scripts/bluetooth.rules" 70-bluetooth-pcmcia.rules || die
+
+ exeinto /lib/udev/
+ newexe "${FILESDIR}/${PN}-3.10.1-udev.script" bluetooth.sh || die
+ doexe "${S}/scripts/bluetooth_serial" || die
+}
+
+pkg_postinst() {
+ udevcontrol reload_rules && udevtrigger
+
+ elog
+ elog "To use dial up networking you must install net-dialup/ppp."
+ elog ""
+ elog "Since 3.0 bluez has changed the passkey handling to use a dbus based"
+ elog "API so please remember to update your /etc/bluetooth/hcid.conf."
+ elog "For a password agent, there is for example net-wireless/bluez-gnome"
+ elog "for gnome and net-wireless/kdebluetooth for kde."
+ elog ""
+ elog "Since 3.10.1 we don't install the old style daemons any more but rely"
+ elog "on the new service architechture:"
+ elog " http://wiki.bluez.org/wiki/Services"
+ elog ""
+ elog "Edit /etc/bluetooth/*.service to enable the services."
+ elog "Use the old-daemons use flag to get the old daemons like hidd"
+ elog "installed. Please note that the init script doesn't stop the old"
+ elog "daemons after you update it so it's recommended to run:"
+ elog " /etc/init.d/bluetooth stop"
+ elog "before updating your configuration files or you can manually kill"
+ elog "the extra daemons you previously enabled in /etc/conf.d/bluetooth."
+ elog ""
+ elog "If you want to use rfcomm as a normal user, you need to add the user"
+ elog "to the uucp group."
+ elog ""
+ if use old-daemons; then
+ elog "The hidd init script was installed because you have the old-daemons"
+ elog "use flag on. It is not started by default via udev so please add it"
+ elog "to the required runleves using rc-update <runlevel> add hidd. If"
+ elog "you need init scripts for the other daemons, please file requests"
+ elog "to https://bugs.gentoo.org."
+ else
+ elog "The bluetooth service should be started automatically by udev"
+ elog "when the required hardware is inserted next time."
+ fi
+}
diff --git a/net-wireless/bluez-utils/files/3.11/bluetooth-conf.d b/net-wireless/bluez-utils/files/3.11/bluetooth-conf.d
new file mode 100644
index 000000000000..c84ac4f1175c
--- /dev/null
+++ b/net-wireless/bluez-utils/files/3.11/bluetooth-conf.d
@@ -0,0 +1,10 @@
+# Bluetooth configuraton file
+
+# Run hid2hci (allowed values are "true" and "false")
+HID2HCI_ENABLE=false
+
+# Bind rfcomm devices (allowed values are "true" and "false")
+RFCOMM_ENABLE=true
+
+# Config file for rfcomm
+RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
diff --git a/net-wireless/bluez-utils/files/3.11/bluetooth-init.d b/net-wireless/bluez-utils/files/3.11/bluetooth-init.d
new file mode 100644
index 000000000000..778794934557
--- /dev/null
+++ b/net-wireless/bluez-utils/files/3.11/bluetooth-init.d
@@ -0,0 +1,53 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-utils/files/3.11/bluetooth-init.d,v 1.1 2007/06/09 11:33:55 betelgeuse Exp $
+
+depend() {
+ after coldplug
+ need dbus localmount
+}
+
+start() {
+ ebegin "Starting Bluetooth"
+ local result=0
+ HCID_CONFIG="${HCID_CONFIG:-/etc/bluetooth/hcid.conf}"
+
+ if [ -f "${HCID_CONFIG}" ]; then
+ ebegin " Starting hcid"
+ # -s enables internal sdp server
+ start-stop-daemon --start \
+ --exec /usr/sbin/hcid -- -s -f "${HCID_CONFIG}"
+ eend $?
+ else
+ eerror "Can't start hcid because HCID_CONFIG is missing."
+ eend 1
+ result=1
+ fi
+
+ if [ "${HID2HCI_ENABLE}" = "true" -a -x /usr/sbin/hid2hci ]; then
+ ebegin " Running hid2hci"
+ /usr/sbin/hid2hci --tohci -q #be quiet
+ eend $?
+ [ "${result}" = "0" ] && result=$?
+ fi
+
+ if [ "${RFCOMM_ENABLE}" = "true" -a -x /usr/bin/rfcomm ]; then
+ if [ -f "${RFCOMM_CONFIG}" ]; then
+ ebegin " Starting rfcomm"
+ /usr/bin/rfcomm -f "${RFCOMM_CONFIG}" bind all
+ eend $?
+ else
+ ewarn "Not enabling rfcomm because RFCOMM_CONFIG does not exists"
+ fi
+ fi
+
+ eend ${result}
+}
+
+stop() {
+ ebegin "Shutting down Bluetooth"
+
+ start-stop-daemon --stop --quiet --exec /usr/sbin/hcid
+ eend $?
+}
diff --git a/net-wireless/bluez-utils/files/digest-bluez-utils-3.11-r2 b/net-wireless/bluez-utils/files/digest-bluez-utils-3.11-r2
new file mode 100644
index 000000000000..92e7c6768bde
--- /dev/null
+++ b/net-wireless/bluez-utils/files/digest-bluez-utils-3.11-r2
@@ -0,0 +1,3 @@
+MD5 703fed8e09e25b5e1f01be337576e343 bluez-utils-3.11.tar.gz 810657
+RMD160 0960cd1d76f29df383397ba33e0bf52648cf393b bluez-utils-3.11.tar.gz 810657
+SHA256 6f442988bf11d8066ee1ed416acea04ed4be764ab3189780bd2148536e9d76d8 bluez-utils-3.11.tar.gz 810657