summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2006-12-03 09:39:11 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2006-12-03 09:39:11 +0000
commite31d1713fcb3892dc29245e64714c7bba6bdf2ea (patch)
tree463cd59beadad780e7a379252b159f8345943c3e /net-wireless/linux-wlan-ng-modules
parentovz bug #254 has been solved; add ~ppc64 and ~sparc; cleanup (diff)
downloadgentoo-2-e31d1713fcb3892dc29245e64714c7bba6bdf2ea.tar.gz
gentoo-2-e31d1713fcb3892dc29245e64714c7bba6bdf2ea.tar.bz2
gentoo-2-e31d1713fcb3892dc29245e64714c7bba6bdf2ea.zip
Added a revision that compiles with 2.6.19. Fixes bug #156838. Thanks to Daniel Drake <dsd@gentoo.org> for the sandbox patch.
(Portage version: 2.1.2_rc2-r3)
Diffstat (limited to 'net-wireless/linux-wlan-ng-modules')
-rw-r--r--net-wireless/linux-wlan-ng-modules/ChangeLog11
-rw-r--r--net-wireless/linux-wlan-ng-modules/files/digest-linux-wlan-ng-modules-0.2.5-r13
-rw-r--r--net-wireless/linux-wlan-ng-modules/files/linux-wlan-ng-0.2.5-kernel-2.6.19.patch247
-rw-r--r--net-wireless/linux-wlan-ng-modules/files/linux-wlan-ng-0.2.5-sandbox.patch17
-rw-r--r--net-wireless/linux-wlan-ng-modules/linux-wlan-ng-modules-0.2.5-r1.ebuild91
5 files changed, 368 insertions, 1 deletions
diff --git a/net-wireless/linux-wlan-ng-modules/ChangeLog b/net-wireless/linux-wlan-ng-modules/ChangeLog
index c71e565088fb..9dd5e968f5c8 100644
--- a/net-wireless/linux-wlan-ng-modules/ChangeLog
+++ b/net-wireless/linux-wlan-ng-modules/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-wireless/linux-wlan-ng-modules
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng-modules/ChangeLog,v 1.11 2006/10/08 19:09:23 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng-modules/ChangeLog,v 1.12 2006/12/03 09:39:11 betelgeuse Exp $
+
+*linux-wlan-ng-modules-0.2.5-r1 (03 Dec 2006)
+
+ 03 Dec 2006; Petteri Räty <betelgeuse@gentoo.org>
+ +files/linux-wlan-ng-0.2.5-kernel-2.6.19.patch,
+ +files/linux-wlan-ng-0.2.5-sandbox.patch,
+ +linux-wlan-ng-modules-0.2.5-r1.ebuild:
+ Added a revision that compiles with 2.6.19. Fixes bug #156838. Thanks to
+ Daniel Drake <dsd@gentoo.org> for the sandbox patch.
*linux-wlan-ng-modules-0.2.5 (08 Oct 2006)
diff --git a/net-wireless/linux-wlan-ng-modules/files/digest-linux-wlan-ng-modules-0.2.5-r1 b/net-wireless/linux-wlan-ng-modules/files/digest-linux-wlan-ng-modules-0.2.5-r1
new file mode 100644
index 000000000000..f91173cb625c
--- /dev/null
+++ b/net-wireless/linux-wlan-ng-modules/files/digest-linux-wlan-ng-modules-0.2.5-r1
@@ -0,0 +1,3 @@
+MD5 b4f6eb438533f73cd456e5ee7a3f722a linux-wlan-ng-0.2.5.tar.bz2 457056
+RMD160 3bd08380d9bd131ad960a8b3c9dd87972254357a linux-wlan-ng-0.2.5.tar.bz2 457056
+SHA256 882f5fe8c3e3a2538f59e96d002866aea1ce3ad33396da0cea7721455f4a42be linux-wlan-ng-0.2.5.tar.bz2 457056
diff --git a/net-wireless/linux-wlan-ng-modules/files/linux-wlan-ng-0.2.5-kernel-2.6.19.patch b/net-wireless/linux-wlan-ng-modules/files/linux-wlan-ng-0.2.5-kernel-2.6.19.patch
new file mode 100644
index 000000000000..d17e82f76e50
--- /dev/null
+++ b/net-wireless/linux-wlan-ng-modules/files/linux-wlan-ng-0.2.5-kernel-2.6.19.patch
@@ -0,0 +1,247 @@
+Index: src/include/wlan/wlan_compat.h
+===================================================================
+--- src/include/wlan/wlan_compat.h (revision 1800)
++++ src/include/wlan/wlan_compat.h (working copy)
+@@ -89,6 +89,11 @@
+ #endif
+
+ #if defined(__KERNEL__)
++
++#ifndef AUTOCONF_INCLUDED
++#include <linux/config.h>
++#endif
++
+ #if defined(__x86_64__)
+ #define WLAN_CPU_FAMILY WLAN_x86_64
+ #define WLAN_SYSARCH WLAN_PCAT
+@@ -276,6 +281,12 @@
+
+ #if defined(__KERNEL__)
+
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,19))
++#define PT_REGS , struct pt_regs *regs
++#else
++#define PT_REGS
++#endif
++
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,7))
+ # define del_singleshot_timer_sync(a) del_timer_sync(a)
+ #endif
+Index: src/p80211/p80211conv.c
+===================================================================
+--- src/p80211/p80211conv.c (revision 1800)
++++ src/p80211/p80211conv.c (working copy)
+@@ -54,7 +54,7 @@
+
+ #define __NO_VERSION__ /* prevent the static definition */
+
+-#include <linux/config.h>
++
+ #include <linux/version.h>
+
+ #include <linux/module.h>
+Index: src/p80211/p80211netdev.c
+===================================================================
+--- src/p80211/p80211netdev.c (revision 1800)
++++ src/p80211/p80211netdev.c (working copy)
+@@ -53,7 +53,7 @@
+ /*================================================================*/
+ /* System Includes */
+
+-#include <linux/config.h>
++
+ #include <linux/version.h>
+
+ #include <linux/module.h>
+Index: src/p80211/p80211req.c
+===================================================================
+--- src/p80211/p80211req.c (revision 1800)
++++ src/p80211/p80211req.c (working copy)
+@@ -53,7 +53,7 @@
+ /*================================================================*/
+ /* System Includes */
+
+-#include <linux/config.h>
++
+ #include <linux/version.h>
+
+ #include <linux/module.h>
+Index: src/p80211/p80211wext.c
+===================================================================
+--- src/p80211/p80211wext.c (revision 1800)
++++ src/p80211/p80211wext.c (working copy)
+@@ -37,7 +37,7 @@
+ /*================================================================*/
+ /* System Includes */
+
+-#include <linux/config.h>
++
+ #include <linux/version.h>
+
+ #include <linux/kernel.h>
+Index: src/p80211/p80211wep.c
+===================================================================
+--- src/p80211/p80211wep.c (revision 1800)
++++ src/p80211/p80211wep.c (working copy)
+@@ -48,7 +48,7 @@
+ /*================================================================*/
+ /* System Includes */
+
+-#include <linux/config.h>
++
+ #include <linux/version.h>
+
+ #include <linux/netdevice.h>
+Index: src/p80211/p80211mod.c
+===================================================================
+--- src/p80211/p80211mod.c (revision 1800)
++++ src/p80211/p80211mod.c (working copy)
+@@ -56,7 +56,7 @@
+ /*================================================================*/
+ /* System Includes */
+
+-#include <linux/config.h>
++
+ #include <linux/version.h>
+
+ #include <linux/module.h>
+Index: src/prism2/driver/hfa384x_usb.c
+===================================================================
+--- src/prism2/driver/hfa384x_usb.c (revision 1800)
++++ src/prism2/driver/hfa384x_usb.c (working copy)
+@@ -116,7 +116,7 @@
+
+ #include <wlan/version.h>
+
+-#include <linux/config.h>
++
+ #include <linux/version.h>
+
+ #include <linux/module.h>
+Index: src/prism2/driver/prism2_cs.c
+===================================================================
+--- src/prism2/driver/prism2_cs.c (revision 1800)
++++ src/prism2/driver/prism2_cs.c (working copy)
+@@ -41,7 +41,7 @@
+ #else
+ dev_link_t *prism2sta_attach(void);
+ static void prism2sta_detach(dev_link_t *link);
+-static int prism2sta_config(dev_link_t *link);
++static void prism2sta_config(dev_link_t *link);
+ static void prism2sta_release(u_long arg);
+ static int prism2sta_event (event_t event, int priority, event_callback_args_t *args);
+
+@@ -243,14 +243,13 @@
+ prism2sta_ifstate(wlandev, P80211ENUM_ifstate_disable);
+ #else
+ wlandev = link->priv;
+-#endif
+- wlandev = link->priv;
+
+ link->state |= DEV_SUSPEND;
+ if (link->state & DEV_CONFIG) {
+ prism2sta_ifstate(wlandev, P80211ENUM_ifstate_disable);
+ pcmcia_release_configuration(link->handle);
+ }
++#endif
+
+ DBFEXIT;
+
+Index: src/prism2/driver/prism2mgmt.c
+===================================================================
+--- src/prism2/driver/prism2mgmt.c (revision 1800)
++++ src/prism2/driver/prism2mgmt.c (working copy)
+@@ -63,7 +63,7 @@
+
+ #include <wlan/version.h>
+
+-#include <linux/config.h>
++
+ #include <linux/version.h>
+
+ #include <linux/if_arp.h>
+Index: src/prism2/driver/prism2mib.c
+===================================================================
+--- src/prism2/driver/prism2mib.c (revision 1800)
++++ src/prism2/driver/prism2mib.c (working copy)
+@@ -56,7 +56,7 @@
+
+ #include <wlan/version.h>
+
+-#include <linux/config.h>
++
+ #include <linux/version.h>
+
+ #include <linux/module.h>
+Index: src/prism2/driver/prism2sta.c
+===================================================================
+--- src/prism2/driver/prism2sta.c (revision 1800)
++++ src/prism2/driver/prism2sta.c (working copy)
+@@ -56,7 +56,7 @@
+
+ #include <wlan/version.h>
+
+-#include <linux/config.h>
++
+ #include <linux/version.h>
+
+ #include <linux/module.h>
+Index: src/prism2/driver/hfa384x.c
+===================================================================
+--- src/prism2/driver/hfa384x.c (revision 1800)
++++ src/prism2/driver/hfa384x.c (working copy)
+@@ -120,7 +120,7 @@
+ #define WLAN_DBVAR prism2_debug
+ #include <wlan/version.h>
+
+-#include <linux/config.h>
++
+ #include <linux/version.h>
+
+ #include <linux/module.h>
+@@ -3210,7 +3210,7 @@
+ * Call context:
+ * Ummm, could it be interrupt?
+ ----------------------------------------------------------------*/
+-irqreturn_t hfa384x_interrupt(int irq, void *dev_id, struct pt_regs *regs)
++irqreturn_t hfa384x_interrupt(int irq, void *dev_id PT_REGS)
+ {
+ int reg;
+ wlandevice_t *wlandev = (wlandevice_t*)dev_id;
+Index: src/README
+===================================================================
+--- src/README (revision 1800)
++++ src/README (working copy)
+@@ -53,4 +53,3 @@
+ src/prism2 - source for the Intersil PRISM2 MAC specific driver
+ src/shared - source files (.c) that are shared among two or more components
+ src/wlanctl - source for the wlanctl user-mode utility
+-src/wland - source for the wland user-mode utility
+Index: CHANGES
+===================================================================
+--- CHANGES (revision 1800)
++++ CHANGES (working copy)
+@@ -41,6 +41,11 @@
+ * Intersil Corporation as part of PRISM(R) chipset product development.
+ *
+ * --------------------------------------------------------------------
++ - 2.6.19+ uses a different IRQ handler function prototype.
++ - linux/config.h is no more on 2.6.19+ kernels.
++0.2.6
++ - Fix another error that affected <2.6.15 builds on some compilers
++ - Fix a cut-n-paste error that broke 2.6.18 builds.
+ 0.2.5
+ - 2.6.18-rc fixes.
+ - A few tweaks for Wireless-Extensions-21
+Index: config.in
+===================================================================
+--- config.in (revision 1800)
++++ config.in (working copy)
+@@ -1,6 +1,6 @@
+ WLAN_VERSION=0
+ WLAN_PATCHLEVEL=2
+-WLAN_SUBLEVEL=5
++WLAN_SUBLEVEL=6
+ WLAN_EXTRAVERSION=
+ #LINUX_SRC=/usr/src/linux
+ PCMCIA_SRC=
diff --git a/net-wireless/linux-wlan-ng-modules/files/linux-wlan-ng-0.2.5-sandbox.patch b/net-wireless/linux-wlan-ng-modules/files/linux-wlan-ng-0.2.5-sandbox.patch
new file mode 100644
index 000000000000..45063df05150
--- /dev/null
+++ b/net-wireless/linux-wlan-ng-modules/files/linux-wlan-ng-0.2.5-sandbox.patch
@@ -0,0 +1,17 @@
+Fix lirc building in sandbox
+
+From: Daniel Drake <dsd@gentoo.org>
+
+Index: linux-wlan-ng-0.2.5/scripts/Makefile
+===================================================================
+--- linux-wlan-ng-0.2.5.orig/scripts/Makefile
++++ linux-wlan-ng-0.2.5/scripts/Makefile
+@@ -27,7 +27,7 @@ get_version:
+ $(CC) -I$(KERNEL_SOURCE)/include get_version.c -o get_version
+
+ get_options:
+- $(MAKE) -f $(CURR_DIR)/Makefile.get_options -C $(KERNEL_SOURCE) get_version_target
++ $(MAKE) -f $(CURR_DIR)/Makefile.get_options -C $(KERNEL_SOURCE) get_version_target M=$(shell pwd)
+
+ clean:
+ $(RM) get_version make.opts
diff --git a/net-wireless/linux-wlan-ng-modules/linux-wlan-ng-modules-0.2.5-r1.ebuild b/net-wireless/linux-wlan-ng-modules/linux-wlan-ng-modules-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..492027c2f4a8
--- /dev/null
+++ b/net-wireless/linux-wlan-ng-modules/linux-wlan-ng-modules-0.2.5-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng-modules/linux-wlan-ng-modules-0.2.5-r1.ebuild,v 1.1 2006/12/03 09:39:11 betelgeuse Exp $
+
+inherit eutils linux-mod
+
+MY_PN=${PN/-modules/}
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Kernel modules for Prism2/2.5/3 based 802.11b USB wireless LAN products"
+HOMEPAGE="http://linux-wlan.org"
+SRC_URI="ftp://ftp.linux-wlan.org/pub/linux-wlan-ng/${MY_P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="debug"
+
+BUILD_TARGETS="default"
+BUILD_PARAMS="WLAN_SRC=${S}/src"
+
+DEPEND="!<net-wireless/linux-wlan-ng-0.2.2"
+
+pkg_setup() {
+ # We have to put this to the global scope inside the function or it will be
+ # reset between functions because the ebuild is sourced many times.
+
+ MODULE_NAMES="p80211(net/wireless:${S}/src/p80211)"
+ MODULE_NAMES="${MODULE_NAMES} prism2_usb(net/wireless:${S}/src/prism2/driver)"
+
+ linux-mod_pkg_setup
+}
+
+config_by_usevar() {
+ local config=${3}
+ [[ -z ${config} ]] && config=${S}/default.config
+
+ if use ${2}; then
+ echo "${1}=y" >> ${config}
+ else
+ echo "${1}=n" >> ${config}
+ fi
+}
+
+src_unpack() {
+ local config=${S}/default.config
+
+ unpack ${A}
+
+ cd ${S}
+ epatch "${FILESDIR}/${MY_PN}-0.2.5-kernel-2.6.19.patch"
+ epatch "${FILESDIR}/${MY_PN}-0.2.5-sandbox.patch"
+
+ cp ${S}/config.in ${config}
+
+ echo "TARGET_ROOT_ON_HOST=${D}" >> ${config}
+ echo "LINUX_SRC=${KERNEL_DIR}" >> ${config}
+ echo "FIRMWARE_DIR=/lib/firmware/" >> ${config}
+ echo "PRISM2_PCI=n" >> ${config}
+ echo "PRISM2_PLX=n" >> ${config}
+ echo "PRISM2_PCMCIA=n" >> ${config}
+ echo "PRISM2_USB=y" >> ${config}
+
+ config_by_usevar WLAN_DEBUG debug
+
+ sed -i -e "s:dep modules:modules:" ${S}/src/p80211/Makefile
+}
+
+src_compile() {
+ set_arch_to_kernel
+ emake default_config || die "emake default_config failed"
+ set_arch_to_portage
+
+ cd ${S}/src/mkmeta
+ emake || die "emake mkmeta failed"
+
+ linux-mod_src_compile
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ einfo "Support for pci, plx and pcmcia drivers has been removed in"
+ einfo "revision. For pci, plx and pcmcia drivers try for example"
+ einfo "the hostap-driver or orinoco drivers. They both work with the"
+ einfo "standard wireless tools."
+ einfo ""
+ einfo "If they do not work, please report this to betelgeuse@gentoo.org."
+}