summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-04-16 13:16:08 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-04-16 13:16:08 +0000
commitd967fbfa4f6b125fa0d47bd5656cfad6a6bbcefe (patch)
tree0f703fb6ed4433809d48dce3cd729907a8823b65 /net-voip
parentStable on ppc/ppc64 (diff)
downloadgentoo-2-d967fbfa4f6b125fa0d47bd5656cfad6a6bbcefe.tar.gz
gentoo-2-d967fbfa4f6b125fa0d47bd5656cfad6a6bbcefe.tar.bz2
gentoo-2-d967fbfa4f6b125fa0d47bd5656cfad6a6bbcefe.zip
Bump to 0.7.3. Added a check for TLS in net-libs/loudmouth, --enable-backtrace removed.
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/telepathy-gabble/ChangeLog9
-rw-r--r--net-voip/telepathy-gabble/telepathy-gabble-0.7.3.ebuild52
2 files changed, 60 insertions, 1 deletions
diff --git a/net-voip/telepathy-gabble/ChangeLog b/net-voip/telepathy-gabble/ChangeLog
index 97cbe24322f3..01b34d7f4c2e 100644
--- a/net-voip/telepathy-gabble/ChangeLog
+++ b/net-voip/telepathy-gabble/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-voip/telepathy-gabble
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.31 2008/02/28 21:38:07 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.32 2008/04/16 13:16:08 coldwind Exp $
+
+*telepathy-gabble-0.7.3 (16 Apr 2008)
+
+ 16 Apr 2008; Santiago M. Mola <coldwind@gentoo.org>
+ +telepathy-gabble-0.7.3.ebuild:
+ Bump to 0.7.3. Added a check for TLS in net-libs/loudmouth,
+ --enable-backtrace removed.
*telepathy-gabble-0.7.2 (28 Feb 2008)
diff --git a/net-voip/telepathy-gabble/telepathy-gabble-0.7.3.ebuild b/net-voip/telepathy-gabble/telepathy-gabble-0.7.3.ebuild
new file mode 100644
index 000000000000..1411fb04ef49
--- /dev/null
+++ b/net-voip/telepathy-gabble/telepathy-gabble-0.7.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/telepathy-gabble-0.7.3.ebuild,v 1.1 2008/04/16 13:16:08 coldwind Exp $
+
+inherit eutils
+
+DESCRIPTION="A Jabber/XMPP connection manager, this handles single and multi user chats and voice calls."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.4
+ >=dev-libs/dbus-glib-0.72
+ >=net-libs/telepathy-glib-0.7.0
+ dev-lang/python
+ >=net-libs/loudmouth-1.3.2"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ test? ( dev-python/twisted
+ dev-python/twisted-words )"
+
+pkg_setup() {
+ if ! built_with_use -o net-libs/loudmouth ssl gnutls ; then
+ eerror "${PN} needs net-libs/loudmouth built with"
+ eerror "USE='gnutls' or USE='ssl'."
+ die "No TLS support in net-libs/loudmouth"
+ fi
+}
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable debug handle-leak-debug) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_test() {
+ if ! dbus-launch emake -j1 check; then
+ die "Make check failed. See above for details."
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS NEWS ChangeLog
+}