summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-28 17:15:37 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-28 17:15:37 +0000
commit9753b19a89b3e3ffd71e6e3d1531281c1368ea4c (patch)
tree2c6af9a11614d5f1134bf14a0f042ea9728d1a40 /net-voip
parentbump (diff)
downloadgentoo-2-9753b19a89b3e3ffd71e6e3d1531281c1368ea4c.tar.gz
gentoo-2-9753b19a89b3e3ffd71e6e3d1531281c1368ea4c.tar.bz2
gentoo-2-9753b19a89b3e3ffd71e6e3d1531281c1368ea4c.zip
Fix building with x11-libs/libnotify >= 0.7 wrt #355929 by "Kobboi".
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/ekiga/ChangeLog6
-rw-r--r--net-voip/ekiga/ekiga-3.2.7.ebuild6
-rw-r--r--net-voip/ekiga/files/ekiga-3.2.7-libnotify-0.7.patch62
3 files changed, 71 insertions, 3 deletions
diff --git a/net-voip/ekiga/ChangeLog b/net-voip/ekiga/ChangeLog
index b6a1423aa53e..89683049eea9 100644
--- a/net-voip/ekiga/ChangeLog
+++ b/net-voip/ekiga/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-voip/ekiga
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/ekiga/ChangeLog,v 1.24 2011/02/02 05:36:52 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/ekiga/ChangeLog,v 1.25 2011/02/28 17:15:37 ssuominen Exp $
+
+ 28 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> ekiga-3.2.7.ebuild,
+ +files/ekiga-3.2.7-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7 wrt #355929 by "Kobboi".
02 Feb 2011; Theo Chatzimichos <tampakrap@gentoo.org> ekiga-3.2.7.ebuild:
Cleanup: bump to EAPI3, use add_kdebase_dep
diff --git a/net-voip/ekiga/ekiga-3.2.7.ebuild b/net-voip/ekiga/ekiga-3.2.7.ebuild
index 010771f46a38..c265b50bec4c 100644
--- a/net-voip/ekiga/ekiga-3.2.7.ebuild
+++ b/net-voip/ekiga/ekiga-3.2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/ekiga/ekiga-3.2.7.ebuild,v 1.7 2011/02/02 05:36:52 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/ekiga/ekiga-3.2.7.ebuild,v 1.8 2011/02/28 17:15:37 ssuominen Exp $
EAPI=3
@@ -8,7 +8,7 @@ KDE_REQUIRED="optional"
CMAKE_REQUIRED="never"
GCONF_DEBUG="no" # debug managed by the ebuild
-inherit kde4-base gnome2
+inherit eutils kde4-base gnome2
# gnome2 at the end to make it default
DESCRIPTION="H.323 and SIP VoIP softphone"
@@ -117,6 +117,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+
gnome2_src_prepare
# remove call to gconftool-2 --shutdown, upstream bug 555976
diff --git a/net-voip/ekiga/files/ekiga-3.2.7-libnotify-0.7.patch b/net-voip/ekiga/files/ekiga-3.2.7-libnotify-0.7.patch
new file mode 100644
index 000000000000..c09fbb0f95fc
--- /dev/null
+++ b/net-voip/ekiga/files/ekiga-3.2.7-libnotify-0.7.patch
@@ -0,0 +1,62 @@
+--- lib/engine/components/libnotify/libnotify-main.cpp
++++ lib/engine/components/libnotify/libnotify-main.cpp
+@@ -40,6 +40,10 @@
+
+ #include <libnotify/notify.h>
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ #include "services.h"
+ #include "notification-core.h"
+
+@@ -158,7 +162,12 @@
+
+ notif = notify_notification_new (notification->get_title ().c_str (),
+ notification->get_body ().c_str (),
+- urgency, NULL);
++ urgency
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , NULL);
++#endif
+
+ g_signal_connect (notif, "closed",
+ G_CALLBACK (on_notif_closed), notification.get ());
+--- src/gui/main.cpp
++++ src/gui/main.cpp
+@@ -84,6 +84,9 @@
+
+ #ifdef HAVE_NOTIFY
+ #include <libnotify/notify.h>
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
+ #endif
+
+ #if defined(P_FREEBSD) || defined (P_MACOSX)
+@@ -2820,12 +2823,21 @@
+
+ body = g_strdup_printf ("%s\n%s\n%s", uri, app, account);
+
+- notify = notify_notification_new (title, body, GM_ICON_LOGO, NULL);
++ notify = notify_notification_new (title, body, GM_ICON_LOGO
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , NULL);
++#endif
+ notify_notification_add_action (notify, "accept", _("Accept"), notify_action_cb, mw, NULL);
+ notify_notification_add_action (notify, "reject", _("Reject"), notify_action_cb, mw, NULL);
+ notify_notification_set_timeout (notify, NOTIFY_EXPIRES_NEVER);
+ notify_notification_set_urgency (notify, NOTIFY_URGENCY_CRITICAL);
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ // notify_notification_attach_to_status_icon was removed
++#else
+ notify_notification_attach_to_status_icon (notify, statusicon);
++#endif
+ if (!notify_notification_show (notify, NULL)) {
+ ekiga_main_window_incoming_call_dialog_show (mw, call);
+ }