summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2006-09-08 17:10:52 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2006-09-08 17:10:52 +0000
commit908e5729d6045ebe5acdc6d32ee96fe0a13aaa21 (patch)
tree5ad3f50f579966ae94b0640148eacde6efb2d586 /net-proxy/ziproxy
parentdep typo fix (diff)
downloadgentoo-2-908e5729d6045ebe5acdc6d32ee96fe0a13aaa21.tar.gz
gentoo-2-908e5729d6045ebe5acdc6d32ee96fe0a13aaa21.tar.bz2
gentoo-2-908e5729d6045ebe5acdc6d32ee96fe0a13aaa21.zip
version bump, solving bugs #139486 and #143496, removing old version.
(Portage version: 2.1.1_rc1-r7)
Diffstat (limited to 'net-proxy/ziproxy')
-rw-r--r--net-proxy/ziproxy/ChangeLog9
-rw-r--r--net-proxy/ziproxy/files/digest-ziproxy-2.1.13
-rw-r--r--net-proxy/ziproxy/files/ziproxy-2.1.confd18
-rw-r--r--net-proxy/ziproxy/files/ziproxy-2.1.initd26
-rw-r--r--net-proxy/ziproxy/ziproxy-2.1.1.ebuild75
5 files changed, 130 insertions, 1 deletions
diff --git a/net-proxy/ziproxy/ChangeLog b/net-proxy/ziproxy/ChangeLog
index 16dfedcf0270..56a4eef1ac9f 100644
--- a/net-proxy/ziproxy/ChangeLog
+++ b/net-proxy/ziproxy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-proxy/ziproxy
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/ziproxy/ChangeLog,v 1.5 2006/07/04 17:33:10 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/ziproxy/ChangeLog,v 1.6 2006/09/08 17:10:52 sbriesen Exp $
+
+*ziproxy-2.1.1 (08 Sep 2006)
+
+ 08 Sep 2006; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/ziproxy-2.1.confd, +files/ziproxy-2.1.initd, -files/ziproxy.confd,
+ -files/ziproxy.initd, -ziproxy-1.5.2.ebuild, +ziproxy-2.1.1.ebuild:
+ version bump, solving bugs #139486 and #143496, removing old version.
*ziproxy-2.0.0 (04 Jul 2006)
diff --git a/net-proxy/ziproxy/files/digest-ziproxy-2.1.1 b/net-proxy/ziproxy/files/digest-ziproxy-2.1.1
new file mode 100644
index 000000000000..51ac5b590c42
--- /dev/null
+++ b/net-proxy/ziproxy/files/digest-ziproxy-2.1.1
@@ -0,0 +1,3 @@
+MD5 74df3faf28e7b4c62ae10bfcfecf1c2c ziproxy-2.1.1.tar.bz2 134973
+RMD160 ce115c3d9cf9b3fbd20fef51e3485df8445ec331 ziproxy-2.1.1.tar.bz2 134973
+SHA256 35b5dd9d06eae54e3e3ce5696a5646f6d1b7dfd15f50ca63598e8e599d3a5fd9 ziproxy-2.1.1.tar.bz2 134973
diff --git a/net-proxy/ziproxy/files/ziproxy-2.1.confd b/net-proxy/ziproxy/files/ziproxy-2.1.confd
new file mode 100644
index 000000000000..0f2c1c24771e
--- /dev/null
+++ b/net-proxy/ziproxy/files/ziproxy-2.1.confd
@@ -0,0 +1,18 @@
+# configuraton file for /etc/init.d/ziproxy
+#
+# you can symlink /etc/init.d/zipproxy to a different name
+# and can copy this config to a new file with the same name
+# as the symlinked init-script to run multiple instances of
+# ziproxy. You have then to change the location for CONFIG
+# of course... ;-)
+
+# Full path to ziproxy.conf file (instead of default one).
+#
+#CONFIG="/etc/ziproxy.conf"
+
+# Limit incoming connections only from the specified address(es).
+# This option has the same meaning, but higher precedence as
+# "OnlyFrom=" option in configuration file. Uncomment it
+# if you want to set it.
+#
+#ONLYFROM="<IP.address or hostname>"
diff --git a/net-proxy/ziproxy/files/ziproxy-2.1.initd b/net-proxy/ziproxy/files/ziproxy-2.1.initd
new file mode 100644
index 000000000000..fcbfcad01356
--- /dev/null
+++ b/net-proxy/ziproxy/files/ziproxy-2.1.initd
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/ziproxy/files/ziproxy-2.1.initd,v 1.1 2006/09/08 17:10:52 sbriesen Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ local OPT="-d"
+ ebegin "Starting ziproxy"
+
+ [ -n "${CONFIG}" ] && OPT="${OPT} -c ${CONFIG}"
+ [ -n "${ONLYFROM}" ] && OPT="${OPT} -f ${ONLYFROM}"
+
+ start-stop-daemon --quiet --start --pidfile /var/run/ziproxy.pid \
+ --chuid ziproxy:ziproxy --exec /usr/sbin/ziproxy -- ${OPT} > /var/run/ziproxy.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ziproxy"
+ start-stop-daemon --stop --quiet --pidfile /var/run/ziproxy.pid
+ eend $?
+}
diff --git a/net-proxy/ziproxy/ziproxy-2.1.1.ebuild b/net-proxy/ziproxy/ziproxy-2.1.1.ebuild
new file mode 100644
index 000000000000..1e3782250b79
--- /dev/null
+++ b/net-proxy/ziproxy/ziproxy-2.1.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/ziproxy/ziproxy-2.1.1.ebuild,v 1.1 2006/09/08 17:10:52 sbriesen Exp $
+
+inherit eutils
+
+DESCRIPTION="A forwarding, non-caching, compressing web proxy server"
+HOMEPAGE="http://ziproxy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="jpeg2k xinetd"
+
+DEPEND="dev-libs/confuse
+ media-libs/giflib
+ media-libs/libpng
+ media-libs/jpeg
+ sys-libs/zlib
+ jpeg2k? ( media-libs/jasper )
+ xinetd? ( virtual/inetd )"
+
+
+pkg_setup() {
+ enewgroup ziproxy
+ enewuser ziproxy -1 -1 -1 ziproxy
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix sample config file
+ sed -i -e "s:/usr/local/ziproxy/\(ziproxy.passwd\):/etc/\1:g" \
+ -e "s:/var/ziproxy/:/var/lib/ziproxy/:g" etc/ziproxy.conf
+
+ # fix sample xinetd config
+ sed -i -e "s:/usr/bin/:/usr/sbin/:g" \
+ -e "s:\(.*port.*\):\1\n\ttype\t\t\t= UNLISTED:g" \
+ -e "s:root:ziproxy:g" etc/xinetd.d/ziproxy
+}
+
+src_compile() {
+ local myconf="--enable-shared-confuse --with-cfgfile=/etc/ziproxy.conf" # --enable-testprogs
+ use jpeg2k && myconf="${myconf} --with-jasper" # use_with doesn't work
+ econf --bindir="/usr/sbin" ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ newbin stats.awk ${PN}-stats.awk
+
+ newinitd "${FILESDIR}/${PN}-${PV%.*}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}-${PV%.*}.confd" ${PN}
+
+ dodoc ChangeLog CREDITS README
+ use jpeg2k && dodoc JPEG2000.txt
+
+ insinto /etc
+ doins etc/ziproxy.conf
+
+ insinto /var/lib/ziproxy/error
+ doins var/ziproxy/error/*.html
+
+ if use xinetd; then
+ insinto /etc/xinetd.d
+ doins etc/xinetd.d/ziproxy
+ fi
+
+ diropts -m0750 -o ziproxy -g ziproxy
+ keepdir /var/log/ziproxy
+}