summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-06-20 22:04:36 +0000
committerAlin Năstac <mrness@gentoo.org>2008-06-20 22:04:36 +0000
commitf458a7006a578ffa123d0ea2c60f66ceb89f8103 (patch)
tree01dcebddf4447f2d06de368cacd9f85ac544b68f /net-proxy/squidguard
parentffmpeg plugin will not be built if we are usingg too recent ffmpeg, adjust de... (diff)
downloadgentoo-2-f458a7006a578ffa123d0ea2c60f66ceb89f8103.tar.gz
gentoo-2-f458a7006a578ffa123d0ea2c60f66ceb89f8103.tar.bz2
gentoo-2-f458a7006a578ffa123d0ea2c60f66ceb89f8103.zip
Fix bypass vulnerability (#228593). Use eautoreconf instead eautoconf.
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-proxy/squidguard')
-rw-r--r--net-proxy/squidguard/ChangeLog8
-rw-r--r--net-proxy/squidguard/files/squidguard-1.3-autoheader.patch52
-rw-r--r--net-proxy/squidguard/squidguard-1.3-r1.ebuild74
3 files changed, 133 insertions, 1 deletions
diff --git a/net-proxy/squidguard/ChangeLog b/net-proxy/squidguard/ChangeLog
index 7ee2012d44f1..67b76be7bf83 100644
--- a/net-proxy/squidguard/ChangeLog
+++ b/net-proxy/squidguard/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/squidguard
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidguard/ChangeLog,v 1.18 2008/02/17 08:05:47 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidguard/ChangeLog,v 1.19 2008/06/20 22:04:35 mrness Exp $
+
+*squidguard-1.3-r1 (20 Jun 2008)
+
+ 20 Jun 2008; Alin Năstac <mrness@gentoo.org>
+ +files/squidguard-1.3-autoheader.patch, +squidguard-1.3-r1.ebuild:
+ Fix bypass vulnerability (#228593). Use eautoreconf instead eautoconf.
*squidguard-1.3 (17 Feb 2008)
diff --git a/net-proxy/squidguard/files/squidguard-1.3-autoheader.patch b/net-proxy/squidguard/files/squidguard-1.3-autoheader.patch
new file mode 100644
index 000000000000..852d1004b22c
--- /dev/null
+++ b/net-proxy/squidguard/files/squidguard-1.3-autoheader.patch
@@ -0,0 +1,52 @@
+diff -Nru squidGuard-1.3.orig/configure.in squidGuard-1.3/configure.in
+--- squidGuard-1.3.orig/configure.in 2008-06-20 23:20:34.000000000 +0200
++++ squidGuard-1.3/configure.in 2008-06-20 23:28:06.000000000 +0200
+@@ -58,18 +58,18 @@
+ sg_dbhome=$withval)
+
+ if test -n "$sg_config"; then
+- AC_DEFINE(ACCONFIG)
++ AC_DEFINE(ACCONFIG, 1, [Defined if you supply --with-sg-config])
+ changequote(, )dnl
+ sg_cfgdir=`echo $sg_config|sed "s%/[^/][^/]*$%%"`
+ changequote([, ])dnl
+ fi
+
+ if test -n "$sg_logdir"; then
+- AC_DEFINE(ACLOGDIR)
++ AC_DEFINE(ACLOGDIR, 1, [Defined if you supply --with-sg-logdir])
+ fi
+
+ if test -n "$sg_dbhome"; then
+- AC_DEFINE(ACDBHOME)
++ AC_DEFINE(ACDBHOME, 1, [Defined if you supply --with-sg-dbhome])
+ fi
+
+ CFLAGS="$CFLAGS $db_inc"
+@@ -126,7 +126,7 @@
+ ])
+ fi
+ if test "$with_ldap" = "yes"; then
+- AC_DEFINE(HAVE_LIBLDAP)
++ AC_DEFINE(HAVE_LIBLDAP, 1, [Define if LDAP support should be compiled])
+ AC_RUN_IFELSE([
+ #include <ldap.h>
+ int main()
+@@ -220,7 +220,7 @@
+ ], dbg2_ok_version=yes, dbg2_ok_version=no, dbg2_ok_version=no)
+
+ if test $dbg2_ok_version = yes; then
+- AC_DEFINE(DB_VERSION_GT2)
++ AC_DEFINE(DB_VERSION_GT2, 1, [Define if you have dbversion greater than 3.2])
+ fi
+
+ AC_RUN_IFELSE([
+@@ -238,7 +238,7 @@
+ ], dbg3_ok_version=yes, dbg3_ok_version=no, dbg3_ok_version=no)
+
+ if test $dbg3_ok_version = yes; then
+- AC_DEFINE(DB_VERSION_GT3)
++ AC_DEFINE(DB_VERSION_GT3, 1, [Define if you have dbversion greater than 4.0])
+ fi
+
+
diff --git a/net-proxy/squidguard/squidguard-1.3-r1.ebuild b/net-proxy/squidguard/squidguard-1.3-r1.ebuild
new file mode 100644
index 000000000000..748e375974bd
--- /dev/null
+++ b/net-proxy/squidguard/squidguard-1.3-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidguard/squidguard-1.3-r1.ebuild,v 1.1 2008/06/20 22:04:35 mrness Exp $
+
+WANT_AUTOMAKE=none
+
+inherit eutils autotools
+
+DESCRIPTION="Combined filter, redirector and access controller plugin for Squid."
+HOMEPAGE="http://www.squidguard.org"
+SRC_URI="http://www.squidguard.org/Downloads/squidGuard-${PV}.tar.gz
+ http://www.squidguard.org/Downloads/Patches/${PV}/squidGuard-${PV}-patch-20080613.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="ldap"
+
+RDEPEND="net-proxy/squid
+ >=sys-libs/db-2
+ ldap? ( net-nds/openldap )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+S="${WORKDIR}/squidGuard-${PV}"
+
+RESTRICT="test" # tests are currently broken
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ cp ../squidGuard-${PV}-patch-20080613/src/sgDiv.c.in src/ || die "failed to replace sgDiv.c.in"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch "${FILESDIR}/${P}-autoheader.patch"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_with ldap) \
+ --with-sg-config=/etc/squidGuard/squidGuard.conf \
+ --with-sg-logdir=/var/log/squidGuard \
+ || die "configure has failed"
+
+ emake || die "make has failed"
+}
+
+src_install() {
+ emake prefix="/usr" INSTDIR="${D}" install || die "emake install has failed"
+
+ keepdir /var/log/squidGuard
+ fowners squid:squid /var/log/squidGuard
+
+ insinto /etc/squidGuard/sample
+ doins "${FILESDIR}"/squidGuard.conf.*
+ insinto /etc/squidGuard/sample/db
+ doins "${FILESDIR}"/blockedsites
+
+ dodoc ANNOUNCE CHANGELOG README
+ dohtml doc/*.html
+ docinto text
+ dodoc doc/*.txt
+}
+
+pkg_postinst() {
+ einfo "To enable squidGuard, add the following lines to /etc/squid/squid.conf:"
+ einfo " url_rewrite_program /usr/bin/squidGuard"
+ einfo " url_rewrite_children 10"
+ einfo ""
+ einfo "Remember to edit /etc/squidGuard/squidGuard.conf first!"
+ einfo "Examples can be found in /etc/squidGuard/sample/"
+}