summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-02-21 11:35:00 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-02-21 11:35:00 +0000
commitd9b457d39180247711b1bd09f1d1b33dfc75cc98 (patch)
tree5bf89422de7af9b1590423f9ac03e169499a65e6 /net-print
parentMigrate to distutils-r1. Enable a subset of tests. (diff)
downloadgentoo-2-d9b457d39180247711b1bd09f1d1b33dfc75cc98.tar.gz
gentoo-2-d9b457d39180247711b1bd09f1d1b33dfc75cc98.tar.bz2
gentoo-2-d9b457d39180247711b1bd09f1d1b33dfc75cc98.zip
Put back version 1.2.9. Raise dep on 1.2.10 to 1.6 cups and revert it to testing. Fixes bug#458522.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/gtklp/ChangeLog9
-rw-r--r--net-print/gtklp/gtklp-1.2.10.ebuild6
-rw-r--r--net-print/gtklp/gtklp-1.2.9.ebuild48
3 files changed, 59 insertions, 4 deletions
diff --git a/net-print/gtklp/ChangeLog b/net-print/gtklp/ChangeLog
index 0d52f897a40c..559c42929ebd 100644
--- a/net-print/gtklp/ChangeLog
+++ b/net-print/gtklp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-print/gtklp
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/ChangeLog,v 1.51 2013/02/20 14:07:26 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/ChangeLog,v 1.52 2013/02/21 11:35:00 scarabeus Exp $
+
+*gtklp-1.2.9 (21 Feb 2013)
+
+ 21 Feb 2013; Tomáš Chvátal <scarabeus@gentoo.org> +gtklp-1.2.9.ebuild,
+ gtklp-1.2.10.ebuild:
+ Put back version 1.2.9. Raise dep on 1.2.10 to 1.6 cups and revert it to
+ testing. Fixes bug#458522.
20 Feb 2013; Tomáš Chvátal <scarabeus@gentoo.org> -gtklp-1.2.8a.ebuild,
gtklp-1.2.10.ebuild:
diff --git a/net-print/gtklp/gtklp-1.2.10.ebuild b/net-print/gtklp/gtklp-1.2.10.ebuild
index 96fb2e0a6a34..ce9c99c03b53 100644
--- a/net-print/gtklp/gtklp-1.2.10.ebuild
+++ b/net-print/gtklp/gtklp-1.2.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/gtklp-1.2.10.ebuild,v 1.2 2013/02/20 14:07:26 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/gtklp-1.2.10.ebuild,v 1.3 2013/02/21 11:34:59 scarabeus Exp $
EAPI=5
@@ -13,11 +13,11 @@ SRC_URI="mirror://sourceforge/gtklp/${P}.src.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc ~sparc x86"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="nls ssl"
RDEPEND="x11-libs/gtk+:2
- >=net-print/cups-1.1.12
+ >=net-print/cups-1.6
nls? ( sys-devel/gettext )
ssl? ( dev-libs/openssl )"
DEPEND="${RDEPEND}
diff --git a/net-print/gtklp/gtklp-1.2.9.ebuild b/net-print/gtklp/gtklp-1.2.9.ebuild
new file mode 100644
index 000000000000..43a8eb25c776
--- /dev/null
+++ b/net-print/gtklp/gtklp-1.2.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/gtklp-1.2.9.ebuild,v 1.3 2013/02/21 11:34:59 scarabeus Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A GUI for cupsd"
+HOMEPAGE="http://gtklp.sirtobi.com/"
+SRC_URI="mirror://sourceforge/gtklp/${P}.src.tar.gz
+ mirror://sourceforge/gtklp/logo.xpm.gz -> gtklp-logo.xpm.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE="nls ssl"
+
+RDEPEND="x11-libs/gtk+:2
+ >=net-print/cups-1.1.12
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS BUGS ChangeLog README TODO USAGE"
+
+src_prepare() {
+ sed -e '/DEF_BROWSER_CMD/{s:netscape:firefox:}' \
+ -e '/DEF_HELP_HOME/{s:631/sum.html#STANDARD_OPTIONS:631/help/:}' \
+ -i include/defaults.h || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable ssl) \
+ --enable-forte #369003
+}
+
+src_install () {
+ default
+
+ doicon "${WORKDIR}"/gtklp-logo.xpm
+ make_desktop_entry 'gtklp -i' "Print files via CUPS" gtklp-logo 'System;HardwareSettings;Settings;Printing'
+ make_desktop_entry gtklpq "CUPS queue manager" gtklp-logo 'System;HardwareSettings;Settings;Printing'
+}