summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 13:20:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 13:20:21 +0000
commit86e2e868fa6cb821a02aa91eb1d23940f3cb7887 (patch)
tree00a6ec0115b03bc4e2d08a337e3558d6a976ee91 /net-print
parentAdd --as-needed patch by Kevin Pyle (bug #248017); fix building with glibc 2.10. (diff)
downloadgentoo-2-86e2e868fa6cb821a02aa91eb1d23940f3cb7887.tar.gz
gentoo-2-86e2e868fa6cb821a02aa91eb1d23940f3cb7887.tar.bz2
gentoo-2-86e2e868fa6cb821a02aa91eb1d23940f3cb7887.zip
Add patch to build with --as-needed by Kevin Pyle, closes bug #248163.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/ink/ChangeLog8
-rw-r--r--net-print/ink/files/ink-0.4.1-asneeded.patch10
-rw-r--r--net-print/ink/ink-0.4.1.ebuild17
3 files changed, 29 insertions, 6 deletions
diff --git a/net-print/ink/ChangeLog b/net-print/ink/ChangeLog
index 83e65b9fbcfc..fee4632dc1be 100644
--- a/net-print/ink/ChangeLog
+++ b/net-print/ink/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-print/ink
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/ink/ChangeLog,v 1.11 2007/06/19 07:34:24 genstef Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/ink/ChangeLog,v 1.12 2009/06/02 13:20:20 flameeyes Exp $
+
+ 02 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org> ink-0.4.1.ebuild,
+ +files/ink-0.4.1-asneeded.patch:
+ Add patch to build with --as-needed by Kevin Pyle, closes bug #248163.
*ink-0.4.1 (19 Jun 2007)
diff --git a/net-print/ink/files/ink-0.4.1-asneeded.patch b/net-print/ink/files/ink-0.4.1-asneeded.patch
new file mode 100644
index 000000000000..3c0e248daeb5
--- /dev/null
+++ b/net-print/ink/files/ink-0.4.1-asneeded.patch
@@ -0,0 +1,10 @@
+diff -ru a/Makefile b/Makefile
+--- a/Makefile 2006-09-06 09:06:22.000000000 -0500
++++ b/Makefile 2009-01-17 12:36:44.000000000 -0600
+@@ -1,5 +1,4 @@
+-CFLAGS = -Wall -O2 -L$(PWD)/../../../libinklevel/cvs/libinklevel \
+- -I$(PWD)/../../../libinklevel/cvs/libinklevel -linklevel
++LDLIBS = -linklevel
+ DESTDIR = /usr/local/
+
+ all: ink
diff --git a/net-print/ink/ink-0.4.1.ebuild b/net-print/ink/ink-0.4.1.ebuild
index 77f4679bbb8e..69f211074bd5 100644
--- a/net-print/ink/ink-0.4.1.ebuild
+++ b/net-print/ink/ink-0.4.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/ink/ink-0.4.1.ebuild,v 1.1 2007/06/19 07:34:24 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/ink/ink-0.4.1.ebuild,v 1.2 2009/06/02 13:20:20 flameeyes Exp $
+
+inherit eutils
DESCRIPTION="A command line utility to display the ink level of your printer"
SRC_URI="mirror://sourceforge/ink/${P/_}.tar.gz"
@@ -14,7 +16,14 @@ IUSE=""
DEPEND=">=net-print/libinklevel-0.7.1"
RDEPEND="${DEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+}
+
src_install () {
- emake DESTDIR=${D}/usr install || die "emake install failed"
- dodoc README
+ emake DESTDIR="${D}"/usr install || die "emake install failed"
+ dodoc README || die
}