summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-25 22:12:03 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-25 22:12:03 +0000
commit67e663a4f391134e6246533d14f24a74b3178364 (patch)
treed6e626c6c2d1c1dbe241520262c45414cff283b2 /net-print/libgnomecups/files
parentSupport >=dev-libssofthsm-1.3.1. Thanks to Tom Hendrikx. (diff)
downloadgentoo-2-67e663a4f391134e6246533d14f24a74b3178364.tar.gz
gentoo-2-67e663a4f391134e6246533d14f24a74b3178364.tar.bz2
gentoo-2-67e663a4f391134e6246533d14f24a74b3178364.zip
Fix building with >=glib-2.31 (bug #400789, thanks to Rolf S. Arvidson for reporting). Fix g_list_find_custom() argument order. Don't build static libraries and don't install .la files.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-print/libgnomecups/files')
-rw-r--r--net-print/libgnomecups/files/libgnomecups-0.2.3-g_list_find_custom.patch94
-rw-r--r--net-print/libgnomecups/files/libgnomecups-0.2.3-glib.h.patch38
2 files changed, 132 insertions, 0 deletions
diff --git a/net-print/libgnomecups/files/libgnomecups-0.2.3-g_list_find_custom.patch b/net-print/libgnomecups/files/libgnomecups-0.2.3-g_list_find_custom.patch
new file mode 100644
index 000000000000..3383cde16786
--- /dev/null
+++ b/net-print/libgnomecups/files/libgnomecups-0.2.3-g_list_find_custom.patch
@@ -0,0 +1,94 @@
+From 14979a2356fd751d82d037db65ce92072097bbf3 Mon Sep 17 00:00:00 2001
+From: Kjartan Maraas <kmaraas@gnome.org>
+Date: Wed, 30 Jan 2008 17:30:43 +0000
+Subject: [PATCH] Fix some warnings. Fix wrong order of arguments to
+ g_list_find_custom.
+
+2008-01-30 Kjartan Maraas <kmaraas@gnome.org>
+
+ * libgnomecups/gnome-cups-printer.c: (set_timeout),
+ (gnome_cups_printer_get_state_name),
+ (_gnome_cups_printer_get_host): Fix some warnings.
+ * libgnomecups/gnome-cups-queue.c: (gnome_cups_queue_get_job):
+ Fix wrong order of arguments to g_list_find_custom.
+
+svn path=/trunk/; revision=237
+---
+ ChangeLog | 8 ++++++++
+ libgnomecups/gnome-cups-printer.c | 7 +++----
+ libgnomecups/gnome-cups-queue.c | 4 ++--
+ 3 files changed, 13 insertions(+), 6 deletions(-)
+
+diff --git a/ChangeLog b/ChangeLog
+index b41ac9e..166c87a 100644
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -1,3 +1,11 @@
++2008-01-30 Kjartan Maraas <kmaraas@gnome.org>
++
++ * libgnomecups/gnome-cups-printer.c: (set_timeout),
++ (gnome_cups_printer_get_state_name),
++ (_gnome_cups_printer_get_host): Fix some warnings.
++ * libgnomecups/gnome-cups-queue.c: (gnome_cups_queue_get_job):
++ Fix wrong order of arguments to g_list_find_custom.
++
+ 2008-01-18 Gil Forcada <gforcada@gnome.org>
+
+ * configure.in: Added mk, tr and zh_HK to ALL_LINGUAS.
+diff --git a/libgnomecups/gnome-cups-printer.c b/libgnomecups/gnome-cups-printer.c
+index 9c5c7d3..704f205 100644
+--- a/libgnomecups/gnome-cups-printer.c
++++ b/libgnomecups/gnome-cups-printer.c
+@@ -791,7 +791,7 @@ set_timeout (void)
+
+ if (should_timeout && !update_timeout_id) {
+ update_timeout_id = g_timeout_add (UPDATE_TIMEOUT,
+- update_printers_timeout,
++ (GSourceFunc)update_printers_timeout,
+ NULL);
+ } else if (!should_timeout && update_timeout_id) {
+ g_source_remove (update_timeout_id);
+@@ -1069,7 +1069,6 @@ gnome_cups_printer_get_state (GnomeCupsPrinter *printer)
+ const char *
+ gnome_cups_printer_get_state_name (GnomeCupsPrinter *printer)
+ {
+- const char *state_str;
+ ipp_pstate_t state;
+
+ g_return_val_if_fail (GNOME_CUPS_IS_PRINTER (printer), NULL);
+@@ -1079,7 +1078,7 @@ gnome_cups_printer_get_state_name (GnomeCupsPrinter *printer)
+
+ state = printer->details->state;
+
+- return state_str = _(printer_state_strings[state - IPP_PRINTER_IDLE]);
++ return _(printer_state_strings[state - IPP_PRINTER_IDLE]);
+ }
+
+ const char *
+@@ -2001,7 +2000,7 @@ _gnome_cups_printer_get_host (GnomeCupsPrinter *printer)
+ {
+ gchar *host = NULL;
+
+-#warning this is broken for smb://user:pass@host/printer urls
++ /* warning this is broken for smb://user:pass@host/printer urls */
+ if (go_directly_to_printer_when_possible &&
+ printer->details->printer_uri) {
+ gchar *x, *y;
+diff --git a/libgnomecups/gnome-cups-queue.c b/libgnomecups/gnome-cups-queue.c
+index d9b9a92..9f98ed9 100644
+--- a/libgnomecups/gnome-cups-queue.c
++++ b/libgnomecups/gnome-cups-queue.c
+@@ -413,8 +413,8 @@ gnome_cups_queue_get_job (GnomeCupsQueue *queue,
+ {
+ if (cache_ok) {
+ GList *link = g_list_find_custom (queue->details->jobs,
+- (GCompareFunc) find_job_by_id,
+- GINT_TO_POINTER (job_id));
++ GINT_TO_POINTER (job_id),
++ (GCompareFunc) find_job_by_id);
+ if (link)
+ return gnome_cups_job_dup (link->data);
+ }
+--
+1.7.8.4
+
diff --git a/net-print/libgnomecups/files/libgnomecups-0.2.3-glib.h.patch b/net-print/libgnomecups/files/libgnomecups-0.2.3-glib.h.patch
new file mode 100644
index 000000000000..3f73af861c04
--- /dev/null
+++ b/net-print/libgnomecups/files/libgnomecups-0.2.3-glib.h.patch
@@ -0,0 +1,38 @@
+From d84eee9450b3b6f6155074915efc61bedcc8d446 Mon Sep 17 00:00:00 2001
+From: Dominique Leuenberger <dimstar@opensuse.org>
+Date: Sun, 27 Nov 2011 21:36:41 +0100
+Subject: [PATCH] Fix: Only glib.h can be included
+
+---
+ libgnomecups/gnome-cups-i18n.c | 2 +-
+ libgnomecups/gnome-cups-init.h | 3 +--
+ 2 files changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/libgnomecups/gnome-cups-i18n.c b/libgnomecups/gnome-cups-i18n.c
+index 8987c5c..127756d 100644
+--- a/libgnomecups/gnome-cups-i18n.c
++++ b/libgnomecups/gnome-cups-i18n.c
+@@ -1,5 +1,5 @@
+ #include <config.h>
+-#include <glib/gmacros.h>
++#include <glib.h>
+ #include "gnome-cups-i18n.h"
+
+ #ifdef ENABLE_NLS
+diff --git a/libgnomecups/gnome-cups-init.h b/libgnomecups/gnome-cups-init.h
+index 22b682a..c4600fc 100644
+--- a/libgnomecups/gnome-cups-init.h
++++ b/libgnomecups/gnome-cups-init.h
+@@ -1,8 +1,7 @@
+ #ifndef GNOME_CUPS_INIT
+ #define GNOME_CUPS_INIT
+
+-#include <glib/gtypes.h>
+-#include <glib/gmacros.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+
+--
+1.7.7
+