summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2009-11-14 16:33:06 +0000
committerDaniel Pielmeier <billie@gentoo.org>2009-11-14 16:33:06 +0000
commite1e5415361e0aa54895e0128cf50e77196afd802 (patch)
tree84c41c0cc65957ecff73893f2318a73691d90f58 /net-print/hplip
parentDrop packages planned for removal. (diff)
downloadgentoo-2-e1e5415361e0aa54895e0128cf50e77196afd802.tar.gz
gentoo-2-e1e5415361e0aa54895e0128cf50e77196afd802.tar.bz2
gentoo-2-e1e5415361e0aa54895e0128cf50e77196afd802.zip
Converted some ebuild hackery into patches for upstream integration.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-print/hplip')
-rw-r--r--net-print/hplip/ChangeLog6
-rw-r--r--net-print/hplip/files/hplip-3.9.10-browser.patch38
-rw-r--r--net-print/hplip/files/hplip-3.9.10-desktop.patch18
-rw-r--r--net-print/hplip/hplip-3.9.10.ebuild14
4 files changed, 66 insertions, 10 deletions
diff --git a/net-print/hplip/ChangeLog b/net-print/hplip/ChangeLog
index 5bab7c4d391f..a98a3c236660 100644
--- a/net-print/hplip/ChangeLog
+++ b/net-print/hplip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-print/hplip
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.131 2009/11/12 21:34:46 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.132 2009/11/14 16:33:06 billie Exp $
+
+ 14 Nov 2009; Daniel Pielmeier <billie@gentoo.org> hplip-3.9.10.ebuild,
+ +files/hplip-3.9.10-browser.patch, +files/hplip-3.9.10-desktop.patch:
+ Converted some ebuild hackery into patches for upstream integration.
*hplip-3.9.10 (12 Nov 2009)
diff --git a/net-print/hplip/files/hplip-3.9.10-browser.patch b/net-print/hplip/files/hplip-3.9.10-browser.patch
new file mode 100644
index 000000000000..46c4f634f36d
--- /dev/null
+++ b/net-print/hplip/files/hplip-3.9.10-browser.patch
@@ -0,0 +1,38 @@
+--- base/utils.py.old 2009-11-14 15:23:29.000000000 +0100
++++ base/utils.py 2009-11-14 15:37:53.000000000 +0100
+@@ -812,13 +812,15 @@
+ return True
+
+
+-BROWSERS = ['firefox', 'mozilla', 'konqueror', 'galeon', 'skipstone'] # in preferred order
+-BROWSER_OPTS = {'firefox': '-new-window', 'mozilla' : '', 'konqueror': '', 'galeon': '-w', 'skipstone': ''}
++BROWSERS = ['firefox', 'mozilla', 'konqueror', 'epiphany', 'skipstone'] # in preferred order
++BROWSER_OPTS = {'firefox': '-new-tab', 'mozilla': '', 'konqueror': '', 'epiphany': '--new-tab', 'skipstone': ''}
+
+
+ def find_browser():
+ if platform_avail and platform.system() == 'Darwin':
+ return "open"
++ if platform_avail and platform.system() == 'Linux' and which("xdg-open"):
++ return "xdg-open"
+ else:
+ for b in BROWSERS:
+ if which(b):
+@@ -832,11 +834,14 @@
+ cmd = 'open "%s"' % url
+ log.debug(cmd)
+ os.system(cmd)
++ if platform_avail and platform.system() == 'Linux' and which("xdg-open"):
++ cmd = 'xdg-open "%s"' % url
++ log.debug(cmd)
++ os.system(cmd)
+ else:
+ for b in BROWSERS:
+- bb = which(b)
+- if bb:
+- bb = os.path.join(bb, b)
++ if b:
++ bb = which(b, return_full_path='True')
+ if use_browser_opts:
+ cmd = """%s %s "%s" &""" % (bb, BROWSER_OPTS[b], url)
+ else:
diff --git a/net-print/hplip/files/hplip-3.9.10-desktop.patch b/net-print/hplip/files/hplip-3.9.10-desktop.patch
new file mode 100644
index 000000000000..4713cefede3c
--- /dev/null
+++ b/net-print/hplip/files/hplip-3.9.10-desktop.patch
@@ -0,0 +1,18 @@
+--- Makefile.am.old 2009-11-06 22:56:26.000000000 +0100
++++ Makefile.am 2009-11-14 16:50:39.000000000 +0100
+@@ -325,6 +325,7 @@
+ hppgsz_CFLAGS = $(libapdk_la_CFLAGS)
+ hppgsz_LDADD = libapdk.la -ljpeg -ldl
+
++if GUI_BUILD
+ # hplip.desktop
+ hplip_desktopdir = $(icondir)
+ hplip_desktop_DATA = hplip.desktop
+@@ -332,6 +333,7 @@
+ # hplip-systray.desktop
+ hplip_systraydir = $(systraydir)
+ hplip_systray_DATA = hplip-systray.desktop
++endif
+
+ # hpipjs (CUPS filter)
+ hplipjsdir = $(cupsfilterdir)
diff --git a/net-print/hplip/hplip-3.9.10.ebuild b/net-print/hplip/hplip-3.9.10.ebuild
index ea99a6d78a26..279f553efb4b 100644
--- a/net-print/hplip/hplip-3.9.10.ebuild
+++ b/net-print/hplip/hplip-3.9.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.9.10.ebuild,v 1.1 2009/11/12 21:34:46 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.9.10.ebuild,v 1.2 2009/11/14 16:33:06 billie Exp $
EAPI="2"
@@ -91,9 +91,10 @@ pkg_setup() {
}
src_prepare() {
- sed -i -e "s/'skipstone']/'skipstone', 'epiphany']/" \
- -e "s/'skipstone': ''}/'skipstone': '', 'epiphany': '--new-window'}/" \
- base/utils.py || die "Sed base/utils.py failed"
+ # Upstream bug: https://bugs.launchpad.net/hplip/+bug/452113
+ epatch "${FILESDIR}"/${P}-desktop.patch
+ # Upstream bug: https://bugs.launchpad.net/hplip/+bug/482674
+ epatch "${FILESDIR}"/${P}-browser.patch
# bug 98428
sed -i -e "s:/usr/bin/env python:/usr/bin/python:g" hpssd.py || die "Sed hpssd.py failed"
@@ -237,11 +238,6 @@ src_install() {
# Bug #201023
rm -f "${D}"/etc/sane.d/dll.conf
- # bug 106035/259763
- if ! use qt3 && ! use qt4 ; then
- rm -r "${D}"/usr/share/applications "${D}"/etc/xdg
- fi
-
# kde3 autostart hack
if [[ -d /usr/kde/3.5/share/autostart ]] && use !minimal ; then
insinto /usr/kde/3.5/share/autostart