summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-08-29 21:21:53 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-08-29 21:21:53 +0000
commit41ecd831b2f2f5b983b2f153a85e23ae97dbf5b5 (patch)
tree94d7ece551f679ec12addc4e50abbab192f960a4 /net-print/gnome-cups-manager
parentVersion bump. (diff)
downloadgentoo-2-41ecd831b2f2f5b983b2f153a85e23ae97dbf5b5.tar.gz
gentoo-2-41ecd831b2f2f5b983b2f153a85e23ae97dbf5b5.tar.bz2
gentoo-2-41ecd831b2f2f5b983b2f153a85e23ae97dbf5b5.zip
Do not add CFLAGS to CXXFLAGS, bug #234028. Fix automagic samba support, bug #288392.
(Portage version: 2.2_rc68/cvs/Linux x86_64)
Diffstat (limited to 'net-print/gnome-cups-manager')
-rw-r--r--net-print/gnome-cups-manager/ChangeLog11
-rw-r--r--net-print/gnome-cups-manager/files/gnome-cups-manager-0.33-automagic-samba.patch32
-rw-r--r--net-print/gnome-cups-manager/files/gnome-cups-manager-0.33-cxxflags-separation.patch71
-rw-r--r--net-print/gnome-cups-manager/gnome-cups-manager-0.33-r2.ebuild69
4 files changed, 182 insertions, 1 deletions
diff --git a/net-print/gnome-cups-manager/ChangeLog b/net-print/gnome-cups-manager/ChangeLog
index 024b3cd4ac04..60ea8fcbdedb 100644
--- a/net-print/gnome-cups-manager/ChangeLog
+++ b/net-print/gnome-cups-manager/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-print/gnome-cups-manager
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/gnome-cups-manager/ChangeLog,v 1.95 2010/07/20 15:39:48 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/gnome-cups-manager/ChangeLog,v 1.96 2010/08/29 21:21:53 eva Exp $
+
+*gnome-cups-manager-0.33-r2 (29 Aug 2010)
+
+ 29 Aug 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnome-cups-manager-0.33-r2.ebuild,
+ +files/gnome-cups-manager-0.33-automagic-samba.patch,
+ +files/gnome-cups-manager-0.33-cxxflags-separation.patch:
+ Do not add CFLAGS to CXXFLAGS, bug #234028. Fix automagic samba support,
+ bug #288392.
20 Jul 2010; Jeroen Roovers <jer@gentoo.org>
gnome-cups-manager-0.33-r1.ebuild:
diff --git a/net-print/gnome-cups-manager/files/gnome-cups-manager-0.33-automagic-samba.patch b/net-print/gnome-cups-manager/files/gnome-cups-manager-0.33-automagic-samba.patch
new file mode 100644
index 000000000000..a834d4c8ba39
--- /dev/null
+++ b/net-print/gnome-cups-manager/files/gnome-cups-manager-0.33-automagic-samba.patch
@@ -0,0 +1,32 @@
+From d3750520a2b23d0757504941ba2066cb63b320d0 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 29 Aug 2010 16:30:23 +0200
+Subject: [PATCH] [gentoo] Fix automagic samba support
+
+---
+ configure.in | 6 +++++-
+ 1 files changed, 5 insertions(+), 1 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index bb15f54..c96fcba 100644
+--- a/configure.in
++++ b/configure.in
+@@ -28,10 +28,14 @@ LIBBONOBO_REQUIRED=2.0.0
+ LIBGNOMECUPS_REQUIRED=0.2.0
+
+ SMBLIBS=
++AC_ARG_ENABLE([samba],
++ AS_HELP_STRING([--enable-samba], [enable samba support]))
++if test "$enable_samba" = "yes"; then
+ AC_CHECK_LIB(smbclient, smbc_opendir, [
+ AC_DEFINE(HAVE_LIBSMBCLIENT, [], ["Do we have libsmbclient"])
+ SMBLIBS=-lsmbclient
+-])
++], [AC_MSG_ERROR([libsmclient not found])])
++fi
+ AC_SUBST(SMBLIBS)
+ AC_SUBST(LIBGNOME_REQUIRED)
+ AC_SUBST(LIBGNOMEUI_REQUIRED)
+--
+1.7.2.2
+
diff --git a/net-print/gnome-cups-manager/files/gnome-cups-manager-0.33-cxxflags-separation.patch b/net-print/gnome-cups-manager/files/gnome-cups-manager-0.33-cxxflags-separation.patch
new file mode 100644
index 000000000000..a8ca8646384a
--- /dev/null
+++ b/net-print/gnome-cups-manager/files/gnome-cups-manager-0.33-cxxflags-separation.patch
@@ -0,0 +1,71 @@
+From f798321d4d7e3059bc51730124f9da9d5c2aff9f Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 29 Aug 2010 15:21:17 +0200
+Subject: [PATCH] [gentoo] Do not add CFLAGS to CPPFLAGS
+
+---
+ configure.in | 1 +
+ gnome-cups-add/Makefile.am | 6 ++++--
+ gnome-cups-manager/Makefile.am | 6 ++++--
+ libgnomecups/Makefile.am | 6 ++++--
+ 4 files changed, 13 insertions(+), 6 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 88902da..bb15f54 100644
+--- a/configure.in
++++ b/configure.in
+@@ -16,6 +16,7 @@ AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
+
+ GNOME_COMPILE_WARNINGS(maximum)
+
++AC_PROG_CC
+ AC_PROG_CXX
+
+ GTK_REQUIRED=2.3.1
+diff --git a/gnome-cups-add/Makefile.am b/gnome-cups-add/Makefile.am
+index 2d5ceee..9c16248 100644
+--- a/gnome-cups-add/Makefile.am
++++ b/gnome-cups-add/Makefile.am
+@@ -1,5 +1,7 @@
+-INCLUDES = \
+- $(WARN_CFLAGS) \
++AM_CFLAGS = $(WARN_CFLAGS)
++AM_CXXFLAGS = $(WARN_CXXFLAGS)
++
++AM_CPPFLAGS = \
+ $(GNOME_CFLAGS) \
+ -I$(top_srcdir) \
+ -DPREFIX=\""$(prefix)"\" \
+diff --git a/gnome-cups-manager/Makefile.am b/gnome-cups-manager/Makefile.am
+index b8fe59a..86721ad 100644
+--- a/gnome-cups-manager/Makefile.am
++++ b/gnome-cups-manager/Makefile.am
+@@ -1,5 +1,7 @@
+-INCLUDES = \
+- $(WARN_CFLAGS) \
++AM_CFLAGS = $(WARN_CFLAGS)
++AM_CXXFLAGS = $(WARN_CXXFLAGS)
++
++AM_CPPFLAGS = \
+ $(GNOME_CFLAGS) \
+ -I$(top_srcdir) \
+ -DPREFIX=\""$(prefix)"\" \
+diff --git a/libgnomecups/Makefile.am b/libgnomecups/Makefile.am
+index 75a2fc7..6b8cea0 100644
+--- a/libgnomecups/Makefile.am
++++ b/libgnomecups/Makefile.am
+@@ -1,7 +1,9 @@
+ SUBDIRS=snmpkit
+
+-INCLUDES = \
+- $(WARN_CFLAGS) \
++AM_CFLAGS = $(WARN_CFLAGS)
++AM_CXXFLAGS = $(WARN_CXXFLAGS)
++
++AM_CPPFLAGS = \
+ $(GNOME_CFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+--
+1.7.2.2
+
diff --git a/net-print/gnome-cups-manager/gnome-cups-manager-0.33-r2.ebuild b/net-print/gnome-cups-manager/gnome-cups-manager-0.33-r2.ebuild
new file mode 100644
index 000000000000..21293f58ae2c
--- /dev/null
+++ b/net-print/gnome-cups-manager/gnome-cups-manager-0.33-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/gnome-cups-manager/gnome-cups-manager-0.33-r2.ebuild,v 1.1 2010/08/29 21:21:53 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2 flag-o-matic
+
+DESCRIPTION="GNOME CUPS Printer Management Interface"
+HOMEPAGE="http://www.gnome.org/"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${PN}-patches-${PV}-r1.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="samba"
+
+# FIXME: samba support is automatic
+COMMON=">=x11-libs/gtk+-2.3.1
+ >=dev-libs/glib-2.3.1
+ >=gnome-base/libgnome-2.14
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/libglade-2
+ >=gnome-base/libbonobo-2
+ >=net-print/libgnomecups-0.2.3
+ gnome-base/gnome-keyring
+ samba? ( net-fs/samba[smbclient] )"
+
+RDEPEND="${COMMON}
+ x11-libs/gksu"
+
+DEPEND="${COMMON}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35"
+
+DOCS="ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-static $(use_enable samba)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Do not add CFLAGS to CPPFLAGS, bug #234028
+ epatch "${FILESDIR}/${PN}-0.33-cxxflags-separation.patch"
+
+ # Fix automagic samba support, bug #288392
+ epatch "${FILESDIR}/${PN}-0.33-automagic-samba.patch"
+
+ # Apply ubuntu patchset
+ rm "${WORKDIR}"/patches/140_all_ui_tooltip.patch || \
+ die "removing patch failed"
+ export EPATCH_SOURCE="${WORKDIR}/patches" \
+ EPATCH_SUFFIX="patch" \
+ EPATCH_MULTI_MSG="Applying Ubuntu patches (enhancements) ..."
+ epatch
+
+ intltoolize --force --copy --automake || die
+ eautoreconf
+}
+
+src_install() {
+ gnome2_src_install
+ # debian-specific.
+ rm "${D}"/usr/sbin/gnome-cups-switch
+}