summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2005-04-26 21:54:48 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2005-04-26 21:54:48 +0000
commiteca1bafbaf70178bc8af4b4e4a2c35f38d75f924 (patch)
tree7b0c0e5c3df6abc56ee9d6916cc042026fd7ed54 /net-p2p
parentfixed metadata.xml (diff)
downloadgentoo-2-eca1bafbaf70178bc8af4b4e4a2c35f38d75f924.tar.gz
gentoo-2-eca1bafbaf70178bc8af4b4e4a2c35f38d75f924.tar.bz2
gentoo-2-eca1bafbaf70178bc8af4b4e4a2c35f38d75f924.zip
Version bump, bug #88772
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bittornado/ChangeLog8
-rw-r--r--net-p2p/bittornado/bittornado-0.3.12.ebuild74
-rw-r--r--net-p2p/bittornado/files/digest-bittornado-0.3.121
3 files changed, 82 insertions, 1 deletions
diff --git a/net-p2p/bittornado/ChangeLog b/net-p2p/bittornado/ChangeLog
index 5be8987e41b6..abc20a3c48a8 100644
--- a/net-p2p/bittornado/ChangeLog
+++ b/net-p2p/bittornado/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/bittornado
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/ChangeLog,v 1.34 2005/04/09 12:48:04 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/ChangeLog,v 1.35 2005/04/26 21:54:48 sekretarz Exp $
+
+*bittornado-0.3.12 (26 Apr 2005)
+
+ 26 Apr 2005; Karol Wojtaszek <sekretarz@gentoo.org>
+ +bittornado-0.3.12.ebuild:
+ Version bump, bug #88772
09 Apr 2005; Markus Rothe <corsair@gentoo.org> bittornado-0.3.10.ebuild:
Stable on ppc64
diff --git a/net-p2p/bittornado/bittornado-0.3.12.ebuild b/net-p2p/bittornado/bittornado-0.3.12.ebuild
new file mode 100644
index 000000000000..fc2edb3c6555
--- /dev/null
+++ b/net-p2p/bittornado/bittornado-0.3.12.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/bittornado-0.3.12.ebuild,v 1.1 2005/04/26 21:54:48 sekretarz Exp $
+
+inherit distutils eutils
+
+MY_PN="BitTornado"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="TheShad0w's experimental BitTorrent client"
+HOMEPAGE="http://www.bittornado.com/"
+SRC_URI="http://bittornado.com/download/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~ppc64 ~alpha"
+IUSE="X"
+
+RDEPEND="X? ( >=dev-python/wxpython-2.4 )
+ >=dev-lang/python-2.1
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ >=sys-apps/sed-4.0.5"
+PROVIDE="virtual/bittorrent"
+
+S="${WORKDIR}/${MY_PN}-CVS"
+PIXMAPLOC="/usr/share/pixmaps/bittornado"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # fixes wrong icons path
+ sed -i "s:os.path.abspath(os.path.dirname(os.path.realpath(sys.argv\[0\]))):\"${PIXMAPLOC}/\":" btdownloadgui.py
+ # fixes a bug with < wxpython-2.5 which is not yet available in portage
+ epatch ${FILESDIR}/${PN}-wxpython-pre2.5-fix.patch
+}
+
+src_install() {
+ distutils_src_install
+
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ dodir ${PIXMAPLOC}
+ insinto ${PIXMAPLOC}
+ doins *.ico *.gif
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ rm ${D}/usr/bin/*gui.py
+ fi
+ insinto /usr/share/bittorrent
+ doins ${FILESDIR}/favicon.ico
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/bttrack.conf bttrack
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/bttrack.rc bttrack
+}
+
diff --git a/net-p2p/bittornado/files/digest-bittornado-0.3.12 b/net-p2p/bittornado/files/digest-bittornado-0.3.12
new file mode 100644
index 000000000000..6075bc50c299
--- /dev/null
+++ b/net-p2p/bittornado/files/digest-bittornado-0.3.12
@@ -0,0 +1 @@
+MD5 c14574fb2ac98c9af53e921b52a4732e BitTornado-0.3.12.tar.gz 189208