summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2015-02-27 21:10:20 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2015-02-27 21:10:20 +0000
commitda3aafe0db773c42ecb98525a1d1cab28dc67322 (patch)
treef1573f4264c5b0952e57139faddfd5ea32c7d732 /net-p2p
parentVersion bump of 1.4 series. This release mitigates two new side channel (diff)
downloadgentoo-2-da3aafe0db773c42ecb98525a1d1cab28dc67322.tar.gz
gentoo-2-da3aafe0db773c42ecb98525a1d1cab28dc67322.tar.bz2
gentoo-2-da3aafe0db773c42ecb98525a1d1cab28dc67322.zip
Version bump. Bug #541386
(Portage version: 2.2.17/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog7
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.1.12.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 2ee1b96cfe22..51c8b7aa522b 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.239 2015/02/23 19:02:33 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.240 2015/02/27 21:10:20 hwoarang Exp $
+
+*qbittorrent-3.1.12 (27 Feb 2015)
+
+ 27 Feb 2015; Markos Chandras <hwoarang@gentoo.org> +qbittorrent-3.1.12.ebuild:
+ Version bump. Bug #541386
23 Feb 2015; Markos Chandras <hwoarang@gentoo.org> qbittorrent-9999.ebuild:
Fix qtgui slot for Qt5
diff --git a/net-p2p/qbittorrent/qbittorrent-3.1.12.ebuild b/net-p2p/qbittorrent/qbittorrent-3.1.12.ebuild
new file mode 100644
index 000000000000..46f415a9df69
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-3.1.12.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-3.1.12.ebuild,v 1.1 2015/02/27 21:10:20 hwoarang Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit python-r1 qt4-r2
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+MY_P=${P/_}
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+IUSE="dbus debug geoip +X"
+
+# geoip and python are runtime deps only (see INSTALL file)
+CDEPEND="
+ dev-libs/boost:=
+ dev-qt/qtcore:4
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[X?]
+ >=net-libs/rb_libtorrent-0.16.17
+ dbus? ( dev-qt/qtdbus:4 )
+ X? ( dev-qt/qtgui:4 )
+"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}
+ geoip? ( dev-libs/geoip )
+"
+
+S=${WORKDIR}/${MY_P}
+DOCS=(AUTHORS Changelog README.md TODO)
+
+src_configure() {
+ # Custom configure script, econf fails
+ local myconf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --with-libboost-inc="${EPREFIX}/usr/include/boost"
+ --with-qtsingleapplication=system
+ $(use dbus || echo --disable-qt-dbus)
+ $(use debug && echo --enable-debug)
+ $(use geoip || echo --disable-geoip-database)
+ $(use X || echo --disable-gui)
+ )
+
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die "configure failed"
+ eqmake4
+}