summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-12-05 15:50:28 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-12-05 15:50:28 +0000
commitc375779350ddee502e637fde7003eb2a31d159ad (patch)
tree1fc6f1b2621cc84783fdeb9a1a980a432e5dbdf2 /net-p2p
parentSparc stable --- Bug #200134 --- works fine. (diff)
downloadgentoo-2-c375779350ddee502e637fde7003eb2a31d159ad.tar.gz
gentoo-2-c375779350ddee502e637fde7003eb2a31d159ad.tar.bz2
gentoo-2-c375779350ddee502e637fde7003eb2a31d159ad.zip
New snapshot and tweak amuleweb init script
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule/ChangeLog8
-rw-r--r--net-p2p/amule/amule-2.2.0_pre20071204.ebuild112
-rw-r--r--net-p2p/amule/files/amuleweb.initd8
-rw-r--r--net-p2p/amule/files/digest-amule-2.2.0_pre200712043
4 files changed, 127 insertions, 4 deletions
diff --git a/net-p2p/amule/ChangeLog b/net-p2p/amule/ChangeLog
index e569f71da75e..297e49538762 100644
--- a/net-p2p/amule/ChangeLog
+++ b/net-p2p/amule/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/amule
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.94 2007/10/13 16:16:45 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.95 2007/12/05 15:50:28 armin76 Exp $
+
+*amule-2.2.0_pre20071204 (05 Dec 2007)
+
+ 05 Dec 2007; Raúl Porcel <armin76@gentoo.org> files/amuleweb.initd,
+ +amule-2.2.0_pre20071204.ebuild:
+ New snapshot and tweak amuleweb init script
13 Oct 2007; Ryan Hill <dirtyepic@gentoo.org> amule-2.1.3.ebuild,
amule-2.2.0_pre20070422.ebuild:
diff --git a/net-p2p/amule/amule-2.2.0_pre20071204.ebuild b/net-p2p/amule/amule-2.2.0_pre20071204.ebuild
new file mode 100644
index 000000000000..646fa2d43bd8
--- /dev/null
+++ b/net-p2p/amule/amule-2.2.0_pre20071204.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.0_pre20071204.ebuild,v 1.1 2007/12/05 15:50:28 armin76 Exp $
+
+inherit eutils flag-o-matic wxwidgets
+
+MY_P=${PN/m/M}-CVS-${PV/2.2.0_pre/}
+S="${WORKDIR}/${PN}-cvs"
+
+DESCRIPTION="aMule, the all-platform eMule p2p client"
+HOMEPAGE="http://www.amule.org/"
+SRC_URI="http://www.hirnriss.net/files/cvs/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="amuled debug geoip gtk nls remote stats"
+
+DEPEND="=x11-libs/wxGTK-2.8*
+ >=sys-libs/zlib-1.2.1
+ stats? ( >=media-libs/gd-2.0.26 )
+ geoip? ( dev-libs/geoip )
+ remote? ( >=media-libs/libpng-1.2.0
+ unicode? ( >=media-libs/gd-2.0.26 ) )"
+
+pkg_setup() {
+ if ! use gtk && ! use remote && ! use amuled; then
+ eerror ""
+ eerror "You have to specify at least one of gtk, remote or amuled"
+ eerror "USE flag to build amule."
+ eerror ""
+ die "Invalid USE flag set"
+ fi
+
+ if use stats && ! use gtk; then
+ einfo "Note: You would need both the gtk and stats USE flags"
+ einfo "to compile aMule Statistics GUI."
+ einfo "I will now compile console versions only."
+ fi
+
+ if use stats && ! built_with_use media-libs/gd jpeg; then
+ die "media-libs/gd should be compiled with the jpeg use flag when you have the stats use flag set"
+ fi
+}
+
+pkg_preinst() {
+ if use amuled || use remote; then
+ enewgroup p2p
+ enewuser p2p -1 -1 /home/p2p p2p
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ WX_GTK_VER="2.8"
+
+ if use gtk; then
+ einfo "wxGTK with gtk support will be used"
+ need-wxwidgets unicode
+ else
+ einfo "wxGTK without X support will be used"
+ need-wxwidgets base
+ fi
+
+ if use gtk ; then
+ use stats && myconf="${myconf}
+ --enable-wxcas
+ --enable-alc"
+ use remote && myconf="${myconf}
+ --enable-amule-gui"
+ else
+ myconf="
+ --disable-monolithic
+ --disable-amule-gui
+ --disable-wxcas
+ --disable-alc"
+ fi
+
+ econf \
+ --with-wx-config=${WX_CONFIG} \
+ --with-wxbase-config=${WX_CONFIG} \
+ --enable-amulecmd \
+ $(use_enable debug) \
+ $(use_enable !debug optimize) \
+ $(use_enable amuled amule-daemon) \
+ $(use_enable geoip) \
+ $(use_enable nls) \
+ $(use_enable remote webserver) \
+ $(use_enable stats cas) \
+ $(use_enable stats alcc) \
+ ${myconf} || die
+
+ # we filter ssp until bug #74457 is closed to build on hardened
+ filter-flags -fstack-protector -fstack-protector-all
+
+ emake -j1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use amuled; then
+ newconfd "${FILESDIR}"/amuled.confd amuled
+ newinitd "${FILESDIR}"/amuled.initd amuled
+ fi
+
+ if use remote; then
+ newconfd "${FILESDIR}"/amuleweb.confd amuleweb
+ newinitd "${FILESDIR}"/amuleweb.initd amuleweb
+ fi
+}
diff --git a/net-p2p/amule/files/amuleweb.initd b/net-p2p/amule/files/amuleweb.initd
index 70cd119925c9..4b0d6cd39e53 100644
--- a/net-p2p/amule/files/amuleweb.initd
+++ b/net-p2p/amule/files/amuleweb.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/files/amuleweb.initd,v 1.5 2006/01/13 13:56:48 mkay Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/files/amuleweb.initd,v 1.6 2007/12/05 15:50:28 armin76 Exp $
depend() {
need net
@@ -19,7 +19,9 @@ start() {
return 1
fi
- rm /var/run/amuleweb.pid
+ if [ -e /var/run/amuleweb.pid ]; then
+ rm /var/run/amuleweb.pid
+ fi
OPTIONS="-h ${AMULEHOST} -p ${AMULEPORT} -P ${AMULEPWD} -A ${WEBPWD}"
diff --git a/net-p2p/amule/files/digest-amule-2.2.0_pre20071204 b/net-p2p/amule/files/digest-amule-2.2.0_pre20071204
new file mode 100644
index 000000000000..7b9c143d1a41
--- /dev/null
+++ b/net-p2p/amule/files/digest-amule-2.2.0_pre20071204
@@ -0,0 +1,3 @@
+MD5 3af38aad783605a3c9dca9175db21d16 aMule-CVS-20071204.tar.bz2 4028121
+RMD160 b75a306f1f02c32f7e55979e9f1ffb8a3223862b aMule-CVS-20071204.tar.bz2 4028121
+SHA256 8297cb0c111c8e278bd4bb50de0f02353b0a6581c68f60a54833bcecc47e213c aMule-CVS-20071204.tar.bz2 4028121