summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Kryczek <mkay@gentoo.org>2005-11-21 22:38:28 +0000
committerMarcin Kryczek <mkay@gentoo.org>2005-11-21 22:38:28 +0000
commitbd3ecbc256a1e248d5d83fd1d58faab86bec23f9 (patch)
treebb4323d8c2589fcf072329d7da78949fd397799d /net-p2p
parentstable on amd64 (diff)
downloadgentoo-2-bd3ecbc256a1e248d5d83fd1d58faab86bec23f9.tar.gz
gentoo-2-bd3ecbc256a1e248d5d83fd1d58faab86bec23f9.tar.bz2
gentoo-2-bd3ecbc256a1e248d5d83fd1d58faab86bec23f9.zip
I've commited broken ebuild. Sorry for that. This one should work
(Portage version: 1.589-cvs)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/xmule/ChangeLog8
-rw-r--r--net-p2p/xmule/xmule-1.10.1-r2.ebuild11
2 files changed, 13 insertions, 6 deletions
diff --git a/net-p2p/xmule/ChangeLog b/net-p2p/xmule/ChangeLog
index 0e656f6e92f5..e6020816a67d 100644
--- a/net-p2p/xmule/ChangeLog
+++ b/net-p2p/xmule/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/xmule
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/ChangeLog,v 1.62 2005/11/21 19:01:45 mkay Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/ChangeLog,v 1.63 2005/11/21 22:38:28 mkay Exp $
+
+ 21 Nov 2005; Marcin Kryczek <mkay@gentoo.org> xmule-1.10.1-r2.ebuild:
+ I've commited broken ebuild. Sorry for that. This one should work
+
+ 21 Nov 2005; Marcin Kryczek <mkay@gentoo.org> xmule-1.10.1-r2.ebuild:
+ Removing unicode from IUSE. It shouldn't be there
*xmule-1.10.1-r2 (21 Nov 2005)
diff --git a/net-p2p/xmule/xmule-1.10.1-r2.ebuild b/net-p2p/xmule/xmule-1.10.1-r2.ebuild
index 5f6c814d99ef..77a4311d7e87 100644
--- a/net-p2p/xmule/xmule-1.10.1-r2.ebuild
+++ b/net-p2p/xmule/xmule-1.10.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/xmule-1.10.1-r2.ebuild,v 1.1 2005/11/21 19:01:45 mkay Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/xmule-1.10.1-r2.ebuild,v 1.2 2005/11/21 22:38:28 mkay Exp $
inherit wxwidgets eutils
@@ -12,7 +12,7 @@ LICENSE="LGPL-2 ZLIB GPL-2"
SLOT="0"
KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE="nls debug unicode"
+IUSE="nls debug"
DEPEND=">=x11-libs/wxGTK-2.6.2
nls? ( sys-devel/gettext )
@@ -21,18 +21,19 @@ DEPEND=">=x11-libs/wxGTK-2.6.2
>=dev-libs/crypto++-5.2.1"
src_unpack() {
+ export WX_GTK_VER="2.6"
+ need-wxwidgets gtk2
+
unpack ${A}
cd ${S}
sed -i 's/@datadir@/${DESTDIR}@datadir@/' Makefile.in || die
+ sed -i "s:wx-config:${WX_CONFIG}:" src/xmule.make.in || die
epatch ${FILESDIR}/${P}-crypto-gentoo.patch
autoreconf
}
src_compile () {
- export WX_GTK_VER="2.6"
- need-wxwidgets gtk2
-
# replace flags -O3 with -O2 because amule can crash with this
# flag, bug #87437
replace-flags -O3 -O2