summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-25 19:53:52 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-25 19:53:52 +0000
commita6743173656532034c8b197dea3f4606db008ed0 (patch)
tree771351938e49092450d94c119dc161e27881ad43 /net-p2p
parentInitial commit. Thanks to Almad (bugs@almad.net). Closes bug #238899. (diff)
downloadgentoo-2-a6743173656532034c8b197dea3f4606db008ed0.tar.gz
gentoo-2-a6743173656532034c8b197dea3f4606db008ed0.tar.bz2
gentoo-2-a6743173656532034c8b197dea3f4606db008ed0.zip
Fix building with GCC 4.4 wrt #277188.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitstormlite/ChangeLog6
-rw-r--r--net-p2p/bitstormlite/bitstormlite-0.2p.ebuild21
-rw-r--r--net-p2p/bitstormlite/files/bitstormlite-0.2p-gcc44.patch34
3 files changed, 50 insertions, 11 deletions
diff --git a/net-p2p/bitstormlite/ChangeLog b/net-p2p/bitstormlite/ChangeLog
index 3d26126d07f2..c6b560b4597b 100644
--- a/net-p2p/bitstormlite/ChangeLog
+++ b/net-p2p/bitstormlite/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/bitstormlite
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitstormlite/ChangeLog,v 1.10 2009/02/16 00:05:16 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitstormlite/ChangeLog,v 1.11 2009/07/25 19:53:52 ssuominen Exp $
+
+ 25 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
+ bitstormlite-0.2p.ebuild, +files/bitstormlite-0.2p-gcc44.patch:
+ Fix building with GCC 4.4 wrt #277188.
16 Feb 2009; Peter Alfredsen <loki_val@gentoo.org>
+files/bitstormlite-0.2p-gcc43.patch, bitstormlite-0.2p.ebuild:
diff --git a/net-p2p/bitstormlite/bitstormlite-0.2p.ebuild b/net-p2p/bitstormlite/bitstormlite-0.2p.ebuild
index dca9af14a949..471d6913535e 100644
--- a/net-p2p/bitstormlite/bitstormlite-0.2p.ebuild
+++ b/net-p2p/bitstormlite/bitstormlite-0.2p.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitstormlite/bitstormlite-0.2p.ebuild,v 1.3 2009/02/16 00:05:16 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitstormlite/bitstormlite-0.2p.ebuild,v 1.4 2009/07/25 19:53:52 ssuominen Exp $
+EAPI=2
inherit eutils
DESCRIPTION="A light BitTorrent client based on c++ and gtk+."
@@ -10,19 +11,19 @@ SRC_URI="mirror://sourceforge/bbom/BitStormLite-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
+
RDEPEND="net-misc/curl
- >=x11-libs/gtk+-2.6"
-DEPEND="dev-util/pkgconfig
- ${RDEPEND}"
+ >=x11-libs/gtk+-2.6:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
-S="${WORKDIR}/BitStormLite-${PV}"
+S=${WORKDIR}/BitStormLite-${PV}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-gcc43.patch"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
}
src_install() {
diff --git a/net-p2p/bitstormlite/files/bitstormlite-0.2p-gcc44.patch b/net-p2p/bitstormlite/files/bitstormlite-0.2p-gcc44.patch
new file mode 100644
index 000000000000..c392daf4e30e
--- /dev/null
+++ b/net-p2p/bitstormlite/files/bitstormlite-0.2p-gcc44.patch
@@ -0,0 +1,34 @@
+diff -ur BitStormLite-0.2p.orig/src/bdict.h BitStormLite-0.2p/src/bdict.h
+--- BitStormLite-0.2p.orig/src/bdict.h 2007-05-17 16:05:06.000000000 +0300
++++ BitStormLite-0.2p/src/bdict.h 2009-07-25 22:53:28.000000000 +0300
+@@ -26,6 +26,7 @@
+ #ifndef _BDICT_H_
+ #define _BDICT_H_
+
++#include <stdio.h>
+ #include <iostream>
+ #include <string>
+ #include <map>
+diff -ur BitStormLite-0.2p.orig/src/BitStorm.h BitStormLite-0.2p/src/BitStorm.h
+--- BitStormLite-0.2p.orig/src/BitStorm.h 2007-05-17 16:06:12.000000000 +0300
++++ BitStormLite-0.2p/src/BitStorm.h 2009-07-25 22:51:46.000000000 +0300
+@@ -25,7 +25,7 @@
+
+ #ifndef _BITSTORM_H_
+ #define _BITSTORM_H_
+-
++ #include <stdint.h>
+ #include <string>
+ #include <list>
+ #include <map>
+diff -ur BitStormLite-0.2p.orig/src/BTTask.h BitStormLite-0.2p/src/BTTask.h
+--- BitStormLite-0.2p.orig/src/BTTask.h 2007-05-17 16:06:52.000000000 +0300
++++ BitStormLite-0.2p/src/BTTask.h 2009-07-25 22:51:57.000000000 +0300
+@@ -26,6 +26,7 @@
+ #ifndef BTTASK_H_
+ #define BTTASK_H_
+
++#include <stdint.h>
+ #include <pthread.h>
+ #include <string>
+ #include <list>