summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-22 20:16:45 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-22 20:16:45 +0000
commit939e92ac4335e0669ea2a436bcef11f0ee9c01c9 (patch)
tree278be5e3ff873c842f3f71ff960d80b25fd062ee /net-p2p
parentVersion bump. (diff)
downloadgentoo-2-939e92ac4335e0669ea2a436bcef11f0ee9c01c9.tar.gz
gentoo-2-939e92ac4335e0669ea2a436bcef11f0ee9c01c9.tar.bz2
gentoo-2-939e92ac4335e0669ea2a436bcef11f0ee9c01c9.zip
Version bump.
(Portage version: 2.2_rc60/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent/ChangeLog8
-rw-r--r--net-p2p/rtorrent/rtorrent-0.8.6.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index f2b08c39b31e..4b3355defb82 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.144 2009/12/09 19:28:04 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.145 2009/12/22 20:16:45 ssuominen Exp $
+
+*rtorrent-0.8.6 (22 Dec 2009)
+
+ 22 Dec 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +rtorrent-0.8.6.ebuild:
+ Version bump.
09 Dec 2009; nixnut <nixnut@gentoo.org> rtorrent-0.8.5.ebuild:
ppc stable #291036
diff --git a/net-p2p/rtorrent/rtorrent-0.8.6.ebuild b/net-p2p/rtorrent/rtorrent-0.8.6.ebuild
new file mode 100644
index 000000000000..88bc4f7cc1db
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.8.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.6.ebuild,v 1.1 2009/12/22 20:16:45 ssuominen Exp $
+
+EAPI=2
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="daemon debug ipv6 xmlrpc"
+
+COMMON_DEPEND=">=net-libs/libtorrent-0.12.${PV##*.}
+ >=dev-libs/libsigc++-2.2.2:2
+ >=net-misc/curl-7.19.1
+ sys-libs/ncurses
+ xmlrpc? ( dev-libs/xmlrpc-c )"
+RDEPEND="${COMMON_DEPEND}
+ daemon? ( app-misc/screen )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_with xmlrpc xmlrpc-c)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+
+ if use daemon; then
+ newinitd "${FILESDIR}/rtorrentd.init" rtorrentd || die "newinitd failed"
+ newconfd "${FILESDIR}/rtorrentd.conf" rtorrentd || die "newconfd failed"
+ fi
+}