summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-04-08 09:32:11 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-04-08 09:32:11 +0000
commit85a65c9ea4c1eaed04bbd5b587061bccf41672ab (patch)
tree58997f2b307037743022794760c0409d3017e87d /net-p2p
parentRemoved old patches (diff)
downloadgentoo-2-85a65c9ea4c1eaed04bbd5b587061bccf41672ab.tar.gz
gentoo-2-85a65c9ea4c1eaed04bbd5b587061bccf41672ab.tar.bz2
gentoo-2-85a65c9ea4c1eaed04bbd5b587061bccf41672ab.zip
Version bump
(Portage version: 2.1.6.7/cvs/Linux ia64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog7
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.3.3.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 40ab2287bb74..8bebfae7f4a7 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.54 2009/03/09 13:06:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.55 2009/04/08 09:32:11 armin76 Exp $
+
+*qbittorrent-1.3.3 (08 Apr 2009)
+
+ 08 Apr 2009; Raúl Porcel <armin76@gentoo.org> +qbittorrent-1.3.3.ebuild:
+ Version bump
*qbittorrent-1.3.2 (09 Mar 2009)
diff --git a/net-p2p/qbittorrent/qbittorrent-1.3.3.ebuild b/net-p2p/qbittorrent/qbittorrent-1.3.3.ebuild
new file mode 100644
index 000000000000..c865b49034fb
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-1.3.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.3.3.ebuild,v 1.1 2009/04/08 09:32:11 armin76 Exp $
+
+EAPI="1"
+
+inherit eutils qt4 multilib
+
+MY_P="${P/_/}"
+
+DESCRIPTION="BitTorrent client in C++ and Qt."
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# boost version so that we always have thread support
+DEPEND="|| ( x11-libs/qt-gui:4 =x11-libs/qt-4.3* )
+ >=net-libs/rb_libtorrent-0.14.1
+ >=dev-libs/boost-1.34.1
+ net-misc/curl
+ dev-cpp/commoncpp2"
+RDEPEND="${DEPEND}
+ >=dev-lang/python-2.3"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+}
+
+src_compile() {
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr \
+ --with-libtorrent-inc=/usr/include \
+ --with-libtorrent-lib=/usr/$(get_libdir) \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc AUTHORS Changelog NEWS README TODO
+}