summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-03-14 07:02:57 +0000
committerHans de Graaff <graaff@gentoo.org>2011-03-14 07:02:57 +0000
commit729b7a2afefb1e299696909227b293a7ac016125 (patch)
tree7e0aa6d75aa2841c4c53211f0089de155f4ca7f2 /net-p2p
parent[bump] dev-perl/File-Listing-6.10.0 (diff)
downloadgentoo-2-729b7a2afefb1e299696909227b293a7ac016125.tar.gz
gentoo-2-729b7a2afefb1e299696909227b293a7ac016125.tar.bz2
gentoo-2-729b7a2afefb1e299696909227b293a7ac016125.zip
Version bump. Switch gnutls USE flag to more generic ssl (but still provided by gnutls).
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gtk-gnutella/ChangeLog9
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-0.96.9.ebuild58
2 files changed, 66 insertions, 1 deletions
diff --git a/net-p2p/gtk-gnutella/ChangeLog b/net-p2p/gtk-gnutella/ChangeLog
index 9320b57b76d7..2660c6f65a49 100644
--- a/net-p2p/gtk-gnutella/ChangeLog
+++ b/net-p2p/gtk-gnutella/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/gtk-gnutella
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/ChangeLog,v 1.108 2011/03/01 18:35:39 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/ChangeLog,v 1.109 2011/03/14 07:02:57 graaff Exp $
+
+*gtk-gnutella-0.96.9 (14 Mar 2011)
+
+ 14 Mar 2011; Hans de Graaff <graaff@gentoo.org>
+ +gtk-gnutella-0.96.9.ebuild:
+ Version bump. Switch gnutls USE flag to more generic ssl (but still
+ provided by gnutls).
01 Mar 2011; Hans de Graaff <graaff@gentoo.org>
gtk-gnutella-0.96.8.ebuild:
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-0.96.9.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-0.96.9.ebuild
new file mode 100644
index 000000000000..f325b813bc1e
--- /dev/null
+++ b/net-p2p/gtk-gnutella/gtk-gnutella-0.96.9.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/gtk-gnutella-0.96.9.ebuild,v 1.1 2011/03/14 07:02:57 graaff Exp $
+
+EAPI="2"
+
+inherit eutils
+
+IUSE="nls dbus ssl +gtk"
+
+DESCRIPTION="A GTK+ Gnutella client"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://gtk-gnutella.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-libs/libxml2-2.6.0
+ gtk? ( >=x11-libs/gtk+-2.2.1:2 )
+ dbus? ( >=sys-apps/dbus-0.35.2 )
+ ssl? ( >=net-libs/gnutls-1.0.16 )
+ nls? ( >=sys-devel/gettext-0.11.5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ # The build script does not support the equivalent --enable
+ # options so we must construct the configuration by hand.
+
+ local myconf
+
+ if ! use nls; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ if ! use dbus; then
+ myconf="${myconf} --disable-dbus"
+ fi
+
+ if ! use ssl; then
+ myconf="${myconf} --disable-gnutls"
+ fi
+
+ if use gtk; then
+ myconf="${myconf} --gtk2"
+ else
+ myconf="${myconf} --topless"
+ fi
+
+ ./build.sh --configure-only --prefix="/usr" ${myconf}
+}
+
+src_install() {
+ dodir /usr/bin
+ emake INSTALL_PREFIX="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog README TODO
+}