summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-10 08:12:41 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-10 08:12:41 +0000
commit708da9e47d381e36d1de7df859d2c30ec8b4c97d (patch)
tree505a6f384fdaf92b30f03132acffcc12ccf3fa2a /net-p2p
parentcreated digest (diff)
downloadgentoo-2-708da9e47d381e36d1de7df859d2c30ec8b4c97d.tar.gz
gentoo-2-708da9e47d381e36d1de7df859d2c30ec8b4c97d.tar.bz2
gentoo-2-708da9e47d381e36d1de7df859d2c30ec8b4c97d.zip
Version bump #8945
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/dc-gui/ChangeLog7
-rw-r--r--net-p2p/dc-gui/dc-gui-0.62.ebuild44
-rw-r--r--net-p2p/dc-gui/files/digest-dc-gui-0.621
-rw-r--r--net-p2p/dctc/ChangeLog12
-rw-r--r--net-p2p/dctc/dctc-0.83.5.ebuild28
-rw-r--r--net-p2p/dctc/files/digest-dctc-0.83.51
6 files changed, 88 insertions, 5 deletions
diff --git a/net-p2p/dc-gui/ChangeLog b/net-p2p/dc-gui/ChangeLog
index 9f39e6ddb8f4..825954f69c82 100644
--- a/net-p2p/dc-gui/ChangeLog
+++ b/net-p2p/dc-gui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/dc-gui
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dc-gui/ChangeLog,v 1.6 2002/08/16 13:49:21 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dc-gui/ChangeLog,v 1.7 2002/10/10 08:11:29 vapier Exp $
+
+*dc-gui-0.62 (10 Oct 2002)
+
+ 10 Oct 2002; Mike Frysinger <vapier@gentoo.org> dc-gui-0.59.ebuild :
+ Version bump #8945
*dc-gui-0.59 (16 Aug 2002)
diff --git a/net-p2p/dc-gui/dc-gui-0.62.ebuild b/net-p2p/dc-gui/dc-gui-0.62.ebuild
new file mode 100644
index 000000000000..c67c10a177a5
--- /dev/null
+++ b/net-p2p/dc-gui/dc-gui-0.62.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dc-gui/dc-gui-0.62.ebuild,v 1.1 2002/10/10 08:12:41 vapier Exp $
+
+IUSE="nls"
+
+S=${WORKDIR}/${P/-/_}
+DESCRIPTION="GUI for DCTC"
+SRC_URI="http://ac2i.tzo.com/dctc/${P/-/_}.tar.gz"
+HOMEPAGE="http://ac2i.tzo.com/dctc"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+
+DEPEND=" =dev-libs/glib-1.2*
+ =gnome-base/gnome-libs-1.4*
+ =sys-libs/db-3.2*
+ =x11-libs/gtk+-1.2*
+ >=net-p2p/dctc-0.83.5"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --with-gnome \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+}
diff --git a/net-p2p/dc-gui/files/digest-dc-gui-0.62 b/net-p2p/dc-gui/files/digest-dc-gui-0.62
new file mode 100644
index 000000000000..560675780a10
--- /dev/null
+++ b/net-p2p/dc-gui/files/digest-dc-gui-0.62
@@ -0,0 +1 @@
+MD5 2c9bf8fab023769a459ef35a71ef4a91 dc_gui-0.62.tar.gz 441860
diff --git a/net-p2p/dctc/ChangeLog b/net-p2p/dctc/ChangeLog
index 31150b6bf7a2..ac42aef2f5ee 100644
--- a/net-p2p/dctc/ChangeLog
+++ b/net-p2p/dctc/ChangeLog
@@ -1,12 +1,16 @@
# ChangeLog for net-p2p/dctc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dctc/ChangeLog,v 1.5 2002/08/16 13:49:21 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dctc/ChangeLog,v 1.6 2002/10/10 08:12:26 vapier Exp $
-*dctc-0.83.2 (16 Aug 2002)
+*dctc-0.83.5 (16 Aug 2002)
+
+ 10 Oct 2002; Mike Frysinger <vapier@gentoo.org> dctc-0.83.5.ebuild :
+ Version Bump + fix dodoc statements + upped glib dependency to glib2
- 16 Aug 2002; Seemant Kulleen <seemant@gentoo.org> dctc-0.83.2.ebuild :
+*dctc-0.83.2 (16 Aug 2002)
- Version bump thanks to: ewaling@ccitt5.net (Erik Waling) in bug #6293
+ 16 Aug 2002; Seemant Kulleen <seemant@gentoo.org> dctc-0.83.2.ebuild :
+ Version bump thanks to: ewaling@ccitt5.net (Erik Waling) in bug #6293
*dctc-0.83.1 (5 Jul 2002)
diff --git a/net-p2p/dctc/dctc-0.83.5.ebuild b/net-p2p/dctc/dctc-0.83.5.ebuild
new file mode 100644
index 000000000000..54b0a439da58
--- /dev/null
+++ b/net-p2p/dctc/dctc-0.83.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dctc/dctc-0.83.5.ebuild,v 1.1 2002/10/10 08:12:26 vapier Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Direct Connect Text Client, almost famous file share program"
+SRC_URI="http://ac2i.tzo.com/dctc/${P}.tar.gz"
+HOMEPAGE="http://ac2i.tzo.com/dctc/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+
+DEPEND="=dev-libs/glib-2*
+ =sys-libs/db-3.2*"
+
+src_compile() {
+ econf --enable-glib2 || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc Documentation/* Documentation/DCextensions/*
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL KNOWN_BUGS NEWS README TODO
+}
diff --git a/net-p2p/dctc/files/digest-dctc-0.83.5 b/net-p2p/dctc/files/digest-dctc-0.83.5
new file mode 100644
index 000000000000..d75497acc094
--- /dev/null
+++ b/net-p2p/dctc/files/digest-dctc-0.83.5
@@ -0,0 +1 @@
+MD5 5e691001fa203e3ca0ae30a9137d56fd dctc-0.83.5.tar.gz 247418