summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2015-03-01 15:49:39 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2015-03-01 15:49:39 +0000
commit6cbec4377b1dd7552bd4e399c200badd0b1e3ed2 (patch)
tree3e55716f9fad2590923cba96af47b870d7611dd4 /net-p2p
parentnet-im/{amsn,emesene} have been removed (diff)
downloadgentoo-2-6cbec4377b1dd7552bd4e399c200badd0b1e3ed2.tar.gz
gentoo-2-6cbec4377b1dd7552bd4e399c200badd0b1e3ed2.tar.bz2
gentoo-2-6cbec4377b1dd7552bd4e399c200badd0b1e3ed2.zip
Add epatch_user. Bug #541690
(Portage version: 2.2.17/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog6
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.1.12.ebuild9
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild8
3 files changed, 18 insertions, 5 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 51c8b7aa522b..88093d4ce6d8 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.240 2015/02/27 21:10:20 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.241 2015/03/01 15:49:39 hwoarang Exp $
+
+ 01 Mar 2015; Markos Chandras <hwoarang@gentoo.org> qbittorrent-3.1.12.ebuild,
+ qbittorrent-9999.ebuild:
+ Add epatch_user. Bug #541690
*qbittorrent-3.1.12 (27 Feb 2015)
diff --git a/net-p2p/qbittorrent/qbittorrent-3.1.12.ebuild b/net-p2p/qbittorrent/qbittorrent-3.1.12.ebuild
index 46f415a9df69..7a7d9c5c7aa2 100644
--- a/net-p2p/qbittorrent/qbittorrent-3.1.12.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-3.1.12.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-3.1.12.ebuild,v 1.1 2015/02/27 21:10:20 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-3.1.12.ebuild,v 1.2 2015/03/01 15:49:39 hwoarang Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
-inherit python-r1 qt4-r2
+inherit eutils python-r1 qt4-r2
DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="http://www.qbittorrent.org/"
@@ -38,6 +38,11 @@ RDEPEND="${CDEPEND}
S=${WORKDIR}/${MY_P}
DOCS=(AUTHORS Changelog README.md TODO)
+src_prepare() {
+ epatch_user
+ qt4-r2_src_prepare
+}
+
src_configure() {
# Custom configure script, econf fails
local myconf=(
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index c11031885203..0371cda2cf37 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.20 2015/02/23 19:02:33 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.21 2015/03/01 15:49:39 hwoarang Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit python-r1 qmake-utils
+inherit eutils python-r1 qmake-utils
DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="http://www.qbittorrent.org/"
@@ -55,6 +55,10 @@ RDEPEND="${CDEPEND}
S=${WORKDIR}/${MY_P}
DOCS=(AUTHORS Changelog README.md TODO)
+src_prepare() {
+ epatch_user
+}
+
src_configure() {
# Custom configure script, econf fails
local myconf=(