summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-01-10 21:54:33 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-01-10 21:54:33 +0000
commit1c21c98019561e44c828d1edb5a2fd7dad381960 (patch)
treeb7bc44faabc8eb336cf2fdbe4f92b726a1f09b9b /net-p2p
parentRevision bump for bug 155782 (CVE-2006-5989), also fixing compilation with gcc4. (diff)
downloadgentoo-2-1c21c98019561e44c828d1edb5a2fd7dad381960.tar.gz
gentoo-2-1c21c98019561e44c828d1edb5a2fd7dad381960.tar.bz2
gentoo-2-1c21c98019561e44c828d1edb5a2fd7dad381960.zip
add some fixes
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission/ChangeLog11
-rw-r--r--net-p2p/transmission/files/digest-transmission-0.6.1-r13
-rw-r--r--net-p2p/transmission/files/transmission-0.6.1-as-needed.patch11
-rw-r--r--net-p2p/transmission/files/transmission-0.6.1-gtk+-check.patch11
-rw-r--r--net-p2p/transmission/transmission-0.6.1-r1.ebuild53
5 files changed, 87 insertions, 2 deletions
diff --git a/net-p2p/transmission/ChangeLog b/net-p2p/transmission/ChangeLog
index 559d49842674..48ee476e06ea 100644
--- a/net-p2p/transmission/ChangeLog
+++ b/net-p2p/transmission/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/transmission
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.5 2006/08/15 23:58:18 squinky86 Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.6 2007/01/10 21:54:33 compnerd Exp $
+
+*transmission-0.6.1-r1 (10 Jan 2007)
+
+ 10 Jan 2007; <compnerd@gentoo.org>
+ +files/transmission-0.6.1-as-needed.patch,
+ +files/transmission-0.6.1-gtk+-check.patch, +transmission-0.6.1-r1.ebuild:
+ Add fixes for as-needed, install, and remove ssl's useflag
15 Aug 2006; Jon Hood <squinky86@gentoo.org> +files/0.6.1-configure.patch,
transmission-0.6.1.ebuild:
diff --git a/net-p2p/transmission/files/digest-transmission-0.6.1-r1 b/net-p2p/transmission/files/digest-transmission-0.6.1-r1
new file mode 100644
index 000000000000..1b4c2f493096
--- /dev/null
+++ b/net-p2p/transmission/files/digest-transmission-0.6.1-r1
@@ -0,0 +1,3 @@
+MD5 1156a88c77ab71782b9261881ea13811 Transmission-0.6.1.tar.gz 447868
+RMD160 cef6e825b72bad7565fa756ec298cbb8167c107f Transmission-0.6.1.tar.gz 447868
+SHA256 e427a78c680052edffb5850e31956c077c174dfa6c22ab1433d8c03617f914c0 Transmission-0.6.1.tar.gz 447868
diff --git a/net-p2p/transmission/files/transmission-0.6.1-as-needed.patch b/net-p2p/transmission/files/transmission-0.6.1-as-needed.patch
new file mode 100644
index 000000000000..157c72e554fd
--- /dev/null
+++ b/net-p2p/transmission/files/transmission-0.6.1-as-needed.patch
@@ -0,0 +1,11 @@
+--- configure 2007-01-02 21:58:49.000000000 -0600
++++ configure 2007-01-02 21:59:16.000000000 -0600
+@@ -115,7 +115,7 @@
+ then
+ if runcmd $CC -o testconf testconf.c -lm
+ then
+- LDFLAGS="$LDFLAGS -lm"
++ LDFLAGS="-lm $LDFLAGS"
+ fi
+ fi
+ rm -f testconf.c testconf
diff --git a/net-p2p/transmission/files/transmission-0.6.1-gtk+-check.patch b/net-p2p/transmission/files/transmission-0.6.1-gtk+-check.patch
new file mode 100644
index 000000000000..b0098cee5eb4
--- /dev/null
+++ b/net-p2p/transmission/files/transmission-0.6.1-gtk+-check.patch
@@ -0,0 +1,11 @@
+--- configure.orig 2006-12-02 16:27:05.000000000 -0600
++++ configure 2006-12-02 16:32:17.000000000 -0600
+@@ -173,7 +173,7 @@
+ verbose gtk_test
+ if runcmd pkg-config gtk+-2.0
+ then
+- if runcmd expr `pkg-config --modversion gtk+-2.0` '>=' 2.6.0
++ if `pkg-config gtk+-2.0 --atleast-version 2.6.0`
+ then
+ cat > testconf.c << EOF
+ #include <gtk/gtk.h>
diff --git a/net-p2p/transmission/transmission-0.6.1-r1.ebuild b/net-p2p/transmission/transmission-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..3695384042d8
--- /dev/null
+++ b/net-p2p/transmission/transmission-0.6.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-0.6.1-r1.ebuild,v 1.1 2007/01/10 21:54:33 compnerd Exp $
+
+inherit eutils
+
+MY_PN="Transmission"
+
+DESCRIPTION="Simple BitTorrent client"
+HOMEPAGE="http://transmission.m0k.org/"
+SRC_URI="http://download.m0k.org/transmission/files/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+RDEPEND="sys-devel/gettext
+ gtk? ( >=x11-libs/gtk+-2.6 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.19"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-0.6.1-gtk+-check.patch
+ epatch ${FILESDIR}/${PN}-0.6.1-as-needed.patch
+
+ # Fix man page install location
+ sed -i -e 's|/man/man1|/share/man/man1|' mk/common.mk
+}
+
+src_compile() {
+ econf $(use_enable gtk) || die "configure failed"
+ emake || die "build failed"
+}
+
+src_install() {
+ make PREFIX="${D}${ROOT}usr" LOCALEDIR="\$(PREFIX)/share/locale" install \
+ || die "install failed"
+
+ if use gtk ; then
+ doicon "${FILESDIR}/transmission.png"
+ make_desktop_entry "transmission-gtk" "${PN}" "${PN}.png" \
+ "Network;Internet;P2P"
+ fi
+
+ dodoc AUTHORS NEWS README
+}