summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-06-16 19:54:27 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-06-16 19:54:27 +0000
commit122de9fcab9ff0d50a7f9d5621911f509acadf75 (patch)
tree88a55aa699bb2e76bd83e1e6f37a6222591d43bc /net-p2p
parentAdd live ebuild for 0.2 branch. (diff)
downloadgentoo-2-122de9fcab9ff0d50a7f9d5621911f509acadf75.tar.gz
gentoo-2-122de9fcab9ff0d50a7f9d5621911f509acadf75.tar.bz2
gentoo-2-122de9fcab9ff0d50a7f9d5621911f509acadf75.zip
dont try to use PIE with ocaml executables, this will not work as ocaml does not create PIC objects. Bug #219282
(Portage version: 2.1.5.5)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/mldonkey/ChangeLog6
-rw-r--r--net-p2p/mldonkey/mldonkey-2.9.5.ebuild12
2 files changed, 15 insertions, 3 deletions
diff --git a/net-p2p/mldonkey/ChangeLog b/net-p2p/mldonkey/ChangeLog
index 8088878a6461..baac949b1177 100644
--- a/net-p2p/mldonkey/ChangeLog
+++ b/net-p2p/mldonkey/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/mldonkey
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/ChangeLog,v 1.211 2008/05/05 11:31:08 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/ChangeLog,v 1.212 2008/06/16 19:54:27 aballier Exp $
+
+ 16 Jun 2008; Alexis Ballier <aballier@gentoo.org> mldonkey-2.9.5.ebuild:
+ dont try to use PIE with ocaml executables, this will not work as ocaml
+ does not create PIC objects. Bug #219282
05 May 2008; Robert Buchholz <rbu@gentoo.org> mldonkey-2.9.4.ebuild:
amd64 stable (bug #219146)
diff --git a/net-p2p/mldonkey/mldonkey-2.9.5.ebuild b/net-p2p/mldonkey/mldonkey-2.9.5.ebuild
index 9bdf8469306b..451f0b8832bf 100644
--- a/net-p2p/mldonkey/mldonkey-2.9.5.ebuild
+++ b/net-p2p/mldonkey/mldonkey-2.9.5.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/mldonkey-2.9.5.ebuild,v 1.1 2008/05/05 10:16:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/mldonkey-2.9.5.ebuild,v 1.2 2008/06/16 19:54:27 aballier Exp $
WANT_AUTOCONF=2.5
-inherit flag-o-matic eutils autotools
+inherit flag-o-matic eutils autotools toolchain-funcs
EAPI="1"
@@ -60,6 +60,14 @@ pkg_setup() {
eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
die "Please install ocaml with ocamlopt useflag"
fi
+ # dev-lang/ocaml creates its own objects but calls gcc for linking, which will
+ # results in relocations if gcc wants to create a PIE executable
+ if gcc-specs-pie ; then
+ append-ldflags -nopie
+ ewarn "Ocaml generates its own native asm, you're using a PIE compiler"
+ ewarn "We have appended -nopie to ocaml build options"
+ ewarn "because linking an executable with pie while the objects are not pic will not work"
+ fi
}
src_unpack() {