summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-10-14 11:31:26 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-10-14 11:31:26 +0000
commit0546b50a669768bfb2b723608c5a4d1e6e6fa759 (patch)
treed390e44fe91865780a113cae902ac016ddd500ef /net-p2p
parentalpha/ia64/sparc stable wrt #189672 (diff)
downloadgentoo-2-0546b50a669768bfb2b723608c5a4d1e6e6fa759.tar.gz
gentoo-2-0546b50a669768bfb2b723608c5a4d1e6e6fa759.tar.bz2
gentoo-2-0546b50a669768bfb2b723608c5a4d1e6e6fa759.zip
Version bump and spell USE-flag
(Portage version: 2.1.3.13)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/nicotine+/ChangeLog7
-rw-r--r--net-p2p/nicotine+/files/digest-nicotine+-1.2.93
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.9.ebuild45
3 files changed, 54 insertions, 1 deletions
diff --git a/net-p2p/nicotine+/ChangeLog b/net-p2p/nicotine+/ChangeLog
index 41e8d542a880..a97b971c52b7 100644
--- a/net-p2p/nicotine+/ChangeLog
+++ b/net-p2p/nicotine+/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/nicotine+
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.23 2007/09/11 13:37:46 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.24 2007/10/14 11:31:25 armin76 Exp $
+
+*nicotine+-1.2.9 (14 Oct 2007)
+
+ 14 Oct 2007; Raúl Porcel <armin76@gentoo.org> +nicotine+-1.2.9.ebuild:
+ Version bump and spell USE-flag
11 Sep 2007; Santiago M. Mola <coldwind@gentoo.org>
nicotine+-1.2.8.ebuild:
diff --git a/net-p2p/nicotine+/files/digest-nicotine+-1.2.9 b/net-p2p/nicotine+/files/digest-nicotine+-1.2.9
new file mode 100644
index 000000000000..af7c3c2ea129
--- /dev/null
+++ b/net-p2p/nicotine+/files/digest-nicotine+-1.2.9
@@ -0,0 +1,3 @@
+MD5 3e310418e4ea8ba9f0bdb240f82feb27 nicotine+-1.2.9.tar.bz2 1148442
+RMD160 fe542c1559626f6ef8e4ff483ed00d9129ca5f73 nicotine+-1.2.9.tar.bz2 1148442
+SHA256 59df380c0c6e310046e70095ca93f9202de005a2daed0b2613ed5820eb328606 nicotine+-1.2.9.tar.bz2 1148442
diff --git a/net-p2p/nicotine+/nicotine+-1.2.9.ebuild b/net-p2p/nicotine+/nicotine+-1.2.9.ebuild
new file mode 100644
index 000000000000..0436aeb97183
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-1.2.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.9.ebuild,v 1.1 2007/10/14 11:31:25 armin76 Exp $
+
+inherit distutils eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="http://nicotine-plus.sourceforge.net"
+SRC_URI="mirror://sourceforge/nicotine-plus/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="geoip spell vorbis"
+
+RDEPEND="virtual/python
+ >=dev-python/pygtk-2
+ vorbis? ( >=dev-python/pyvorbis-1.4-r1
+ >=dev-python/pyogg-1 )
+ geoip? ( >=dev-python/geoip-python-0.2.0
+ >=dev-libs/geoip-1.2.1 )
+ spell? ( dev-python/sexy-python )
+ !net-p2p/nicotine"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+src_compile() {
+ distutils_src_compile
+
+ cd "${S}"/trayicon/
+ sed -i -e "s:/lib/:/$(get_libdir)/:" \
+ Makefile.in || die "sed failed"
+ ./autogen.py
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ distutils_python_version
+ distutils_src_install --install-lib \
+ /usr/$(get_libdir)/python${PYVER}/site-packages
+
+ cd "${S}"/trayicon/
+ emake DESTDIR="${D}" install || die "emake install failed"
+}