summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2006-06-06 21:26:57 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2006-06-06 21:26:57 +0000
commitfdc87de6b42f1245ea109d8238a30f86bc137244 (patch)
tree37524d173e8e4e448a70c7ec1cc0e6855c70b37c /net-p2p/sancho-bin
parentInitial import. Original ebuild by James Jones <jcjones@ufl.edu> and edited ... (diff)
downloadgentoo-2-fdc87de6b42f1245ea109d8238a30f86bc137244.tar.gz
gentoo-2-fdc87de6b42f1245ea109d8238a30f86bc137244.tar.bz2
gentoo-2-fdc87de6b42f1245ea109d8238a30f86bc137244.zip
Version bump, bug #129448. Added desktop entry, bug #122741
(Portage version: 2.1_rc4-r1)
Diffstat (limited to 'net-p2p/sancho-bin')
-rw-r--r--net-p2p/sancho-bin/ChangeLog8
-rw-r--r--net-p2p/sancho-bin/files/digest-sancho-bin-0.9.4.573
-rw-r--r--net-p2p/sancho-bin/sancho-bin-0.9.4.57.ebuild57
3 files changed, 67 insertions, 1 deletions
diff --git a/net-p2p/sancho-bin/ChangeLog b/net-p2p/sancho-bin/ChangeLog
index 949ec1c94afe..64e69a71447a 100644
--- a/net-p2p/sancho-bin/ChangeLog
+++ b/net-p2p/sancho-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/sancho-bin
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/sancho-bin/ChangeLog,v 1.32 2006/06/06 21:06:25 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/sancho-bin/ChangeLog,v 1.33 2006/06/06 21:26:57 sekretarz Exp $
+
+*sancho-bin-0.9.4.57 (07 Jun 2006)
+
+ 07 Jun 2006; Karol Wojtaszek <sekretarz@gentoo.org>
+ +sancho-bin-0.9.4.57.ebuild:
+ Version bump, bug #129448. Added desktop entry, bug #122741
07 Jun 2006; Karol Wojtaszek <sekretarz@gentoo.org>
-sancho-bin-0.9.4.17.ebuild, -sancho-bin-0.9.4.19.ebuild,
diff --git a/net-p2p/sancho-bin/files/digest-sancho-bin-0.9.4.57 b/net-p2p/sancho-bin/files/digest-sancho-bin-0.9.4.57
new file mode 100644
index 000000000000..a4cbfb073227
--- /dev/null
+++ b/net-p2p/sancho-bin/files/digest-sancho-bin-0.9.4.57
@@ -0,0 +1,3 @@
+MD5 193c75415869402888ff6172d676e44f sancho-0.9.4-57-linux-gtk.tar.bz2 5360001
+RMD160 4438631dd0f4d4f58eb33328da2a798fd1334749 sancho-0.9.4-57-linux-gtk.tar.bz2 5360001
+SHA256 438b608509bcbf29207b1a23aed59c3d410aa3dbc15fe88b956f8598a3bcc277 sancho-0.9.4-57-linux-gtk.tar.bz2 5360001
diff --git a/net-p2p/sancho-bin/sancho-bin-0.9.4.57.ebuild b/net-p2p/sancho-bin/sancho-bin-0.9.4.57.ebuild
new file mode 100644
index 000000000000..7184494ce32b
--- /dev/null
+++ b/net-p2p/sancho-bin/sancho-bin-0.9.4.57.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/sancho-bin/sancho-bin-0.9.4.57.ebuild,v 1.1 2006/06/06 21:26:57 sekretarz Exp $
+
+inherit eutils
+
+MY_P=${P/-bin/}
+MY_P=${MY_P%.*}-${MY_P##*.}
+
+DESCRIPTION="a powerful frontend for mldonkey"
+HOMEPAGE="http://sancho-gui.sourceforge.net/"
+SRC_URI="http://sancho-gui.sourceforge.net/files/${MY_P}-linux-gtk.tar.bz2"
+
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="CPL-1.0 LGPL-2.1"
+
+DEPEND="virtual/libc
+ || ( ( x11-libs/libXxf86vm
+ x11-libs/libXext
+ x11-libs/libX11
+ ) virtual/x11 )
+ >=x11-libs/gtk+-2
+ >=net-libs/linc-1.0.3
+ amd64? ( >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0 )"
+
+S="${WORKDIR}/${MY_P}-linux-gtk"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ dodir /opt/sancho
+ dodir /opt/bin
+
+ cd ${S}
+ cp -dpR sancho distrib lib ${D}/opt/sancho
+
+ exeinto /opt/sancho
+ doexe sancho-bin
+
+ exeinto /opt/bin
+ newexe ${FILESDIR}/sancho.sh sancho
+
+ dodir /etc/env.d
+ echo -e "PATH=/opt/sancho\n" > ${D}/etc/env.d/20sancho
+ make_desktop_entry sancho sancho /opt/sancho/distrib/sancho-32.xpm
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Sancho requires the presence of a p2p core, like"
+ einfo "net-p2p/mldonkey, in order to operate."
+ einfo
+}