summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-10-06 13:11:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-10-06 13:11:39 +0000
commite3221380ec3c4cc638bb8671792de51e20999e59 (patch)
tree493bcb4d985992e494551b8ced75b8e0a32d09a4 /net-p2p/mktorrent
parentRemove vdr-submenu, as that plugin only supported already removed vdr-1.4. (diff)
downloadgentoo-2-e3221380ec3c4cc638bb8671792de51e20999e59.tar.gz
gentoo-2-e3221380ec3c4cc638bb8671792de51e20999e59.tar.bz2
gentoo-2-e3221380ec3c4cc638bb8671792de51e20999e59.zip
Rename invalid USE flag "openssl" to "ssl".
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/mktorrent')
-rw-r--r--net-p2p/mktorrent/ChangeLog6
-rw-r--r--net-p2p/mktorrent/metadata.xml1
-rw-r--r--net-p2p/mktorrent/mktorrent-0.7.ebuild34
-rw-r--r--net-p2p/mktorrent/mktorrent-1.0.ebuild12
4 files changed, 11 insertions, 42 deletions
diff --git a/net-p2p/mktorrent/ChangeLog b/net-p2p/mktorrent/ChangeLog
index 223ee4652e78..581c3772cbea 100644
--- a/net-p2p/mktorrent/ChangeLog
+++ b/net-p2p/mktorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/mktorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/ChangeLog,v 1.7 2010/04/20 21:08:47 sochotnicky Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/ChangeLog,v 1.8 2010/10/06 13:11:39 ssuominen Exp $
+
+ 06 Oct 2010; Samuli Suominen <ssuominen@gentoo.org> -mktorrent-0.7.ebuild,
+ mktorrent-1.0.ebuild, metadata.xml:
+ Rename invalid USE flag "openssl" to "ssl".
*mktorrent-1.0 (20 Apr 2010)
diff --git a/net-p2p/mktorrent/metadata.xml b/net-p2p/mktorrent/metadata.xml
index f4ec5e826b1e..13c9d77da193 100644
--- a/net-p2p/mktorrent/metadata.xml
+++ b/net-p2p/mktorrent/metadata.xml
@@ -3,7 +3,6 @@
<pkgmetadata>
<herd>net-p2p</herd>
<use>
- <flag name='openssl'>Use OpenSSL for md5 and sha1 support</flag>
<flag name='largefile'>Enable largefile support on 32 bit systems</flag>
</use>
</pkgmetadata>
diff --git a/net-p2p/mktorrent/mktorrent-0.7.ebuild b/net-p2p/mktorrent/mktorrent-0.7.ebuild
deleted file mode 100644
index 494f1bdbdf2b..000000000000
--- a/net-p2p/mktorrent/mktorrent-0.7.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/mktorrent-0.7.ebuild,v 1.1 2009/08/17 18:19:01 rbu Exp $
-
-EAPI=1
-inherit toolchain-funcs
-
-DESCRIPTION="Simple command line utility to create BitTorrent metainfo files"
-HOMEPAGE="http://mktorrent.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="threads +largefile +openssl debug"
-
-RDEPEND="openssl? ( dev-libs/openssl )"
-DEPEND="${RDEPEND}"
-
-src_compile() {
- tc-export CC
- MAKEPARAM="USE_LONG_OPTIONS=1 DONT_STRIP=1"
- use debug && MAKEPARAM="${MAKEPARAM} DEBUG=1"
- use largefile && MAKEPARAM="${MAKEPARAM} USE_LARGE_FILES=1"
- use openssl && MAKEPARAM="${MAKEPARAM} USE_OPENSSL=1"
- use threads && MAKEPARAM="${MAKEPARAM} USE_PTHREADS=1"
-
- emake ${MAKEPARAM} || die "emake failed."
-}
-
-src_install() {
- dobin ${PN}
- dodoc README
-}
diff --git a/net-p2p/mktorrent/mktorrent-1.0.ebuild b/net-p2p/mktorrent/mktorrent-1.0.ebuild
index 49d35f4bc40a..dc6fbe2fdd3f 100644
--- a/net-p2p/mktorrent/mktorrent-1.0.ebuild
+++ b/net-p2p/mktorrent/mktorrent-1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/mktorrent-1.0.ebuild,v 1.2 2010/04/20 21:16:21 sochotnicky Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/mktorrent-1.0.ebuild,v 1.3 2010/10/06 13:11:39 ssuominen Exp $
EAPI=1
inherit toolchain-funcs
@@ -12,9 +12,9 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="threads +largefile +openssl debug"
+IUSE="threads +largefile +ssl debug"
-RDEPEND="openssl? ( dev-libs/openssl )"
+RDEPEND="ssl? ( dev-libs/openssl )"
DEPEND="${RDEPEND}"
src_compile() {
@@ -22,13 +22,13 @@ src_compile() {
MAKEPARAM="USE_LONG_OPTIONS=1"
use debug && MAKEPARAM="${MAKEPARAM} DEBUG=1"
use largefile && MAKEPARAM="${MAKEPARAM} USE_LARGE_FILES=1"
- use openssl && MAKEPARAM="${MAKEPARAM} USE_OPENSSL=1"
+ use ssl && MAKEPARAM="${MAKEPARAM} USE_OPENSSL=1"
use threads && MAKEPARAM="${MAKEPARAM} USE_PTHREADS=1"
emake ${MAKEPARAM} || die "emake failed."
}
src_install() {
- dobin ${PN}
+ dobin ${PN} || die
dodoc README
}