summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-07-14 20:28:07 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-07-14 20:28:07 +0000
commit669570ffd4fb4ca88b2a126f8866918605662dc6 (patch)
tree9ca2b418ac504bc2740e3d74fd937e3f65de5a15 /net-p2p/gift
parentMany changes to update CVS and real versions of gift and gift-fasttrack (diff)
downloadgentoo-2-669570ffd4fb4ca88b2a126f8866918605662dc6.tar.gz
gentoo-2-669570ffd4fb4ca88b2a126f8866918605662dc6.tar.bz2
gentoo-2-669570ffd4fb4ca88b2a126f8866918605662dc6.zip
Many changes to update CVS and real versions of gift and gift-fasttrack
Diffstat (limited to 'net-p2p/gift')
-rw-r--r--net-p2p/gift/ChangeLog9
-rw-r--r--net-p2p/gift/Manifest4
-rw-r--r--net-p2p/gift/files/digest-gift-0.11.11
-rw-r--r--net-p2p/gift/gift-0.11.1.ebuild49
4 files changed, 61 insertions, 2 deletions
diff --git a/net-p2p/gift/ChangeLog b/net-p2p/gift/ChangeLog
new file mode 100644
index 000000000000..71cbad719f53
--- /dev/null
+++ b/net-p2p/gift/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-p2p/gift
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift/ChangeLog,v 1.31 2003/07/14 20:27:57 lostlogic Exp $
+
+*gift-cvs-0.11.1 (14 Jul 2003) Brandon Low <lostlogic@gentoo.org>
+
+ 18 Nov 2003; Brandon Low <lostlogic@gentoo.org>; gift-cvs-0.11.1.ebuild:
+ Initial import of a release giFT version
+
diff --git a/net-p2p/gift/Manifest b/net-p2p/gift/Manifest
index b6d85df66dc9..96ff7b70d87c 100644
--- a/net-p2p/gift/Manifest
+++ b/net-p2p/gift/Manifest
@@ -1,3 +1,3 @@
-MD5 edef39b31c398ef3841c7aba2ecc5d60 gift-0.11.1.ebuild 1303
-MD5 26cd07b04c3caac0155451b6c2ae1aef ChangeLog 397
+MD5 fa48fb1f813b0e053c9755b091af334d gift-0.11.1.ebuild 1314
+MD5 6c1c290f3e25b197dae00921ebf31834 ChangeLog 396
MD5 93526e524a41a4a69c2bce58826b062e files/digest-gift-0.11.1 64
diff --git a/net-p2p/gift/files/digest-gift-0.11.1 b/net-p2p/gift/files/digest-gift-0.11.1
new file mode 100644
index 000000000000..49893093ab7c
--- /dev/null
+++ b/net-p2p/gift/files/digest-gift-0.11.1
@@ -0,0 +1 @@
+MD5 84a03d803abd0f93634f588e37340d6f giFT-0.11.1.tar.bz2 519631
diff --git a/net-p2p/gift/gift-0.11.1.ebuild b/net-p2p/gift/gift-0.11.1.ebuild
new file mode 100644
index 000000000000..7e693f12a3cd
--- /dev/null
+++ b/net-p2p/gift/gift-0.11.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift/gift-0.11.1.ebuild,v 1.1 2003/07/14 20:27:57 lostlogic Exp $
+
+DESCRIPTION="A OpenFT, Gnutella and FastTrack p2p network client"
+HOMEPAGE="http://gift.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P/ft/FT}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha"
+
+DEPENDS="virtual/glibc
+ !net-p2p/gift-cvs
+ >=sys-apps/sed-4
+ >=sys-libs/zlib-1.1.4"
+
+inherit debug flag-o-matic
+
+strip-flags
+
+S=${WORKDIR}/${P/ft/FT}
+
+src_compile() {
+
+ econf --enable-gnutella || die "Configure"
+# ./autogen.sh --prefix=/usr --enable-gnutella --host=${CHOST} || die "Bootstrap configure failed"
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die "Make failed"
+
+}
+
+src_install() {
+
+ einstall giftconfdir=${D}/etc/giFT \
+ plugindir=${D}/usr/lib/giFT \
+ giftdatadir=${D}/usr/share/giFT \
+ giftperldir=${D}/usr/bin \
+ libgiftincdir=${D}/usr/include/libgift || die "Install failed"
+
+ # Fix the giFT-setup executable.
+ cd ${D}/usr/bin
+ sed -i -e 's:$prefix/etc/giFT/:/etc/giFT/:' giFT-setup
+
+}
+
+pkg_postinst() {
+ einfo "First of all you need to run giFT-setup with your normal"
+ einfo "user account to create the giFT configuration files."
+}
+