summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-08-16 23:12:24 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-08-16 23:12:24 +0000
commit1f8c928dd9362e8f097bc7aee8ef2625a6abe8ac (patch)
tree9272d147fe04af2fe135d09e4fa994194283e236 /net-p2p/gift-fasttrack/gift-fasttrack-0.8.3.ebuild
parentBump (diff)
downloadgentoo-2-1f8c928dd9362e8f097bc7aee8ef2625a6abe8ac.tar.gz
gentoo-2-1f8c928dd9362e8f097bc7aee8ef2625a6abe8ac.tar.bz2
gentoo-2-1f8c928dd9362e8f097bc7aee8ef2625a6abe8ac.zip
Bump
Diffstat (limited to 'net-p2p/gift-fasttrack/gift-fasttrack-0.8.3.ebuild')
-rw-r--r--net-p2p/gift-fasttrack/gift-fasttrack-0.8.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-p2p/gift-fasttrack/gift-fasttrack-0.8.3.ebuild b/net-p2p/gift-fasttrack/gift-fasttrack-0.8.3.ebuild
new file mode 100644
index 000000000000..410dfba59da6
--- /dev/null
+++ b/net-p2p/gift-fasttrack/gift-fasttrack-0.8.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-fasttrack/gift-fasttrack-0.8.3.ebuild,v 1.1 2003/08/16 23:12:19 lostlogic Exp $
+
+DESCRIPTION="FastTrack Plugin for giFT"
+HOMEPAGE="https://developer.berlios.de/projects/gift-fasttrack/"
+SRC_URI="http://download.berlios.de/${PN}/giFT-FastTrack-${PV}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+DEPEND="virtual/glibc
+ !net-p2p/gift-fasttrack-cvs
+ >=net-p2p/gift-0.11.1
+ >=sys-apps/sed-4
+ >=sys-libs/zlib-1.1.4"
+
+S=${WORKDIR}/${P/gift-fasttrack/giFT-FastTrack}
+
+src_compile() {
+# cp /usr/share/libtool/ltmain.sh .
+# ./autogen.sh --prefix=/usr --host=${CHOST} || die "FastTrack configure failed"
+ econf || dir "FastTrack plugin failed to configure"
+ emake || die "FastTrack plugin failed to build"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || "FastTrack plugin failed to install"
+
+}
+
+pkg_postinst() {
+ einfo "To run giFT with FastTrack support, run:"
+ einfo "giFT -p /usr/lib/giFT/libFastTrack.so"
+ echo
+ einfo "Alternatively you can add the following line to"
+ einfo "your ~/.giFT/gift.conf configuration file:"
+ einfo "plugins = OpenFT:FastTrack"
+}
+