summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2012-08-02 19:33:27 +0000
committerThomas Sachau <tommy@gentoo.org>2012-08-02 19:33:27 +0000
commit82ff16fc9c0cf0420fca87a5b9ae2d1b905a39bb (patch)
tree5290611225ea1a25dc72478c851a9c843e21f042 /net-p2p/fms
parentamd64/x86 stable (diff)
downloadgentoo-2-82ff16fc9c0cf0420fca87a5b9ae2d1b905a39bb.tar.gz
gentoo-2-82ff16fc9c0cf0420fca87a5b9ae2d1b905a39bb.tar.bz2
gentoo-2-82ff16fc9c0cf0420fca87a5b9ae2d1b905a39bb.zip
Version bump
(Portage version: 2.2.0_alpha116-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/fms')
-rw-r--r--net-p2p/fms/ChangeLog7
-rw-r--r--net-p2p/fms/fms-0.3.69.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/net-p2p/fms/ChangeLog b/net-p2p/fms/ChangeLog
index f4cca0b692da..504651124b7c 100644
--- a/net-p2p/fms/ChangeLog
+++ b/net-p2p/fms/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/fms
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/fms/ChangeLog,v 1.29 2012/04/12 13:57:49 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/fms/ChangeLog,v 1.30 2012/08/02 19:33:27 tommy Exp $
+
+*fms-0.3.69 (02 Aug 2012)
+
+ 02 Aug 2012; Thomas Sachau (Tommy[D]) <tommy@gentoo.org> +fms-0.3.69.ebuild:
+ Version bump
*fms-0.3.67 (12 Apr 2012)
diff --git a/net-p2p/fms/fms-0.3.69.ebuild b/net-p2p/fms/fms-0.3.69.ebuild
new file mode 100644
index 000000000000..4543a365ec99
--- /dev/null
+++ b/net-p2p/fms/fms-0.3.69.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/fms/fms-0.3.69.ebuild,v 1.1 2012/08/02 19:33:27 tommy Exp $
+
+EAPI="2"
+
+inherit eutils cmake-utils user
+
+DESCRIPTION="A spam-resistant message board application for Freenet"
+HOMEPAGE="http://freenetproject.org/tools.html"
+SRC_URI="mirror://gentoo/${PN}-src-${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="frost"
+
+RDEPEND="virtual/libiconv
+ frost? ( net-libs/polarssl )
+ >=dev-libs/poco-1.4.3_p1
+ >=dev-db/sqlite-3.6.15"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ enewgroup freenet
+ enewuser freenet -1 -1 /var/freenet freenet
+}
+
+src_prepare() {
+ edos2unix src/http/pages/showfilepage.cpp
+ epatch "${FILESDIR}"/${PN}-use-system-libs2.patch
+}
+
+src_configure() {
+ local mycmakeargs="-DI_HAVE_READ_THE_README=ON \
+ -DUSE_BUNDLED_SQLITE=OFF \
+ -DDO_CHARSET_CONVERSION=ON \
+ $(cmake-utils_use frost FROST_SUPPORT)"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ insinto /var/freenet/fms
+ dobin "${CMAKE_BUILD_DIR}"/fms || die
+ doins *.htm || die "doinstall failed"
+ doins -r fonts images styles translations || die
+ fperms -R o-rwx /var/freenet/fms/ /usr/bin/fms
+ fowners -R freenet:freenet /var/freenet/fms/ /usr/bin/fms
+ doinitd "${FILESDIR}/fms" || die "installing init.d file failed"
+ dodoc readme.txt || die "installing doc failed"
+}
+
+pkg_postinst() {
+ if ! has_version 'net-p2p/freenet' ; then
+ ewarn "FMS needs a freenet node to up-/download #ssages."
+ ewarn "Please make sure to have a node you can connect to"
+ ewarn "or install net-p2p/freenet to get FMS working."
+ fi
+ elog "By default, the FMS NNTP server will listen on port 1119,"
+ elog "and the web configuration interface will be running at"
+ elog "http://localhost:8080. For more information, read"
+ elog "${ROOT}usr/share/doc/${PF}/readme.txt.bz2"
+ if use frost; then
+ elog " "
+ elog "You need to enable frost on the config page"
+ elog "and restart fms for frost support."
+ fi
+}