summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-03-10 06:43:41 +0000
committerPeter Volkov <pva@gentoo.org>2011-03-10 06:43:41 +0000
commitc81e6ee779de5fbfebe16ac07bda732f5dce4377 (patch)
tree7134e480873caa73aaaf6bb2741b7cc173f51e75 /net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild
parentVersion bump. Update to EAPI 3. (diff)
downloadgentoo-2-c81e6ee779de5fbfebe16ac07bda732f5dce4377.tar.gz
gentoo-2-c81e6ee779de5fbfebe16ac07bda732f5dce4377.tar.bz2
gentoo-2-c81e6ee779de5fbfebe16ac07bda732f5dce4377.zip
Sync 9999 with 2.2.1.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild')
-rw-r--r--net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild30
1 files changed, 21 insertions, 9 deletions
diff --git a/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild b/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild
index d2439fe8e9f1..0899b1714481 100644
--- a/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild
+++ b/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild
@@ -1,20 +1,31 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild,v 1.18 2011/01/19 13:02:20 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild,v 1.19 2011/03/10 06:43:41 pva Exp $
-EAPI="2"
+EAPI="3"
LANGS="be bg cs en es fr hu pl ru sk sr uk"
-inherit qt4-r2 cmake-utils git
+
+[[ ${PV} = *9999* ]] && VCS_ECLASS="git" || VCS_ECLASS=""
+inherit cmake-utils ${VCS_ECLASS}
DESCRIPTION="Qt4 based client for DirectConnect and ADC protocols, based on DC++ library"
HOMEPAGE="http://eiskaltdc.googlecode.com/"
-EGIT_REPO_URI="git://github.com/negativ/${PN}.git"
LICENSE="GPL-2 GPL-3"
SLOT="0"
-KEYWORDS=""
-IUSE="daemon dbus +emoticons examples -gnome -gtk -javascript libnotify lua +qt4 pcre sounds spell sqlite upnp xmlrpc"
+IUSE="cli daemon dbus +emoticons examples -gnome -gtk -javascript libnotify lua +qt4 pcre sound spell sqlite upnp"
+for x in ${LANGS}; do
+ IUSE="${IUSE} linguas_${x}"
+done
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="http://${PN/pp/}.googlecode.com/files/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+else
+ EGIT_REPO_URI="git://github.com/negativ/${PN}.git"
+ KEYWORDS=""
+fi
RDEPEND="
app-arch/bzip2
@@ -22,7 +33,7 @@ RDEPEND="
>=dev-libs/openssl-0.9.8
virtual/libiconv
sys-devel/gettext
- daemon? ( xmlrpc? ( dev-libs/xmlrpc-c[abyss,cxx,curl] ) )
+ cli? ( sys-libs/readline )
lua? ( >=dev-lang/lua-5.1 )
upnp? ( net-libs/miniupnpc )
gtk? (
@@ -74,9 +85,10 @@ src_configure() {
"$(cmake-utils_use examples WITH_EXAMPLES)"
"$(cmake-utils_use lua WITH_LUASCRIPTS)"
"$(cmake-utils_use pcre PERL_REGEX)"
- "$(cmake-utils_use sounds WITH_SOUNDS)"
+ "$(cmake-utils_use sound WITH_SOUNDS)"
+ "$(cmake-utils_use cli CLI_DAEMON)"
"$(cmake-utils_use daemon NO_UI_DAEMON)"
- "$(cmake-utils_use xmlrpc XMLRPC_DAEMON)"
+ -DXMLRPC_DAEMON=OFF
-Dlinguas="${langs}"
)
cmake-utils_src_configure