summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2005-08-24 13:21:40 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2005-08-24 13:21:40 +0000
commitf6443a6793d6b790b10d9a6e68756f9f4afa77b2 (patch)
treebed321b05c2d8e7636838dacaeecfcd46cee5748 /net-p2p/bittorrent
parentQA -added IUSE (diff)
downloadgentoo-2-f6443a6793d6b790b10d9a6e68756f9f4afa77b2.tar.gz
gentoo-2-f6443a6793d6b790b10d9a6e68756f9f4afa77b2.tar.bz2
gentoo-2-f6443a6793d6b790b10d9a6e68756f9f4afa77b2.zip
Version bump, bug #103566
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-p2p/bittorrent')
-rw-r--r--net-p2p/bittorrent/ChangeLog7
-rw-r--r--net-p2p/bittorrent/bittorrent-4.1.4.ebuild83
-rw-r--r--net-p2p/bittorrent/files/digest-bittorrent-4.1.41
3 files changed, 90 insertions, 1 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index 2fb96d0cc151..03a788b76c4f 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.53 2005/08/24 12:59:41 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.54 2005/08/24 13:21:40 sekretarz Exp $
+
+*bittorrent-4.1.4 (24 Aug 2005)
+
+ 24 Aug 2005; <sekretarz@gentoo.org> +bittorrent-4.1.4.ebuild:
+ Version bump, bug #103566
*bittorrent-4.0.4 (24 Aug 2005)
diff --git a/net-p2p/bittorrent/bittorrent-4.1.4.ebuild b/net-p2p/bittorrent/bittorrent-4.1.4.ebuild
new file mode 100644
index 000000000000..353d61dbeb8f
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-4.1.4.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-4.1.4.ebuild,v 1.1 2005/08/24 13:21:40 sekretarz Exp $
+
+inherit distutils fdo-mime
+
+MY_P="${P/bittorrent/BitTorrent}"
+#MY_P="${MY_P/}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="tool for distributing files via a distributed network of nodes"
+HOMEPAGE="http://www.bittorrent.com/"
+SRC_URI="http://www.bittorrent.com/dl/${MY_P}.tar.gz"
+
+LICENSE="BitTorrent"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE="X"
+
+RDEPEND="X? (
+ >=x11-libs/gtk+-2.4
+ >=dev-python/pygtk-2.4
+ )
+ >=dev-lang/python-2.3
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ app-arch/gzip
+ >=sys-apps/sed-4.0.5
+ dev-python/dnspython"
+PROVIDE="virtual/bittorrent"
+
+DOCS="credits.txt"
+PYTHON_MODNAME="BitTorrent"
+
+src_install() {
+ distutils_src_install
+ if ! use X; then
+ rm ${D}/usr/bin/*gui.py
+ fi
+ dohtml redirdonate.html
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+
+ mv ${D}/usr/share/doc/${MY_P}/* ${D}/usr/share/doc/${P}/
+ rm -fr ${D}/usr/share/doc/${MY_P}
+
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ fi
+
+ if use X ; then
+ cp ${D}/usr/share/pixmaps/${MY_P}/bittorrent.ico ${D}/usr/share/pixmaps/
+ dodir /usr/share/applications
+ insinto /usr/share/applications
+ doins ${FILESDIR}/btdownloadgui.desktop
+ fi
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/bttrack.conf bttrack
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/bttrack.rc bttrack
+}
+
+pkg_postinst() {
+ einfo "BitTorrent has changed to the BitTorrent Open Source License"
+ einfo ">> http://www.bittorrent.com/license/"
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+}
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-4.1.4 b/net-p2p/bittorrent/files/digest-bittorrent-4.1.4
new file mode 100644
index 000000000000..3e2c644b51e5
--- /dev/null
+++ b/net-p2p/bittorrent/files/digest-bittorrent-4.1.4
@@ -0,0 +1 @@
+MD5 1d0f85eb5cd4ac219853e2e6709f5847 BitTorrent-4.1.4.tar.gz 2016856