summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-06-26 03:06:46 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-06-26 03:06:46 +0000
commit24765f8e0c1f4c0535b7c87033061e7c48b3a265 (patch)
treec94a8bcec803859068576e2de9c9eb954002f108 /net-p2p/bitcoin-qt
parentVersion bump (diff)
downloadgentoo-2-24765f8e0c1f4c0535b7c87033061e7c48b3a265.tar.gz
gentoo-2-24765f8e0c1f4c0535b7c87033061e7c48b3a265.tar.bz2
gentoo-2-24765f8e0c1f4c0535b7c87033061e7c48b3a265.zip
Version bump
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/bitcoin-qt')
-rw-r--r--net-p2p/bitcoin-qt/ChangeLog6
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.6.3.ebuild116
2 files changed, 121 insertions, 1 deletions
diff --git a/net-p2p/bitcoin-qt/ChangeLog b/net-p2p/bitcoin-qt/ChangeLog
index 47d4fc470861..f681f01d38e3 100644
--- a/net-p2p/bitcoin-qt/ChangeLog
+++ b/net-p2p/bitcoin-qt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/bitcoin-qt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/ChangeLog,v 1.32 2012/06/26 02:47:27 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/ChangeLog,v 1.33 2012/06/26 03:06:46 blueness Exp $
+
+ 26 Jun 2012; Anthony G. Basile <blueness@gentoo.org>
+ +bitcoin-qt-0.6.3.ebuild:
+ Version bump
*bitcoin-qt-0.6.3 (26 Jun 2012)
*bitcoin-qt-0.6.0.9_rc1 (26 Jun 2012)
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.6.3.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.6.3.ebuild
new file mode 100644
index 000000000000..5b1d8b3af4fb
--- /dev/null
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.6.3.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-0.6.3.ebuild,v 1.1 2012/06/26 03:06:46 blueness Exp $
+
+EAPI=4
+
+DB_VER="4.8"
+
+LANGS="ca_ES cs da de en es es_CL et eu_ES fa fa_IR fi fr_CA fr_FR he hr hu it lt nb nl pl pt_BR ro_RO ru sk sr sv tr uk zh_CN zh_TW"
+inherit db-use eutils qt4-r2 versionator
+
+DESCRIPTION="An end-user Qt4 GUI for the Bitcoin crypto-currency"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="https://nodeload.github.com/bitcoin/bitcoin/tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
+ eligius? ( http://luke.dashjr.org/programs/bitcoin/files/bitcoind/eligius/sendfee/0.6.1-eligius_sendfee.patch.xz )
+"
+
+LICENSE="MIT ISC GPL-3 md2k7-asyouwish LGPL-2.1 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="$IUSE 1stclassmsg dbus +eligius +qrcode upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0
+ dev-libs/openssl[-bindist]
+ qrcode? (
+ media-gfx/qrencode
+ )
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+ x11-libs/qt-gui
+ dbus? (
+ x11-libs/qt-dbus
+ )
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+DOCS="doc/README"
+
+S="${WORKDIR}/bitcoin-bitcoin-bbe1084"
+
+src_prepare() {
+ cd src || die
+ use eligius && epatch "${WORKDIR}/0.6.1-eligius_sendfee.patch"
+
+ local filt= yeslang= nolang=
+
+ for lan in $LANGS; do
+ if [ ! -e qt/locale/bitcoin_$lan.ts ]; then
+ ewarn "Language '$lan' no longer supported. Ebuild needs update."
+ fi
+ done
+
+ for ts in $(ls qt/locale/*.ts)
+ do
+ x="${ts/*bitcoin_/}"
+ x="${x/.ts/}"
+ if ! use "linguas_$x"; then
+ nolang="$nolang $x"
+ rm "$ts"
+ filt="$filt\\|$x"
+ else
+ yeslang="$yeslang $x"
+ fi
+ done
+ filt="bitcoin_\\(${filt:2}\\)\\.qm"
+ sed "/${filt}/d" -i 'qt/bitcoin.qrc'
+ einfo "Languages -- Enabled:$yeslang -- Disabled:$nolang"
+}
+
+src_configure() {
+ OPTS=()
+ local BOOST_PKG BOOST_VER
+
+ use dbus && OPTS+=("USE_DBUS=1")
+ if use upnp; then
+ OPTS+=("USE_UPNP=1")
+ else
+ OPTS+=("USE_UPNP=-")
+ fi
+ use qrcode && OPTS+=("USE_QRCODE=1")
+ use 1stclassmsg && OPTS+=("FIRST_CLASS_MESSAGING=1")
+
+ OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
+ OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
+
+ BOOST_PKG="$(best_version 'dev-libs/boost')"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ OPTS+=("BOOST_INCLUDE_PATH=/usr/include/boost-${BOOST_VER}")
+ OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
+
+ eqmake4 "${PN}.pro" "${OPTS[@]}"
+}
+
+src_compile() {
+ emake
+}
+
+src_test() {
+ cd src || die
+ emake -f makefile.unix "${OPTS[@]}" test_bitcoin
+ ./test_bitcoin || die 'Tests failed'
+}
+
+src_install() {
+ qt4-r2_src_install
+ dobin ${PN}
+ insinto /usr/share/pixmaps
+ newins "share/pixmaps/bitcoin.ico" "${PN}.ico"
+ make_desktop_entry ${PN} "Bitcoin-Qt" "/usr/share/pixmaps/${PN}.ico" "Network;P2P"
+}