summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2006-02-12 11:36:01 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2006-02-12 11:36:01 +0000
commitd168116fdd8a3ee7c0dd3dfdf293f782f3c2aa17 (patch)
tree4112d7b577dc0891d6d4b165d4947713e445dc17 /net-p2p/azureus/azureus-2.3.0.6-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-d168116fdd8a3ee7c0dd3dfdf293f782f3c2aa17.tar.gz
gentoo-2-d168116fdd8a3ee7c0dd3dfdf293f782f3c2aa17.tar.bz2
gentoo-2-d168116fdd8a3ee7c0dd3dfdf293f782f3c2aa17.zip
Fixed bug #119400 so now azureus won\'t fail on x86 machines with small amounts of memory.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'net-p2p/azureus/azureus-2.3.0.6-r1.ebuild')
-rw-r--r--net-p2p/azureus/azureus-2.3.0.6-r1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/net-p2p/azureus/azureus-2.3.0.6-r1.ebuild b/net-p2p/azureus/azureus-2.3.0.6-r1.ebuild
index 022a1c2c6ee3..b5fcbc9fd503 100644
--- a/net-p2p/azureus/azureus-2.3.0.6-r1.ebuild
+++ b/net-p2p/azureus/azureus-2.3.0.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/azureus-2.3.0.6-r1.ebuild,v 1.1 2006/01/02 21:24:54 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/azureus-2.3.0.6-r1.ebuild,v 1.2 2006/02/12 11:36:01 betelgeuse Exp $
inherit eutils java-pkg
@@ -58,7 +58,13 @@ src_compile() {
fi
# Fails to build on amd64 without this
- ANT_OPTS="${ANT_OPTS} -Xmx1g" \
+ # Globally enabling this makes x86 machines with
+ # little memory fail...
+ if use amd64; then
+ ANT_OPTS="${ANT_OPTS} -Xmx248m"
+ fi
+
+ ANT_OPTS="${ANT_OPTS}" \
ant -q -q ${ant_extra_opts} jar \
|| die "ant build failed"
}